Gentoo: GTK+ 2, GdkPixbuf Multiple XPM decoding vulnerabilities
Posted by Benjamin D. Thomas   
Gentoo The GdkPixbuf library, that is also included in GTK+ 2, contains vulnerabilities that could lead to a Denial of Service or the execution of arbitrary code.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200511-14
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: GTK+ 2, GdkPixbuf: Multiple XPM decoding vulnerabilities
      Date: November 16, 2005
      Bugs: #112608
        ID: 200511-14

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

The GdkPixbuf library, that is also included in GTK+ 2, contains
vulnerabilities that could lead to a Denial of Service or the
execution of arbitrary code.

Background
==========

GTK+ (the GIMP Toolkit) is a toolkit for creating graphical user
interfaces. The GdkPixbuf library provides facilities for image
handling. It is available as a standalone library and also packaged
with GTK+ 2.

Affected packages
=================

    -------------------------------------------------------------------
     Package                /   Vulnerable   /              Unaffected
    -------------------------------------------------------------------
  1  x11-libs/gtk+              < 2.8.6-r1                 >= 2.8.6-r1
                                                         *>= 2.6.10-r1
                                                                 < 2.0
  2  media-libs/gdk-pixbuf      < 0.22.0-r5               >= 0.22.0-r5
    -------------------------------------------------------------------
     2 affected packages on all of their supported architectures.
    -------------------------------------------------------------------

Description
===========

iDEFENSE reported a possible heap overflow in the XPM loader
(CVE-2005-3186). Upon further inspection, Ludwig Nussel discovered two
additional issues in the XPM processing functions : an integer overflow
(CVE-2005-2976) that affects only gdk-pixbuf, and an infinite loop
(CVE-2005-2975).

Impact
======

Using a specially crafted XPM image an attacker could cause an affected
application to enter an infinite loop or trigger the overflows,
potentially allowing the execution of arbitrary code.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All GTK+ 2 users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose x11-libs/gtk+

All GdkPixbuf users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=media-libs/gdk-pixbuf-0.22.0-r5"

References
==========

  [ 1 ] CVE-2005-2975
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2975
  [ 2 ] CVE-2005-2976
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2976
  [ 3 ] CVE-2005-3186
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3186
  [ 4 ] iDefense Security Advisory 11.15.05

http://www.idefense.com/application/poi/display?id=339&type=vulnerabilities

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200511-14.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0