Gentoo: cURL NTLM username stack overflow
Posted by Benjamin D. Thomas   
Gentoo cURL is vulnerable to a buffer overflow which could lead to the execution of arbitrary code.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200510-19
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: cURL: NTLM username stack overflow
      Date: October 22, 2005
      Bugs: #109097
        ID: 200510-19

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

cURL is vulnerable to a buffer overflow which could lead to the
execution of arbitrary code.

Background
==========

cURL is a command line tool and library for transferring files via many
different protocols. It supports NTLM authentication to retrieve files
from Windows-based systems.

Affected packages
=================

    -------------------------------------------------------------------
     Package        /  Vulnerable  /                        Unaffected
    -------------------------------------------------------------------
  1  net-misc/curl      < 7.15.0                             >= 7.15.0

Description
===========

iDEFENSE reported that insufficient bounds checking on a memcpy() of
the supplied NTLM username can result in a stack overflow.

Impact
======

A remote attacker could setup a malicious server and entice an user to
connect to it using a cURL client, potentially leading to the execution
of arbitrary code with the permissions of the user running cURL.

Workaround
==========

Disable NTLM authentication by not using the --anyauth or --ntlm
options when using cURL (the command line version). Workarounds for
programs that use the cURL library depend on the configuration options
presented by those programs.

Resolution
==========

All cURL users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=net-misc/curl-7.15.0"

References
==========

  [ 1 ] CVE-2005-3185
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3185
  [ 2 ] iDefense Security Advisory 10.13.05

http://www.idefense.com/application/poi/display?id=322&type=vulnerabilities

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200510-19.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0