Gentoo: Mailutils Format string vulnerability in imap4d
Posted by Benjamin D. Thomas   
Gentoo The imap4d server contains a vulnerability allowing an authenticated user to execute arbitrary code with the privileges of the imap4d process.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200509-10
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: Mailutils: Format string vulnerability in imap4d
      Date: September 17, 2005
      Bugs: #105458
        ID: 200509-10

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

The imap4d server contains a vulnerability allowing an authenticated
user to execute arbitrary code with the privileges of the imap4d
process.

Background
==========

The GNU Mailutils are a collection of mail-related utilities, including
an IMAP4 server (imap4d).

Affected packages
=================

    -------------------------------------------------------------------
     Package             /  Vulnerable  /                   Unaffected
    -------------------------------------------------------------------
  1  net-mail/mailutils      < 0.6-r2                        >= 0.6-r2

Description
===========

The imap4d server contains a format string bug in the handling of IMAP
SEARCH requests.

Impact
======

An authenticated IMAP user could exploit the format string error in
imap4d to execute arbitrary code as the imap4d user, which is usually
root.

Workaround
==========

There are no known workarounds at this time.

Resolution
==========

All GNU Mailutils users should upgrade to the latest available version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=net-mail/mailutils-0.6-r2"

References
==========

  [ 1 ] iDEFENSE 09.09.05 advisory

http://www.idefense.com/application/poi/display?id=303&type=vulnerabilities

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200509-10.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0