Gentoo: Xpdf, Kpdf, GPdf Denial of Service vulnerability
Posted by Benjamin D. Thomas   
Gentoo Xpdf, Kpdf and GPdf may crash as a result of a Denial of Service vulnerability.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200508-08
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Xpdf, Kpdf, GPdf: Denial of Service vulnerability
      Date: August 16, 2005
      Bugs: #99769, #100263, #100265
        ID: 200508-08

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Xpdf, Kpdf and GPdf may crash as a result of a Denial of Service
vulnerability.

Background
==========

Xpdf, Kpdf and GPdf are PDF file viewers that run under the X Window
System. Kpdf and GPdf both contain Xpdf code. Kpdf is also part of
kdegraphics.

Affected packages
=================

    -------------------------------------------------------------------
     Package               /   Vulnerable   /               Unaffected
    -------------------------------------------------------------------
  1  app-text/xpdf             < 3.00-r10                  >= 3.00-r10
  2  kde-base/kdegraphics      < 3.3.2-r3                  >= 3.3.2-r3
  3  kde-base/kpdf             < 3.4.1-r1                  >= 3.4.1-r1
  4  app-text/gpdf             < 2.10.0-r1                >= 2.10.0-r1
    -------------------------------------------------------------------
     4 affected packages on all of their supported architectures.
    -------------------------------------------------------------------

Description
===========

Xpdf, Kpdf and GPdf do not handle a broken table of embedded TrueType
fonts correctly. After detecting such a table, Xpdf, Kpdf and GPdf
attempt to reconstruct the information in it by decoding the PDF file,
which causes the generation of a huge temporary file.

Impact
======

A remote attacker may cause a Denial of Service by creating a specially
crafted PDF file, sending it to a CUPS printing system (which uses
Xpdf), or by enticing a user to open it in Xpdf, Kpdf, or GPdf.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Xpdf users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=app-text/xpdf-3.00-r10"

All GPdf users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=app-text/gpdf-2.10.0-r1"

All Kpdf users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=kde-base/kdegraphics-3.3.2-r3"

All KDE Split Ebuild Kpdf users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=kde-base/kpdf-3.4.1-r1"

References
==========

  [ 1 ] CAN-2005-2097
        http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-2097

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200508-08.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0