Greasemonkey Flaw Prompts Critical Uninstall Warning
Source: eWeek - Posted by Pax Dickinson   
Security A gaping security hole in a popular Firefox browser extension could allow malicious hackers to hijack files from a user's hard drive, developers warned Tuesday.

The vulnerability was flagged in Greasemonkey, the Firefox add-on that allows users to load custom scripts that modify Web sites on the fly.

The flaw is so serious that developers are warning users to completely uninstall Greasemonkey versions prior to 0.3.5.

Mark Pilgrim, an XML coder who helped to evangelize the extension with the free "Dive into Greasemonkey" e-book, has published working exploits to highlight the severity of the flaw.

In a series of posts to the Greasemonkey mailing list, Pilgrim warned that the published exploits are "much, much worse" than first imagined, noting that a successful attacker could hijack any world-readable file from a vulnerable computer.

Read this full article at eWeek

Only registered users can write comments.
Please login or register.

Powered by AkoComment!