Gentoo: Adobe Acrobat Reader Buffer overflow vulnerability
Posted by Benjamin D. Thomas   
Gentoo Adobe Acrobat Reader is vulnerable to a buffer overflow that could lead to remote execution of arbitrary code.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200507-09
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Adobe Acrobat Reader: Buffer overflow vulnerability
      Date: July 11, 2005
      Bugs: #98101
        ID: 200507-09

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Adobe Acrobat Reader is vulnerable to a buffer overflow that could lead
to remote execution of arbitrary code.

Background
==========

Adobe Acrobat Reader is a utility used to view PDF files.

Affected packages
=================

    -------------------------------------------------------------------
     Package            /  Vulnerable  /                    Unaffected
    -------------------------------------------------------------------
  1  app-text/acroread       <= 5.10                            >= 7.0

Description
===========

A buffer overflow has been discovered in the UnixAppOpenFilePerform()
function, which is called when Adobe Acrobat Reader tries to open a
file with the "Filespec" tag.

Impact
======

By enticing a user to open a specially crafted PDF document, a remote
attacker could exploit this vulnerability to execute arbitrary code.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

Since Adobe will most likely not update the 5.0 series of Adobe Acrobat
Reader for Linux, all users should upgrade to the latest available
version of the 7.0 series:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=app-text/acroread-7.0"

References
==========

  [ 1 ] CAN-2005-1625
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-1625
  [ 2 ] iDEFENSE Security Advisory
        http://www.idefense.com/application/poi/display?id=279&type=vulnerabilities&flashstatus=true
  [ 3 ] Adobe Security Advisory
        http://www.adobe.com/support/techdocs/329083.html

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200507-09.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0