Gentoo: PostgreSQL Multiple vulnerabilities
Posted by Benjamin D. Thomas   
Gentoo PostgreSQL is vulnerable to Denial of Service attacks and possibly allows unprivileged users to gain administrator rights.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200505-12
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: PostgreSQL: Multiple vulnerabilities
      Date: May 15, 2005
      Bugs: #91231
        ID: 200505-12

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

PostgreSQL is vulnerable to Denial of Service attacks and possibly
allows unprivileged users to gain administrator rights.

Background
==========

PostgreSQL is a SQL compliant, open source object-relational database
management system.

Affected packages
=================

    -------------------------------------------------------------------
     Package            /  Vulnerable  /                    Unaffected
    -------------------------------------------------------------------
  1  dev-db/postgresql     < 8.0.2-r1                     *>= 7.4.7-r2
                                                          *>= 8.0.1-r3
                                                           >= 8.0.2-r1

Description
===========

PostgreSQL gives public EXECUTE access to a number of character
conversion routines, but doesn't validate the given arguments
(CAN-2005-1409). It has also been reported that the contrib/tsearch2
module of PostgreSQL misdeclares the return value of some functions as
"internal" (CAN-2005-1410).

Impact
======

An attacker could call the character conversion routines with specially
setup arguments to crash the backend process of PostgreSQL or to
potentially gain administrator rights. A malicious user could also call
the misdeclared functions of the contrib/tsearch2 module, resulting in
a Denial of Service or other, yet uninvestigated, impacts.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PostgreSQL users should update to the latest available version and
follow the guide at http://www.postgresql.org/about/news.315

    # emerge --sync
    # emerge --ask --oneshot --verbose dev-db/postgresql

References
==========

  [ 1 ] CAN-2005-1409
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=2005-1409
  [ 2 ] CAN-2005-1410
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=2005-1410
  [ 3 ] PostgreSQL Announcement
        http://www.postgresql.org/about/news.315

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200505-12.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0