Gentoo: OpenMotif, LessTif New libXpm buffer overflows
Posted by Benjamin D. Thomas   
Gentoo A new vulnerability has been discovered in libXpm, which is included in OpenMotif and LessTif, that can potentially lead to remote code execution.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200503-08
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: OpenMotif, LessTif: New libXpm buffer overflows
      Date: March 04, 2005
      Bugs: #83655, #83656
        ID: 200503-08

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A new vulnerability has been discovered in libXpm, which is included in
OpenMotif and LessTif, that can potentially lead to remote code
execution.

Background
==========

LessTif is a clone of OSF/Motif, which is a standard user interface
toolkit available on Unix and Linux. OpenMotif also provides a free
version of the Motif toolkit for open source applications.

Affected packages
=================

    -------------------------------------------------------------------
     Package             /   Vulnerable   /                 Unaffected
    -------------------------------------------------------------------
  1  x11-libs/openmotif      < 2.2.3-r3                    >= 2.2.3-r3
                                                         *>= 2.1.30-r9
  2  x11-libs/lesstif        < 0.94.0-r2                  >= 0.94.0-r2
    -------------------------------------------------------------------
     2 affected packages on all of their supported architectures.
    -------------------------------------------------------------------

Description
===========

Chris Gilbert discovered potentially exploitable buffer overflow cases
in libXpm that weren't fixed in previous libXpm security advisories.

Impact
======

A carefully-crafted XPM file could crash applications making use of the
OpenMotif or LessTif toolkits, potentially allowing the execution of
arbitrary code with the privileges of the user running the application.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All OpenMotif users should upgrade to an unaffected version:

    # emerge --sync
    # emerge --ask --oneshot --verbose x11-libs/openmotif

All LessTif users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=x11-libs/lesstif-0.94.0-r2"

References
==========

  [ 1 ] CAN-2005-0605
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0605

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200503-08.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0