Gentoo: uim Privilege escalation vulnerability
Posted by Benjamin D. Thomas   
Gentoo Under certain conditions, applications linked against uim suffer from a privilege escalation vulnerability.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200502-31
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: uim: Privilege escalation vulnerability
      Date: February 28, 2005
      Bugs: #82678
        ID: 200502-31

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Under certain conditions, applications linked against uim suffer from a
privilege escalation vulnerability.

Background
==========

uim is a simple, secure and flexible input method library.

Affected packages
=================

    -------------------------------------------------------------------
     Package       /  Vulnerable  /                         Unaffected
    -------------------------------------------------------------------
  1  app-i18n/uim      < 0.4.5.1                            >= 0.4.5.1

Description
===========

Takumi Asaki discovered that uim insufficiently checks environment
variables. setuid/setgid applications linked against libuim could end
up executing arbitrary code. This vulnerability only affects
immodule-enabled Qt (if you build Qt 3.3.2 or later versions with
USE="immqt" or USE="immqt-bc").

Impact
======

A malicious local user could exploit this vulnerability to execute
arbitrary code with escalated privileges.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All uim users should upgrade to the latest available version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=app-i18n/uim-0.4.5.1"

References
==========

  [ 1 ] CAN-2005-0503
        http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0503
  [ 2 ] uim announcement
        http://lists.freedesktop.org/archives/uim/2005-February/000996.html

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200502-31.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0