Gentoo: PostgreSQL Buffer overflows in PL/PgSQL parser
Posted by Benjamin D. Thomas   
Gentoo PostgreSQL is vulnerable to several buffer overflows in the PL/PgSQL parser leading to execution of arbitrary code.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200502-19
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: PostgreSQL: Buffer overflows in PL/PgSQL parser
      Date: February 14, 2005
      Bugs: #81350
        ID: 200502-19

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

PostgreSQL is vulnerable to several buffer overflows in the PL/PgSQL
parser leading to execution of arbitrary code.

Background
==========

PostgreSQL is a SQL compliant, open source object-relational database
management system.

Affected packages
=================

    -------------------------------------------------------------------
     Package            /  Vulnerable  /                    Unaffected
    -------------------------------------------------------------------
  1  dev-db/postgresql     < 8.0.1-r1                      >= 8.0.1-r1
                                                          *>= 7.4.7-r1
                                                          *>= 7.3.9-r1

Description
===========

PostgreSQL is vulnerable to several buffer overflows in the PL/PgSQL
parser.

Impact
======

A remote attacker could send a malicious query resulting in the
execution of arbitrary code with the permissions of the user running
PostgreSQL.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PostgreSQL users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-db/postgresql-7.4.7-r1"

References
==========

  [ 1 ] CAN-2005-0247
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0247

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200502-19.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0