Gentoo: GraphicsMagick PSD decoding heap overflow
Posted by Joseph Shakespeare   
Gentoo GraphicsMagick is vulnerable to a heap overflow when decoding Photoshop Document (PSD) files, which could lead to arbitrary code execution.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200501-37
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: GraphicsMagick: PSD decoding heap overflow
      Date: January 26, 2005
      Bugs: #79336
        ID: 200501-37

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

GraphicsMagick is vulnerable to a heap overflow when decoding Photoshop
Document (PSD) files, which could lead to arbitrary code execution.

Background
==========

GraphicsMagick is a collection of tools to read, write and manipulate
images in many formats. GraphicsMagick is originally derived from
ImageMagick 5.5.2.

Affected packages
=================

    -------------------------------------------------------------------
     Package                   /  Vulnerable  /             Unaffected
    -------------------------------------------------------------------
  1  media-gfx/graphicsmagick       < 1.1.5                   >= 1.1.5

Description
===========

Andrei Nigmatulin discovered that handling a Photoshop Document (PSD)
file with more than 24 layers in ImageMagick could trigger a heap
overflow (GLSA 200501-26). GraphicsMagick is based on the same code and
therefore suffers from the same flaw.

Impact
======

An attacker could potentially design a malicious PSD image file to
cause arbitrary code execution with the permissions of the user running
GraphicsMagick.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All GraphicsMagick users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=media-gfx/graphicsmagick-1.1.5"

References
==========

  [ 1 ] CAN-2005-0005
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0005
  [ 2 ] GLSA 200501-26
        http://www.gentoo.org/security/en/glsa/glsa-200501-26.xml

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200501-37.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0