Mandrake: Updated xpdf packages fix
Posted by Joseph Shakespeare   
Mandrake A buffer overflow vulnerability was discovered in the xpdf PDF viewer, which could allow for arbitrary code execution as the user viewing a PDF file. The vulnerability exists due to insufficient bounds checking while processing a PDF file that provides malicious values in the /Encrypt /Length tag. The updated packages have been patched to prevent these problems.
 _______________________________________________________________________

                 Mandrakelinux Security Update Advisory
 _______________________________________________________________________

 Package name:           xpdf
 Advisory ID:            MDKSA-2005:017
 Date:                   January 25th, 2005

 Affected versions:	 10.0, 10.1, Corporate Server 2.1,
			 Corporate Server 3.0
 ______________________________________________________________________

 Problem Description:

 A buffer overflow vulnerability was discovered in the xpdf PDF          
 viewer, which could allow for arbitrary code execution as the user 
 viewing a PDF file. The vulnerability exists due to insufficient bounds
 checking while processing a PDF file that provides malicious values in
 the /Encrypt /Length tag.
 
 The updated packages have been patched to prevent these problems.
 _______________________________________________________________________

 References:

  http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0064
 ______________________________________________________________________

 Updated Packages:
  
 Mandrakelinux 10.0:
 8fe688c70f2d61ff8750e21f75eebeb3  10.0/RPMS/xpdf-3.00-5.4.100mdk.i586.rpm
 1990c8a678ea40233f5dc12c3a503fa2  10.0/SRPMS/xpdf-3.00-5.4.100mdk.src.rpm

 Mandrakelinux 10.0/AMD64:
 661d716961ace2071ec87bedb51811da  amd64/10.0/RPMS/xpdf-3.00-5.4.100mdk.amd64.rpm
 1990c8a678ea40233f5dc12c3a503fa2  amd64/10.0/SRPMS/xpdf-3.00-5.4.100mdk.src.rpm

 Mandrakelinux 10.1:
 5eb526adbcae9193ce09fa06724215c3  10.1/RPMS/xpdf-3.00-7.3.101mdk.i586.rpm
 5eb526adbcae9193ce09fa06724215c3  10.1/SRPMS/xpdf-3.00-7.3.101mdk.i586.rpm

 Mandrakelinux 10.1/X86_64:
 62c8956238470dde55e328c2d397e276  x86_64/10.1/RPMS/xpdf-3.00-7.3.101mdk.x86_64.rpm
 5eb526adbcae9193ce09fa06724215c3  x86_64/10.1/SRPMS/xpdf-3.00-7.3.101mdk.i586.rpm

 Corporate Server 2.1:
 e890707f2e00fd17a06ff2fb6545b5dd  corporate/2.1/RPMS/xpdf-1.01-4.8.C21mdk.i586.rpm
 b3a3a37961c14abe80eda3d170ab3550  corporate/2.1/SRPMS/xpdf-1.01-4.8.C21mdk.src.rpm

 Corporate Server 2.1/x86_64:
 2d48f20adea08eb27f25469cf66d4be8  x86_64/corporate/2.1/RPMS/xpdf-1.01-4.8.C21mdk.x86_64.rpm
 b3a3a37961c14abe80eda3d170ab3550  x86_64/corporate/2.1/SRPMS/xpdf-1.01-4.8.C21mdk.src.rpm

 Corporate Server 3.0:
 681b0e2029b8d4e468e4e94d9f76d0f7  corporate/3.0/RPMS/xpdf-3.00-5.4.C30mdk.i586.rpm
 ab09023403f50e92c11ea277e9819f8a  corporate/3.0/SRPMS/xpdf-3.00-5.4.C30mdk.src.rpm
 _______________________________________________________________________

 To upgrade automatically use MandrakeUpdate or urpmi.  The verification
 of md5 checksums and GPG signatures is performed automatically for you.

 All packages are signed by Mandrakesoft for security.  You can obtain
 the GPG public key of the Mandrakelinux Security Team by executing:

  gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

 You can view other update advisories for Mandrakelinux at:

  http://www.mandrakesoft.com/security/advisories

 If you want to report vulnerabilities, please contact

  security_linux-mandrake.com

 Type Bits/KeyID     Date       User ID
 pub  1024D/22458A98 2000-07-10 Linux Mandrake Security Team