NetBSD: cvs Heap overflow vulnerabilities
Posted by LinuxSecurity.com Team   
NetBSD CVS had heap overflow vulnerabilities which can be trigged remotely by malicious people on the net.

NetBSD Security Advisory 2004-008
		 =================================

Topic:		CVS server vulnerability

Version:	NetBSD-current:	source prior to May 21, 2004
		netBSD 1.6.2:	affected
		NetBSD 1.6.1:	affected
		NetBSD 1.6:	affected
		NetBSD-1.5.*:	not affected (does not ship with CVS)
		pkgsrc:		cvs packages prior to 1.11.16/1.12.8

Severity:	

Fixed:		NetBSD-current:		May 21, 2004
		NetBSD-2.0 branch:	May 21, 2004 (2.0 will include the fix)
		NetBSD-1.6 branch:	Jun 2, 2004 (1.6.3 will include the fix)
		pkgsrc:		cvs-1.11.16, 1.12.8 or higher corrects the issue


Abstract
========

CVS had heap overflow vulnerabilities which can be trigged remotely by
malicious people on the net.

NetBSD does not run a CVS server in the default install. Relatively few
users have reason to configure one, and only those who do are affected.


Technical Details
=================
 
http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0396


Solutions and Workarounds
=========================

If you run a CVS server:

We highly recommend you to upgrade your cvs binary to 1.11.16, or 1.12.8 or
higher.

The following instructions describe how to upgrade your cvs
binaries by updating your source tree and rebuilding and
installing a new version of cvs.

* NetBSD-current:

	Systems running NetBSD-current dated from before 2004-05-21
	should be upgraded to NetBSD-current dated 2004-05-22 or later.

	The following directories need to be updated from the
	netbsd-current CVS branch (aka HEAD):
		gnu/dist/cvs
		gnu/usr.bin/cvs

	To update from CVS, re-build, and re-install cvs:
		# cd src
		# cvs update -d -P gnu/dist/cvs gnu/usr.bin/cvs
		# cd gnu/usr.bin/cvs

		# make USETOOLS=no cleandir dependall
		# make USETOOLS=no install


* NetBSD 1.6, 1.6.1, 1.6.2:

	The binary distribution of NetBSD 1.6, 1.6.1 and 1.6.2 are vulnerable.

	Systems running NetBSD 1.6 sources dated from before
	2004-06-01 should be upgraded from NetBSD 1.6 sources dated
	2004-06-02 or later.

	Alternately, delete your cvs binaries, and update from pkgsrc.

	NetBSD 1.6.3 will include the fix.

	The following directories need to be updated from the
	netbsd-1-6 CVS branch:
		gnu/dist/cvs
		gnu/usr.bin/cvs

	To update from CVS, re-build, and re-install cvs:

		# cd src
		# cvs update -d -P -r netbsd-1-6 gnu/dist/cvs gnu/usr.bin/cvs
		# cd gnu/usr.bin/cvs

		# make USETOOLS=no cleandir dependall
		# make USETOOLS=no install

* pkgsrc:

        If your system has devel/cvs pkgsrc version 1.11.15 or lower, update
	to 1.11.16


Thanks To
=========

Matthias Scheler and Curt Sampson


Revision History
================

	2004-06-03	Initial release


More Information
================

Advisories may be updated as new information becomes available.
The most recent version of this advisory (PGP signed) can be found at 
   ftp://ftp.NetBSD.org/pub/NetBSD/security/advisories/NetBSD-SA2004-008.txt.asc

Information about NetBSD and NetBSD security can be found at 
http://www.NetBSD.org/ and  http://www.NetBSD.org/Security/.


Copyright 2004, The NetBSD Foundation, Inc.  All Rights Reserved.
Redistribution permitted only in full, unmodified form.

$NetBSD: NetBSD-SA2004-008.txt,v 1.3 2004/06/03 14:03:05 david Exp $