Mandrake: gdm multiple vulnerabilities
Posted by LinuxSecurity.com Team   
Mandrake Two vulnerabilities were discovered in gdm by Jarno Gassenbauer that would allow a local attacker to cause gdm to crash or freeze.

________________________________________________________________________

                Mandrake Linux Security Update Advisory
________________________________________________________________________

Package name:           gdm
Advisory ID:            MDKSA-2003:100
Date:                   October 16th, 2003

Affected versions:	9.1, 9.2, Corporate Server 2.1
________________________________________________________________________

Problem Description:

 Two vulnerabilities were discovered in gdm by Jarno Gassenbauer that
 would allow a local attacker to cause gdm to crash or freeze.
 
 The provided packages are patched to fix this problem.
________________________________________________________________________

References:
  
   http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2003-0793
   http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2003-0794
________________________________________________________________________

Updated Packages:
  
 Corporate Server 2.1:
 2415e6b15710985db37f26e59994f3b4  corporate/2.1/RPMS/gdm-2.4.1.6-0.4.90mdk.i586.rpm
 bd7d7a7226ced78c725e02e3566b4e69  corporate/2.1/RPMS/gdm-Xnest-2.4.1.6-0.4.90mdk.i586.rpm
 40d9f1610797b08c0983f40ae13b9238  corporate/2.1/SRPMS/gdm-2.4.1.6-0.4.90mdk.src.rpm

 Corporate Server 2.1/x86_64:
 881cda419d0219f52892a24cd8aebae8  x86_64/corporate/2.1/RPMS/gdm-2.4.1.6-0.4.90mdk.x86_64.rpm
 38ec4809a9b2a7f595198cdbe29f7e4b  x86_64/corporate/2.1/RPMS/gdm-Xnest-2.4.1.6-0.4.90mdk.x86_64.rpm
 40d9f1610797b08c0983f40ae13b9238  x86_64/corporate/2.1/SRPMS/gdm-2.4.1.6-0.4.90mdk.src.rpm

 Mandrake Linux 9.1:
 2cd716dcbf5ece067278ba90c29d0341  9.1/RPMS/gdm-2.4.1.6-0.4.91mdk.i586.rpm
 60193a5489038aa012c24b853bc7f176  9.1/RPMS/gdm-Xnest-2.4.1.6-0.4.91mdk.i586.rpm
 d1aceb0deb1a3515a02b0b66d0f381de  9.1/SRPMS/gdm-2.4.1.6-0.4.91mdk.src.rpm

 Mandrake Linux 9.1/PPC:
 491767107a03cf195c8c86df44eb704d  ppc/9.1/RPMS/gdm-2.4.1.6-0.4.91mdk.ppc.rpm
 b64a8250f0eab46f595b4ef484a783b8  ppc/9.1/RPMS/gdm-Xnest-2.4.1.6-0.4.91mdk.ppc.rpm
 d1aceb0deb1a3515a02b0b66d0f381de  ppc/9.1/SRPMS/gdm-2.4.1.6-0.4.91mdk.src.rpm

 Mandrake Linux 9.2:
 c3306d682a085cbf50af9b7498bcc945  9.2/RPMS/gdm-2.4.4.0-2.1.92mdk.i586.rpm
 0b70010cb78963062c5ab4964b82b995  9.2/RPMS/gdm-Xnest-2.4.4.0-2.1.92mdk.i586.rpm
 a5d6f00670c5bdaeb5906451714e7497  9.2/SRPMS/gdm-2.4.4.0-2.1.92mdk.src.rpm
________________________________________________________________________

Bug IDs fixed (see https://qa.mandrakesoft.com for more information):
________________________________________________________________________

To upgrade automatically, use MandrakeUpdate or urpmi.  The verification
of md5 checksums and GPG signatures is performed automatically for you.

A list of FTP mirrors can be obtained from:

   http://www.mandrakesecure.net/en/ftp.php

All packages are signed by MandrakeSoft for security.  You can obtain
the GPG public key of the Mandrake Linux Security Team by executing:

  gpg --recv-keys --keyserver www.mandrakesecure.net 0x22458A98

Please be aware that sometimes it takes the mirrors a few hours to
update.

You can view other update advisories for Mandrake Linux at:

   http://www.mandrakesecure.net/en/advisories/

MandrakeSoft has several security-related mailing list services that
anyone can subscribe to.  Information on these lists can be obtained by
visiting:

   http://www.mandrakesecure.net/en/mlist.php

If you want to report vulnerabilities, please contact

  security_linux-mandrake.com

Type Bits/KeyID     Date       User ID
pub  1024D/22458A98 2000-07-10 Linux Mandrake Security Team