Gentoo: exim buffer overflow vulnerability
Posted by LinuxSecurity.com Team   
Gentoo There's a heap overflow in all versions of exim3 and exim4 priorto version 4.21. It can be exercised by anyone who can make anSMTP connection to the exim daemon.

- - - ---------------------------------------------------------------------
GENTOO LINUX SECURITY ANNOUNCEMENT 200309-09
- - - ---------------------------------------------------------------------

          PACKAGE : exim
          SUMMARY : buffer overflow
             DATE : 2003-09-15 13:07 UTC
          EXPLOIT : remote
VERSIONS AFFECTED : =exim-4.21
              CVE : CAN-2003-0743

- - - ---------------------------------------------------------------------

quote from advisory:

"There's a heap overflow in all versions of exim3 and exim4 prior
to version 4.21.  It can be exercised by anyone who can make an
SMTP connection to the exim daemon."

read the full advisory at: 
http://marc.theaimsgroup.com/?l=vuln-dev&m=106264740820334&w=2

Altough not thought to be exploitable, users are encouraged to upgrade
exim.

SOLUTION

It is recommended that all Gentoo Linux users who are running
net-mail/exim upgrade to exim-4.21 as follows:

emerge sync
emerge exim
emerge clean

- - - ---------------------------------------------------------------------
aliz@gentoo.org - GnuPG key is available at  http://dev.gentoo.org/~aliz
raker@gentoo.org
- - - ---------------------------------------------------------------------