Gentoo: 'atari800' buffer overflow
Posted by LinuxSecurity.com Team   
Gentoo atari800 contains a buffer overflow which could be used by an attackerto gain root privileges.

- - ---------------------------------------------------------------------
GENTOO LINUX SECURITY ANNOUNCEMENT 200309-07
- - ---------------------------------------------------------------------

          PACKAGE : atari800
          SUMMARY : buffer overflow
             DATE : 2003-09-02 14:03 UTC
          EXPLOIT : local
VERSIONS AFFECTED : =atari800-1.3.0-r1
              CVE : CAN-2003-0630

- - ---------------------------------------------------------------------

atar800 contains a buffer overflow which could be used by an attacker
to gain root privileges. Altough the atari800 package in Gentoo does not
install any files suid root we encourage our users to upgrade.

SOLUTION

It is recommended that all Gentoo Linux users who are running
app-emulation/atari800 upgrade to atari800-1.3.0-r1 as follows:

emerge sync
emerge atari800
emerge clean

- - ---------------------------------------------------------------------
aliz@gentoo.org - GnuPG key is available at  http://dev.gentoo.org/~aliz
- - ---------------------------------------------------------------------