Slackware: epic4 multiple vulnerabilities
Posted by LinuxSecurity.com Team   
Slackware New EPIC4 packages are available to fix security problems found by Timo Sirainen.

[slackware-security]  EPIC4 security fixes (SSA:2003-141-01)

New EPIC4 packages are available to fix security problems found
by Timo Sirainen.  EPIC4 is an IRC (Internet Relay Chat) client.
Under certain circumstances, a malicious IRC server could cause
EPIC4 to crash, or possibly to run arbitrary code as the user
running EPIC4.

All sites running EPIC4 are advised to upgrade.

More information on the problem can be found here:

Here are the details from the Slackware 9.0 ChangeLog:
+--------------------------+
Tue May 20 20:13:09 PDT 2003
patches/packages/epic4-1.0.1-i386-3.tgz:  Patched a buffer overflow in ctcp.c.
  (* Security fix *)
+--------------------------+



WHERE TO FIND THE NEW PACKAGES:
+-----------------------------+

Updated package for Slackware 8.1: 
ftp://ftp.slackware.com/pub/slackware/slackware-8.1/patches/packages/epic4-1.0.1-i386-3.tgz

Updated package for Slackware 9.0: 
ftp://ftp.slackware.com/pub/slackware/slackware-9.0/patches/packages/epic4-1.0.1-i386-3.tgz



MD5 SIGNATURES:
+-------------+

Slackware 8.1 package:
4593af7c875770e1eadbb00b39b1de7a  epic4-1.0.1-i386-3.tgz

Slackware 9.0 package:
9b3a389255484d9a2ff7ea0e8caacbc4  epic4-1.0.1-i386-3.tgz



INSTALLATION INSTRUCTIONS:
+------------------------+

Upgrade using upgradepkg (as root):

upgradepkg epic4-1.0.1-i386-3.tgz


+-----+

Slackware Linux Security Team 
http://slackware.com/gpg-key
security@slackware.com