Gentoo: cdrtools privlege escalation vulnerability
Posted by LinuxSecurity.com Team   
Gentoo A vulnerability in cdrecord that could lead to a root compromise was discovered. cdrecord is not installed suid by default in Gentoo.

- - ---------------------------------------------------------------------
GENTOO LINUX SECURITY ANNOUNCEMENT 200305-06
- - ---------------------------------------------------------------------

          PACKAGE : cdrtools
          SUMMARY : privelige escalation
             DATE : 2003-05-17 14:07 UTC
          EXPLOIT : local
VERSIONS AFFECTED : =cdrtools-2.01_alpha14, =cdrtools-1.11.33-r1,
		    =cdrtools-1.11.39-r1
              CVE : CAN-2003-0289

- - ---------------------------------------------------------------------

Cdrecord isn't installed setuid root by default in Gentoo.

Read the full advisory at 
http://marc.theaimsgroup.com/?l=bugtraq&m=105285351304781&w=2

SOLUTION

It is recommended that all Gentoo Linux users who are running
app-cdr/cdrtools upgrade to one of the following versions:
for users running xcdroast: cdrtools-1.11.33-r1
for sparc users: cdrtools-1.11.39-r1
for everyone else: cdrtools-2.01_alpha14

emerge sync
emerge \=app-cdr/
emerge clean

- - ---------------------------------------------------------------------
aliz@gentoo.org - GnuPG key is available at  http://cvs.gentoo.org/~aliz
- - ---------------------------------------------------------------------