Mandrake: netpbm Multiple math overflow vulnerabilities
Posted by LinuxSecurity.com Team   
Mandrake These errors may permit remote attackers to cause a denial of service or execute arbitrary code in any programs or scripts that use these graphics conversion tools.

________________________________________________________________________

                Mandrake Linux Security Update Advisory
________________________________________________________________________

Package name:           netpbm
Advisory ID:            MDKSA-2003:036
Date:                   March 25th, 2003

Affected versions:	8.2, 9.0, 9.1, Corporate Server 2.1,
			Multi Network Firewall 8.2
________________________________________________________________________

Problem Description:

 Several math overflow errors were found in NetPBM by Al Viro and Alan
 Cox.  While these programs are not installed suid root, they are often
 used to prepare data for processing.  These errors may permit remote
 attackers to cause a denial of service or execute arbitrary code in
 any programs or scripts that use these graphics conversion tools.
________________________________________________________________________

References:

   http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2003-0146
________________________________________________________________________

Updated Packages:

 Corporate Server 2.1:
 1cacb96516f20c657e707220883da4e2  corporate/2.1/RPMS/libnetpbm9-9.24-4.1mdk.i586.rpm
 d02aafe14615b2c7d3fe1d2dbc11cf88  corporate/2.1/RPMS/libnetpbm9-devel-9.24-4.1mdk.i586.rpm
 846afa2193443b7eab80617f575908f7  corporate/2.1/RPMS/libnetpbm9-static-devel-9.24-4.1mdk.i586.rpm
 a511622a573dbeb8d1797ef06e5f84d2  corporate/2.1/RPMS/netpbm-9.24-4.1mdk.i586.rpm
 8ab4aa98e85996de86cdd5a0352998b2  corporate/2.1/SRPMS/netpbm-9.24-4.1mdk.src.rpm

 Mandrake Linux 8.2:
 4c277ce5221a712ff3a2e81f4d4ae779  8.2/RPMS/libnetpbm9-9.20-2.1mdk.i586.rpm
 5cd77d93147a04562f7786e3d54d3b1f  8.2/RPMS/libnetpbm9-devel-9.20-2.1mdk.i586.rpm
 68d366954fefdd8aca8f5a7d5173c5c1  8.2/RPMS/netpbm-9.20-2.1mdk.i586.rpm
 fa92b8f4cf40d23b0f3b413538a25d96  8.2/SRPMS/netpbm-9.20-2.1mdk.src.rpm

 Mandrake Linux 8.2/PPC:
 0bcd2f6a657fb9cb1155beeaeb9d36a3  ppc/8.2/RPMS/libnetpbm9-9.20-2.1mdk.ppc.rpm
 85688ef2cf1403fc9b206d6695486ed7  ppc/8.2/RPMS/libnetpbm9-devel-9.20-2.1mdk.ppc.rpm
 ea6be931b8b18fb481a7f3afa342d68a  ppc/8.2/RPMS/netpbm-9.20-2.1mdk.ppc.rpm
 fa92b8f4cf40d23b0f3b413538a25d96  ppc/8.2/SRPMS/netpbm-9.20-2.1mdk.src.rpm

 Mandrake Linux 9.0:
 1cacb96516f20c657e707220883da4e2  9.0/RPMS/libnetpbm9-9.24-4.1mdk.i586.rpm
 d02aafe14615b2c7d3fe1d2dbc11cf88  9.0/RPMS/libnetpbm9-devel-9.24-4.1mdk.i586.rpm
 846afa2193443b7eab80617f575908f7  9.0/RPMS/libnetpbm9-static-devel-9.24-4.1mdk.i586.rpm
 a511622a573dbeb8d1797ef06e5f84d2  9.0/RPMS/netpbm-9.24-4.1mdk.i586.rpm
 8ab4aa98e85996de86cdd5a0352998b2  9.0/SRPMS/netpbm-9.24-4.1mdk.src.rpm

 Mandrake Linux 9.1:
 bb8f608467f395541f6c07fba5387446  9.1/RPMS/libnetpbm9-9.24-4.1mdk.i586.rpm
 83c13c185a3d1acb563ab92048b19293  9.1/RPMS/libnetpbm9-devel-9.24-4.1mdk.i586.rpm
 456cb325352a4c67bf8043698ff9e1eb  9.1/RPMS/libnetpbm9-static-devel-9.24-4.1mdk.i586.rpm
 5cb800b6e2bede124a8c7b074b6f8b98  9.1/RPMS/netpbm-9.24-4.1mdk.i586.rpm
 8ab4aa98e85996de86cdd5a0352998b2  9.1/SRPMS/netpbm-9.24-4.1mdk.src.rpm

 Mandrake Linux 9.1/PPC:
 698a57c9e890a7ead13218a41088b520  ppc/9.1/RPMS/libnetpbm9-9.24-4.1mdk.ppc.rpm
 f20183e0ac7bb83e6a8ef62b6d102aa8  ppc/9.1/RPMS/libnetpbm9-devel-9.24-4.1mdk.ppc.rpm
 ec3079aafa81664762c509e6027c4e83  ppc/9.1/RPMS/libnetpbm9-static-devel-9.24-4.1mdk.ppc.rpm
 a679a6f2f228a7cc4151f0d1d3db77fa  ppc/9.1/RPMS/netpbm-9.24-4.1mdk.ppc.rpm
 8ab4aa98e85996de86cdd5a0352998b2  ppc/9.1/SRPMS/netpbm-9.24-4.1mdk.src.rpm

 Multi Network Firewall 8.2:
 4c277ce5221a712ff3a2e81f4d4ae779  mnf8.2/RPMS/libnetpbm9-9.20-2.1mdk.i586.rpm
 68d366954fefdd8aca8f5a7d5173c5c1  mnf8.2/RPMS/netpbm-9.20-2.1mdk.i586.rpm
 fa92b8f4cf40d23b0f3b413538a25d96  mnf8.2/SRPMS/netpbm-9.20-2.1mdk.src.rpm
________________________________________________________________________

Bug IDs fixed (see https://qa.mandrakesoft.com for more information):
________________________________________________________________________

To upgrade automatically, use MandrakeUpdate.  The verification of md5
checksums and GPG signatures is performed automatically for you.

If you want to upgrade manually, download the updated package from one
of our FTP server mirrors and upgrade with "rpm -Fvh *.rpm".  A list of
FTP mirrors can be obtained from:

   http://www.mandrakesecure.net/en/ftp.php

Please verify the update prior to upgrading to ensure the integrity of
the downloaded package.  You can do this with the command:

  rpm --checksig 

All packages are signed by MandrakeSoft for security.  You can obtain
the GPG public key of the Mandrake Linux Security Team from:

  https://www.mandrakesecure.net/RPM-GPG-KEYS

Please be aware that sometimes it takes the mirrors a few hours to
update.

You can view other update advisories for Mandrake Linux at:

   http://www.mandrakesecure.net/en/advisories/

MandrakeSoft has several security-related mailing list services that
anyone can subscribe to.  Information on these lists can be obtained by
visiting:

   http://www.mandrakesecure.net/en/mlist.php

If you want to report vulnerabilities, please contact

  security_linux-mandrake.com

Type Bits/KeyID     Date       User ID
pub  1024D/22458A98 2000-07-10 Linux Mandrake Security Team
  

-----BEGIN PGP PUBLIC KEY BLOCK-----
Version: GnuPG v1.0.7 (GNU/Linux)

mQGiBDlp594RBAC2tDozI3ZgQsE7XwxurJCJrX0L5vx7SDByR5GHDdWekGhdiday
L4nfUax+SeR9SCoCgTgPW1xB8vtQc8/sinJlMjp9197a2iKM0FOcPlkpa3HcOdt7
WKJqQhlMrHvRcsivzcgqjH44GBBJIT6sygUF8k0lU6YnMHj5MPc/NGWt8wCg9vKo
P0l5QVAFSsHtqcU9W8cc7wMEAJzQsAlnvPXDBfBLEH6u7ptWFdp0GvbSuG2wRaPl
hynHvRiE01ZvwbJZXsPsKm1z7uVoW+NknKLunWKB5axrNXDHxCYJBzY3jTeFjsqx
PFZkIEAQphLTkeXXelAjQ5u9tEshPswEtMvJvUgNiAfbzHfPYmq8D6x5xOw1IySg
2e/LBACxr2UJYCCB2BZ3p508mAB0RpuLGukq+7UWiOizy+kSskIBg2O7sQkVY/Cs
iyGEo4XvXqZFMY39RBdfm2GY+WB/5NFiTOYJRKjfprP6K1YbtsmctsX8dG+foKsD
LLFs7OuVfaydLQYp1iiN6D+LJDSMPM8/LCWzZsgr9EKJ8NXiyrQ6TGludXggTWFu
ZHJha2UgU2VjdXJpdHkgVGVhbSA8c2VjdXJpdHlAbGludXgtbWFuZHJha2UuY29t
PohWBBMRAgAWBQI5aefeBAsKBAMDFQMCAxYCAQIXgAAKCRCaqNDQIkWKmK6LAKCy
/NInDsaMSI+WHwrquwC5PZrcnQCeI+v3gUDsNfQfiKBvQSANu1hdulqIRgQQEQIA
BgUCOtNVGQAKCRBZ5w3um0pAJJWQAKDUoL5He+mKbfrMaTuyU5lmRyJ0fwCgoFAP
WdvQlu/kFjphF740XeOwtOqIRgQQEQIABgUCOu8A6QAKCRBynDnb9lq3CnpjAJ4w
Pk0SEE9U4r40IxWpwLU+wrWVugCdFfSPllPpZRCiaC7HwbFcfExRmPaIRgQQEQIA
BgUCPI+UAwAKCRDniYrgcHcf8xK5AKCm/Mq8qP8GE0o1hEX22QsJMZwH5gCfZ72H
8TacOb3oAmBdprf+K6gkdOiIRgQQEQIABgUCOtOieAAKCRCv2bZyU0yB80MeAJ9K
+jXt0cKuaUonRU+CRGetk6t9dgCfTRRL6/puOKdD6md70+K5EBBSvsG0OE1hbmRy
YWtlIExpbnV4IFNlY3VyaXR5IFRlYW0gPHNlY3VyaXR5QG1hbmRyYWtlc29mdC5j
b20+iFcEExECABcFAjyPnuUFCwcKAwQDFQMCAxYCAQIXgAAKCRCaqNDQIkWKmFi+
AJsHhohgnU3ik4+gy3EdFlB2i/MBoACg6lHn5cnVvTcmgNccWxeNxLLZI5e5AQ0E
OWnn7xAEAOQlTVY4TiNo5V/iP0J1xnqjqlqZsU7yEBKo/gZz6/+hx75RURe1ebiJ
9F779FQbpJ9Epz1KLSXvq974rnVb813zuGdmgFyk+ryA/rTR2RQ8h+EoNkwmATzR
xBXVJb57fFQjxOu4eNjZAtfII/YXb0uyXXrdr5dlJ/3eXrcO4p0XAAMFBACCxo6Z
269s+A4v8C6Ui12aarOQcCDlV8cVG9LkyatU3FNTlnasqwo6EkaP572448weJWwN
6SCXVl+xOYLiK0hL/6Jb/O9Agw75yUVdk+RMM2I4fNEi+y4hmfMh2siBv8yEkEvZ
jTcl3TpkTfzYky85tu433wmKaLFOv0WjBFSikohGBBgRAgAGBQI5aefvAAoJEJqo
0NAiRYqYid0AoJgeWzXrEdIClBOSW5Q6FzqJJyaqAKC0Y9YI3UFlE4zSIGjcFlLJ
EJGXlA==
=yGlX
-----END PGP PUBLIC KEY BLOCK-----