Gentoo: sendmail remote root exploit
Posted by LinuxSecurity.com Team   
Gentoo A remote vulnerability exists that can result in commands can be executed with administrative privileges.

- - ---------------------------------------------------------------------
GENTOO LINUX SECURITY ANNOUNCEMENT 200303-4
- - ---------------------------------------------------------------------

          PACKAGE : sendmail
          SUMMARY : remote root exploit
             DATE : 2003-03-04 10:12 UTC
          EXPLOIT : remote
VERSIONS AFFECTED : <8.12.8
    FIXED VERSION : =>8.12.8
              CVE : CAN-2002-1337

- - ---------------------------------------------------------------------

- From advisory:

"Attackers may remotely exploit this vulnerability to gain "root" or 
superuser control of any vulnerable Sendmail server. Sendmail and all 
other email servers are typically exposed to the Internet in order to 
send and receive Internet email. Vulnerable Sendmail servers will not be 
protected by legacy security devices such as firewalls and/or packet 
filters. This vulnerability is especially dangerous because the exploit 
can be delivered within an email message and the attacker doesn't need 
any specific knowledge of the target to launch a successful attack."

Read the full advisory at: 
http://www.iss.net/issEn/delivery/xforce/alertdetail.jsp?oid=21950

SOLUTION

It is recommended that all Gentoo Linux users who are running
net-mail/sendmail upgrade to sendmail-8.12.8 as follows:

emerge sync
emerge -u sendmail
emerge clean

- - ---------------------------------------------------------------------
aliz@gentoo.org - GnuPG key is available at  http://cvs.gentoo.org/~aliz
- - ---------------------------------------------------------------------