Gentoo: apcupsd Multiple vulnerabilities
Posted by LinuxSecurity.com Team   
Gentoo A remote root vulnerability in slave setups and some buffer overflowsin the network information server code were discovered by the apcupsddevelopers.

- ---------------------------------------------------------------------
GENTOO LINUX SECURITY ANNOUNCEMENT 200302-13
- ---------------------------------------------------------------------

          PACKAGE : apcupsd
          SUMMARY : remote root vulnerability and buffer overflows
             DATE : 2003-02-24 10:05 UTC
          EXPLOIT : remote
VERSIONS AFFECTED : <3.10.5
    FIXED VERSION : 3.10.5

- ---------------------------------------------------------------------

>From Mandrake Linux Security Update Advisory MDKSA-2003:018:

"A remote root vulnerability in slave setups and some buffer overflows
in the network information server code were discovered by the apcupsd
developers."

Read the full advisory at: 
http://www.mandrakesecure.net/en/advisories/advisory.php?name=MDKSA-2003:018

SOLUTION

It is recommended that all Gentoo Linux users who are running
sys-apps/apcupsd upgrade to apcupsd-3.10.5 as follows:

emerge sync
emerge -u apcupsd
emerge clean

- ---------------------------------------------------------------------
aliz@gentoo.org - GnuPG key is available at  http://cvs.gentoo.org/~aliz
zwelch@gentoo.org
- ---------------------------------------------------------------------