Gentoo: KDE multiple vulnerabilities
Posted by LinuxSecurity.com Team   
Gentoo In some instances KDE fails to properly quote parameters of instructions passed to a command shell for execution.

- --------------------------------------------------------------------
GENTOO LINUX SECURITY ANNOUNCEMENT 200212-9
- --------------------------------------------------------------------

PACKAGE : kde-3.0.x
SUMMARY : multiple vulnerabilities in KDE
DATE    : 2002-12-22 13:12 UTC
EXPLOIT : remote

- --------------------------------------------------------------------

From advisory:

"In some instances KDE fails to properly quote parameters of
instructions passed to a command shell for execution.

These parameters may incorporate data such as URLs, filenames and
e-mail addresses, and this data may be provided remotely to a victim
in an e-mail, a webpage or files on a network filesystem or other
untrusted source.

By carefully crafting such data an attacker might be able to
execute arbitary commands on a vulnerable sytem using the victim's
account and privileges.

The KDE Project is aware of several possible exploits of these
vulnerabilities and is releasing this advisory with patches to
correct the issues. The patches also provide better safe guards and
check data from untrusted sources more strictly in multiple places."

Read the full advisory at 
http://www.kde.org/info/security/advisory-20021220-1.txt

INFORMATION REGARDING OTHER ARCHITECTURES THAN X86

kde-3.0.5a is currenlty only marked stable for x86. If you have
succesfully compiled and merged 3.0.5a on any other architecture
than x86 please report this to kde@gentoo.org.

INFORMATION REGARDING KDE 2.2.2 AND KDE 3.1

The Gentoo KDE team is currently testing a new revision of KDE 2.2.2
that includes fixes for the vulnerabilities mentioned in KDEs security
advisory. A new GLSA will be issued when those packages are available.

KDE 3.1 has not yet been released by KDE. However, masked ebuilds exist
in the portage tree for various release canidates. Since KDE has not
released a new version that fixes these vulnerabilites no update is
available for those who are currently running any version of the 3.1.x
series. If KDE releases a new RC before the official release and when
KDE 3.1 final is released a new GLSA will be issued to adress the
vulnerabilites in the 3.1.x series.

SOLUTION

It is recommended that all Gentoo Linux users who are running
kde-base/kde-3.0.4 and earlier in the 3.0.x series update their
systems as follows:

emerge rsync
emerge kde
emerge clean

- --------------------------------------------------------------------
aliz@gentoo.org - GnuPG key is available at www.gentoo.org/~aliz
kde@gentoo.org
- --------------------------------------------------------------------