Gentoo: fetchmail buffer overflow vulnerability
Posted by LinuxSecurity.com Team   
Gentoo This heap overflow can be used by remote attackers to crash it or to execute arbitrary code with the privileges of the user running fetchmail. Depending on the configuration this allows a remote root compromise.

- --------------------------------------------------------------------
GENTOO LINUX SECURITY ANNOUNCEMENT 200212-3
- --------------------------------------------------------------------

PACKAGE : fetchmail
SUMMARY : buffer overflow
DATE    : 2002-12-15 13:12 UTC
EXPLOIT : remote

- --------------------------------------------------------------------

From e-matters advisory:

"In the light of recent discoveries we reaudited Fetchmail and found
another buffer overflow within the default configuration. This heap
overflow can be used by remote attackers to crash it or to execute
arbitrary code with the privileges of the user running fetchmail.
Depending on the configuration this allows a remote root compromise."

Read the full advisory at 
http://security.e-matters.de/advisories/052002.html

SOLUTION

It is recommended that all Gentoo Linux users who are running
net-mail/fetchmail-6.1.2 and earlier update their systems as follows:

emerge rsync
emerge fetchmail
emerge clean

- --------------------------------------------------------------------
aliz@gentoo.org - GnuPG key is available at www.gentoo.org/~aliz
avenj@gentoo.org
- --------------------------------------------------------------------