RedHat: SquirrelMail XSS vulnerabilities
Posted by LinuxSecurity.com Team   
RedHat Linux Two Cross-site scripting vulnerabilities have been found that affect SquirrelMail version 1.2.7 and earlier.

---------------------------------------------------------------------
                   Red Hat, Inc. Red Hat Security Advisory

Synopsis:          Updated squirrelmail packages close cross-site scripting vulnerabilities
Advisory ID:       RHSA-2002:204-10
Issue date:        2002-09-20
Updated on:        2002-10-09
Product:           Red Hat Linux
Keywords:          squirrelmail cross-site scripting
Cross references:  
Obsoletes:         
CVE Names:         CAN-2002-1131 CAN-2002-1132
---------------------------------------------------------------------

1. Topic:

Updated squirrelmail packages are now available for Red Hat Linux.

2. Relevant releases/architectures:

Red Hat Linux 8.0 - noarch

3. Problem description:

SquirrelMail is a webmail package written in PHP.  Two vulnerabilities
have been found that affect SquirrelMail version 1.2.7 and earlier.

Cross-site scripting vulnerabilities allow remote attackers to execute
script as other web users via addressbook.php, options.php, search.php, or
help.php.

It is possible for remote attackers to determine the absolute pathname of
the options.php script via a malformed optpage file argument, which
generates an error message when the file cannot be included in the script.

Red Hat Linux 8 shipped with SquirrelMail version 1.2.7 and is therefore
vulnerable to these issues. 

All users are advised to upgrade to these errata packages containing
SquirrelMail version 1.2.8 which is not vulnerable to these issues.

4. Solution:

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

To update all RPMs for your particular architecture, run:

rpm -Fvh [filenames]

where [filenames] is a list of the RPMs you wish to upgrade.  Only those
RPMs which are currently installed will be updated.  Those RPMs which are
not installed but included in the list will not be updated.  Note that you
can also use wildcards (*.rpm) if your current directory *only* contains the
desired RPMs.

Please note that this update is also available via Red Hat Network.  Many
people find this an easier way to apply updates.  To use Red Hat Network,
launch the Red Hat Update Agent with the following command:

up2date

This will start an interactive process that will result in the appropriate
RPMs being upgraded on your system.

5. Bug IDs fixed  (http://bugzilla.Red Hat.com/bugzilla for more info):

74313 - SquirrelMail 1.2.7 vulnerable to XSS attacks

6. RPMs required:

Red Hat Linux 8.0:

SRPMS: 
ftp://updates.Red Hat.com/8.0/en/os/SRPMS/squirrelmail-1.2.8-1.src.rpm

noarch: 
ftp://updates.Red Hat.com/8.0/en/os/noarch/squirrelmail-1.2.8-1.noarch.rpm



7. Verification:

MD5 sum                          Package Name
--------------------------------------------------------------------------
2a03426b9e7b439563310c8b34f3c1cb 8.0/en/os/SRPMS/squirrelmail-1.2.8-1.src.rpm
de62960435fc414967ea8503e0ce721f 8.0/en/os/noarch/squirrelmail-1.2.8-1.noarch.rpm


These packages are GPG signed by Red Hat, Inc. for security.  Our key
is available at:
     http://www.Red Hat.com/about/contact/pgpkey.html

You can verify each package with the following command:
    rpm --checksig  

If you only wish to verify that each package has not been corrupted or
tampered with, examine only the md5sum with the following command:
    rpm --checksig --nogpg 


8. References:
 
http://sourceforge.net/project/shownotes.php?group_id=311&release_id=110774 
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2002-1131 
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2002-1132


Copyright(c) 2000, 2001, 2002 Red Hat, Inc.