Debian: 'cipe' DoS attack vulnerability
Posted by LinuxSecurity.com Team   
Debian Larry McVoy found a bug in the packet handling code for the CIPEVPN package: it did not check if a received packet was too shortand could crash.

------------------------------------------------------------------------
Debian Security Advisory DSA-104-1                   security@debian.org 
http://www.debian.org/security/                         Wichert Akkerman
January 14, 2002
------------------------------------------------------------------------


Package        : cipe
Problem type   : DoS attack
Debian-specific: no

Larry McVoy found a bug in the packet handling code for the CIPE
VPN package: it did not check if a received packet was too short
and could crash.

This has been fixed in version 1.3.0-3, and we recommend that you
upgrade your cipe packages immediately.

Please note that the package only contains the needed kernel patch,
you will have to build the kernel modules for your kernel with the
updated source from the cipe-source package.

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.


Debian GNU/Linux 2.2 alias potato
---------------------------------

  Potato was released for alpha, arm, i386, m68k, powerpc and sparc.

  Source archives:
     http://security.debian.org/dists/stable/updates/main/source/cipe_1.3.0-3.diff.gz
      MD5 checksum: afbeeab103f402414c22bc039dff7984
     http://security.debian.org/dists/stable/updates/main/source/cipe_1.3.0-3.dsc
      MD5 checksum: f573894eaab254cacd5a256e22423a8e
     http://security.debian.org/dists/stable/updates/main/source/cipe_1.3.0.orig.tar.gz
      MD5 checksum: 01269317d3c387713f40b18f73514fb6

  Architecture independent archives:
     
http://security.debian.org/dists/stable/updates/main/binary-all/cipe-common_1.3.0-3_all.deb
      MD5 checksum: bbfe46765a76bce4f4ce6f9855eee717
     
http://security.debian.org/dists/stable/updates/main/binary-all/cipe-source_1.3.0-3_all.deb
      MD5 checksum: c380864ae382aff742f08869f89848f6

  These packages will be moved into the stable distribution on its next
  revision.

--
----------------------------------------------------------------------------
apt-get: deb  http://security.debian.org/ stable/updates main
dpkg-ftp:  ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org