RedHat: PowerTools: Cyrus SASL format string vulnerability
Posted by LinuxSecurity.com Team   
RedHat Linux These packages fix a possible format-string vulnerability in the defaultlogging callback function provided by libsasl.

---------------------------------------------------------------------
                   Red Hat, Inc. Red Hat Security Advisory

Synopsis:          Updated Cyrus SASL packages available
Advisory ID:       RHSA-2001:151-06
Issue date:        2001-11-02
Updated on:        2001-11-29
Product:           Red Hat Powertools
Keywords:          cyrus sasl syslog format string
Cross references:  RHSA-2001:150
Obsoletes:         
---------------------------------------------------------------------

1. Topic:

Updated Cyrus-SASL packages are now available for Red Hat Power Tools 6.2.
These packages fix a possible format-string vulnerability in the default
logging callback function provided by libsasl.

2. Relevant releases/architectures:

Red Hat Powertools 6.2 - alpha, i386, sparc

3. Problem description:

The default logging callback function supplied by the Cyrus SASL library
suffers from a format-string vulnerability.  This function is used when a
server which uses Cyrus SASL attempts to set or change a user's secrets.

The Common Vulnerabilities and Exposures project (cve.mitre.org) has
assigned the name CAN-2001-0869 to this issue.

4. Solution:

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

To update all RPMs for your particular architecture, run:

rpm -Fvh [filenames]

where [filenames] is a list of the RPMs you wish to upgrade.  Only those
RPMs which are currently installed will be updated.  Those RPMs which are
not installed but included in the list will not be updated.  Note that you
can also use wildcards (*.rpm) if your current directory *only* contains the
desired RPMs.

Please note that this update is also available via Red Hat Network.  Many
people find this an easier way to apply updates.  To use Red Hat Network,
launch the Red Hat Update Agent with the following command:

up2date

This will start an interactive process that will result in the appropriate
RPMs being upgraded on your system.

5. Bug IDs fixed  (http://bugzilla.Red Hat.com/bugzilla for more info):



6. RPMs required:

Red Hat Powertools 6.2:

SRPMS: 
ftp://updates.Red Hat.com/6.2/en/powertools/SRPMS/cyrus-sasl-1.5.24-22.6.src.rpm

alpha: 
ftp://updates.Red Hat.com/6.2/en/powertools/alpha/cyrus-sasl-1.5.24-22.6.alpha.rpm 
ftp://updates.Red Hat.com/6.2/en/powertools/alpha/cyrus-sasl-devel-1.5.24-22.6.alpha.rpm 
ftp://updates.Red Hat.com/6.2/en/powertools/alpha/cyrus-sasl-gssapi-1.5.24-22.6.alpha.rpm

i386: 
ftp://updates.Red Hat.com/6.2/en/powertools/i386/cyrus-sasl-1.5.24-22.6.i386.rpm 
ftp://updates.Red Hat.com/6.2/en/powertools/i386/cyrus-sasl-devel-1.5.24-22.6.i386.rpm 
ftp://updates.Red Hat.com/6.2/en/powertools/i386/cyrus-sasl-gssapi-1.5.24-22.6.i386.rpm

sparc: 
ftp://updates.Red Hat.com/6.2/en/powertools/sparc/cyrus-sasl-1.5.24-22.6.sparc.rpm 
ftp://updates.Red Hat.com/6.2/en/powertools/sparc/cyrus-sasl-devel-1.5.24-22.6.sparc.rpm 
ftp://updates.Red Hat.com/6.2/en/powertools/sparc/cyrus-sasl-gssapi-1.5.24-22.6.sparc.rpm



7. Verification:

MD5 sum                          Package Name
--------------------------------------------------------------------------
58815b353b9903171c71ed27c5453c47 6.2/en/powertools/SRPMS/cyrus-sasl-1.5.24-22.6.src.rpm
b7c6aa9328181c301bc1b4787d0345e4 6.2/en/powertools/alpha/cyrus-sasl-1.5.24-22.6.alpha.rpm
bfc51530e88dbd005f1d7f0f83585ad6 6.2/en/powertools/alpha/cyrus-sasl-devel-1.5.24-22.6.alpha.rpm
2c5152154ce70cad31f3f35589a82f25 6.2/en/powertools/alpha/cyrus-sasl-gssapi-1.5.24-22.6.alpha.rpm
29824544efd19001da08a3040ec07932 6.2/en/powertools/i386/cyrus-sasl-1.5.24-22.6.i386.rpm
eaf2f39c854e8b36ecb3bcd13dd8e064 6.2/en/powertools/i386/cyrus-sasl-devel-1.5.24-22.6.i386.rpm
b3f4886cf69a22846d403b11040ab718 6.2/en/powertools/i386/cyrus-sasl-gssapi-1.5.24-22.6.i386.rpm
128167f42bb1543c9c5eb17a90b6a204 6.2/en/powertools/sparc/cyrus-sasl-1.5.24-22.6.sparc.rpm
752949756234de6adaeb2bedc8f073a9 6.2/en/powertools/sparc/cyrus-sasl-devel-1.5.24-22.6.sparc.rpm
218774230544b6a8d2f4de1a731afebf 6.2/en/powertools/sparc/cyrus-sasl-gssapi-1.5.24-22.6.sparc.rpm
 

These packages are GPG signed by Red Hat, Inc. for security.  Our key
is available at:
     http://www.Red Hat.com/about/contact/pgpkey.html

You can verify each package with the following command:
    rpm --checksig  

If you only wish to verify that each package has not been corrupted or
tampered with, examine only the md5sum with the following command:
    rpm --checksig --nogpg 

8. References:
 
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2001-0869 
http://www.securityfocus.com/bid/3498


Copyright(c) 2000, 2001 Red Hat, Inc.