LinuxSecurity.com
Share your story
The central voice for Linux and Open Source security news
Home News Topics Advisories HOWTOs Features Newsletters About Register

Welcome!
Sign up!
EnGarde Community
Login
Polls
What is the most important Linux security technology?
 
Advisories
Community
Linux Events
Linux User Groups
Link to Us
Security Center
Book Reviews
Security Dictionary
Security Tips
SELinux
White Papers
Featured Blogs
All About Linux
DanWalsh LiveJournal
Securitydistro
Latest Newsletters
Linux Security Week: October 20th, 2014
Linux Advisory Watch: October 17th, 2014
Subscribe
LinuxSecurity Newsletters
E-mail:
Choose Lists:
About our Newsletters
RSS Feeds
Get the LinuxSecurity news you want faster with RSS
Powered By

  
Gentoo: 201406-27 polkit, Spice-Gtk, systemd, HPLIP, libvirt: Privilege Print E-mail
User Rating:      How can I rate this item?
Posted by Benjamin D. Thomas   
Gentoo A race condition in polkit could allow a local attacker to gain escalated privileges.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201406-27
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: High
    Title: polkit, Spice-Gtk, systemd, HPLIP, libvirt: Privilege
           escalation
     Date: June 26, 2014
     Bugs: #484486, #484488, #485420, #485546, #485904
       ID: 201406-27

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A race condition in polkit could allow a local attacker to gain
escalated privileges.

Background
==========

polkit is a toolkit for managing policies relating to unprivileged
processes communicating with privileged processes.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  net-print/hplip              < 3.14.1                  >= 3.14.1
  2  net-misc/spice-gtk            < 0.21                     >= 0.21
  3  sys-apps/systemd             < 204-r1                  >= 204-r1
  4  app-emulation/libvirt       < 1.1.2-r3               >= 1.1.2-r3
  5  sys-auth/polkit              < 0.112                    >= 0.112
    -------------------------------------------------------------------
     5 affected packages

Description
===========

polkit has a race condition which potentially allows a process to
change its UID/EUID via suid or pkexec before authentication is
completed.

Impact
======

A local attacker could start a suid or pkexec process through a
polkit-enabled application, which could result in privilege escalation
or bypass of polkit restrictions.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All polkit users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=sys-auth/polkit-0.112"

All HPLIP users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-print/hplip-3.14.1"

All Spice-Gtk users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-misc/spice-gtk-0.21"

All systemd users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=sys-apps/systemd-204-r1"

All libvirt users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=app-emulation/libvirt-1.1.2-r3"

References
==========

[ 1 ] CVE-2013-4288
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4288
[ 2 ] CVE-2013-4311
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4311
[ 3 ] CVE-2013-4324
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4324
[ 4 ] CVE-2013-4325
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4325
[ 5 ] CVE-2013-4327
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4327

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 http://security.gentoo.org/glsa/glsa-201406-27.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License

Copyright 2014 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
 
< Prev   Next >
    
Partner

 

Latest Features
Peter Smith Releases Linux Network Security Online
Securing a Linux Web Server
Password guessing with Medusa 2.0
Password guessing as an attack vector
Squid and Digest Authentication
Squid and Basic Authentication
Demystifying the Chinese Hacking Industry: Earning 6 Million a Night
Free Online security course (LearnSIA) - A Call for Help
What You Need to Know About Linux Rootkits
Review: A Practical Guide to Fedora and Red Hat Enterprise Linux - Fifth Edition
Yesterday's Edition
Hacker Halted 2014: Johnny Long Calls for Hackers for Charity Volunteers
RIPS – Static Source Code Analysis For PHP Vulnerabilities
Finding a Video Poker Bug Made These Guys Rich—Then Vegas Made Them Pay
Partner Sponsor

Community | HOWTOs | Blogs | Features | Book Reviews | Networking
 Security Projects |  Latest News |  Newsletters |  SELinux |  Privacy |  Home
 Hardening |   About Us |   Advertise |   Legal Notice |   RSS |   Guardian Digital
(c)Copyright 2014 Guardian Digital, Inc. All rights reserved.