LinuxSecurity.com
Share your story
The central voice for Linux and Open Source security news
Home News Topics Advisories HOWTOs Features Newsletters About Register

Welcome!
Sign up!
EnGarde Community
Login
Polls
What is the most important Linux security technology?
 
Advisories
Community
Linux Events
Linux User Groups
Link to Us
Security Center
Book Reviews
Security Dictionary
Security Tips
SELinux
White Papers
Featured Blogs
All About Linux
DanWalsh LiveJournal
Securitydistro
Latest Newsletters
Linux Advisory Watch: September 26th, 2014
Linux Security Week: September 22nd, 2014
Subscribe
LinuxSecurity Newsletters
E-mail:
Choose Lists:
About our Newsletters
RSS Feeds
Get the LinuxSecurity news you want faster with RSS
Powered By

  
Red Hat: 2014:0312-01: php: Critical Advisory Print E-mail
User Rating:      How can I rate this item?
Posted by Benjamin D. Thomas   
RedHat Linux Updated php packages that fix one security issue are now available for Red Hat Enterprise Linux 5.3 and 5.6 Long Life, and Red Hat Enterprise Linux 5.9 Extended Update Support. [More...]
=====================================================================
                   Red Hat Security Advisory

Synopsis:          Critical: php security update
Advisory ID:       RHSA-2014:0312-01
Product:           Red Hat Enterprise Linux
Advisory URL:      https://rhn.redhat.com/errata/RHSA-2014-0312.html
Issue date:        2014-03-18
CVE Names:         CVE-2009-0689 
=====================================================================

1. Summary:

Updated php packages that fix one security issue are now available for Red
Hat Enterprise Linux 5.3 and 5.6 Long Life, and Red Hat Enterprise Linux
5.9 Extended Update Support.

The Red Hat Security Response Team has rated this update as having Critical
security impact. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available from the CVE link in
the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux EUS (v. 5.9 server) - i386, ia64, ppc, s390x, x86_64
Red Hat Enterprise Linux LL (v. 5.6 server) - i386, ia64, x86_64
Red Hat Enterprise Linux Long Life (v. 5.3 server) - i386, ia64, x86_64

3. Description:

PHP is an HTML-embedded scripting language commonly used with the Apache
HTTP Server.

A buffer overflow flaw was found in the way PHP parsed floating point
numbers from their text representation. If a PHP application converted
untrusted input strings to numbers, an attacker able to provide such input
could cause the application to crash or, possibly, execute arbitrary code
with the privileges of the application. (CVE-2009-0689)

All php users are advised to upgrade to these updated packages, which
contain a backported patch to correct this issue. After installing the
updated packages, the httpd daemon must be restarted for the update to
take effect.

4. Solution:

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at
https://access.redhat.com/site/articles/11258

5. Bugs fixed (https://bugzilla.redhat.com/):

539784 - CVE-2009-0689 array index error in dtoa implementation of many products
1057555 - CVE-2009-0689 php: heap overflow in floating point parsing

6. Package List:

Red Hat Enterprise Linux Long Life (v. 5.3 server):

Source:
php-5.1.6-23.6.el5_3.src.rpm

i386:
php-5.1.6-23.6.el5_3.i386.rpm
php-bcmath-5.1.6-23.6.el5_3.i386.rpm
php-cli-5.1.6-23.6.el5_3.i386.rpm
php-common-5.1.6-23.6.el5_3.i386.rpm
php-dba-5.1.6-23.6.el5_3.i386.rpm
php-debuginfo-5.1.6-23.6.el5_3.i386.rpm
php-devel-5.1.6-23.6.el5_3.i386.rpm
php-gd-5.1.6-23.6.el5_3.i386.rpm
php-imap-5.1.6-23.6.el5_3.i386.rpm
php-ldap-5.1.6-23.6.el5_3.i386.rpm
php-mbstring-5.1.6-23.6.el5_3.i386.rpm
php-mysql-5.1.6-23.6.el5_3.i386.rpm
php-ncurses-5.1.6-23.6.el5_3.i386.rpm
php-odbc-5.1.6-23.6.el5_3.i386.rpm
php-pdo-5.1.6-23.6.el5_3.i386.rpm
php-pgsql-5.1.6-23.6.el5_3.i386.rpm
php-snmp-5.1.6-23.6.el5_3.i386.rpm
php-soap-5.1.6-23.6.el5_3.i386.rpm
php-xml-5.1.6-23.6.el5_3.i386.rpm
php-xmlrpc-5.1.6-23.6.el5_3.i386.rpm

ia64:
php-5.1.6-23.6.el5_3.ia64.rpm
php-bcmath-5.1.6-23.6.el5_3.ia64.rpm
php-cli-5.1.6-23.6.el5_3.ia64.rpm
php-common-5.1.6-23.6.el5_3.ia64.rpm
php-dba-5.1.6-23.6.el5_3.ia64.rpm
php-debuginfo-5.1.6-23.6.el5_3.ia64.rpm
php-devel-5.1.6-23.6.el5_3.ia64.rpm
php-gd-5.1.6-23.6.el5_3.ia64.rpm
php-imap-5.1.6-23.6.el5_3.ia64.rpm
php-ldap-5.1.6-23.6.el5_3.ia64.rpm
php-mbstring-5.1.6-23.6.el5_3.ia64.rpm
php-mysql-5.1.6-23.6.el5_3.ia64.rpm
php-ncurses-5.1.6-23.6.el5_3.ia64.rpm
php-odbc-5.1.6-23.6.el5_3.ia64.rpm
php-pdo-5.1.6-23.6.el5_3.ia64.rpm
php-pgsql-5.1.6-23.6.el5_3.ia64.rpm
php-snmp-5.1.6-23.6.el5_3.ia64.rpm
php-soap-5.1.6-23.6.el5_3.ia64.rpm
php-xml-5.1.6-23.6.el5_3.ia64.rpm
php-xmlrpc-5.1.6-23.6.el5_3.ia64.rpm

x86_64:
php-5.1.6-23.6.el5_3.x86_64.rpm
php-bcmath-5.1.6-23.6.el5_3.x86_64.rpm
php-cli-5.1.6-23.6.el5_3.x86_64.rpm
php-common-5.1.6-23.6.el5_3.x86_64.rpm
php-dba-5.1.6-23.6.el5_3.x86_64.rpm
php-debuginfo-5.1.6-23.6.el5_3.x86_64.rpm
php-devel-5.1.6-23.6.el5_3.x86_64.rpm
php-gd-5.1.6-23.6.el5_3.x86_64.rpm
php-imap-5.1.6-23.6.el5_3.x86_64.rpm
php-ldap-5.1.6-23.6.el5_3.x86_64.rpm
php-mbstring-5.1.6-23.6.el5_3.x86_64.rpm
php-mysql-5.1.6-23.6.el5_3.x86_64.rpm
php-ncurses-5.1.6-23.6.el5_3.x86_64.rpm
php-odbc-5.1.6-23.6.el5_3.x86_64.rpm
php-pdo-5.1.6-23.6.el5_3.x86_64.rpm
php-pgsql-5.1.6-23.6.el5_3.x86_64.rpm
php-snmp-5.1.6-23.6.el5_3.x86_64.rpm
php-soap-5.1.6-23.6.el5_3.x86_64.rpm
php-xml-5.1.6-23.6.el5_3.x86_64.rpm
php-xmlrpc-5.1.6-23.6.el5_3.x86_64.rpm

Red Hat Enterprise Linux LL (v. 5.6 server):

Source:
php-5.1.6-27.el5_6.7.src.rpm

i386:
php-5.1.6-27.el5_6.7.i386.rpm
php-bcmath-5.1.6-27.el5_6.7.i386.rpm
php-cli-5.1.6-27.el5_6.7.i386.rpm
php-common-5.1.6-27.el5_6.7.i386.rpm
php-dba-5.1.6-27.el5_6.7.i386.rpm
php-debuginfo-5.1.6-27.el5_6.7.i386.rpm
php-devel-5.1.6-27.el5_6.7.i386.rpm
php-gd-5.1.6-27.el5_6.7.i386.rpm
php-imap-5.1.6-27.el5_6.7.i386.rpm
php-ldap-5.1.6-27.el5_6.7.i386.rpm
php-mbstring-5.1.6-27.el5_6.7.i386.rpm
php-mysql-5.1.6-27.el5_6.7.i386.rpm
php-ncurses-5.1.6-27.el5_6.7.i386.rpm
php-odbc-5.1.6-27.el5_6.7.i386.rpm
php-pdo-5.1.6-27.el5_6.7.i386.rpm
php-pgsql-5.1.6-27.el5_6.7.i386.rpm
php-snmp-5.1.6-27.el5_6.7.i386.rpm
php-soap-5.1.6-27.el5_6.7.i386.rpm
php-xml-5.1.6-27.el5_6.7.i386.rpm
php-xmlrpc-5.1.6-27.el5_6.7.i386.rpm

ia64:
php-5.1.6-27.el5_6.7.ia64.rpm
php-bcmath-5.1.6-27.el5_6.7.ia64.rpm
php-cli-5.1.6-27.el5_6.7.ia64.rpm
php-common-5.1.6-27.el5_6.7.ia64.rpm
php-dba-5.1.6-27.el5_6.7.ia64.rpm
php-debuginfo-5.1.6-27.el5_6.7.ia64.rpm
php-devel-5.1.6-27.el5_6.7.ia64.rpm
php-gd-5.1.6-27.el5_6.7.ia64.rpm
php-imap-5.1.6-27.el5_6.7.ia64.rpm
php-ldap-5.1.6-27.el5_6.7.ia64.rpm
php-mbstring-5.1.6-27.el5_6.7.ia64.rpm
php-mysql-5.1.6-27.el5_6.7.ia64.rpm
php-ncurses-5.1.6-27.el5_6.7.ia64.rpm
php-odbc-5.1.6-27.el5_6.7.ia64.rpm
php-pdo-5.1.6-27.el5_6.7.ia64.rpm
php-pgsql-5.1.6-27.el5_6.7.ia64.rpm
php-snmp-5.1.6-27.el5_6.7.ia64.rpm
php-soap-5.1.6-27.el5_6.7.ia64.rpm
php-xml-5.1.6-27.el5_6.7.ia64.rpm
php-xmlrpc-5.1.6-27.el5_6.7.ia64.rpm

x86_64:
php-5.1.6-27.el5_6.7.x86_64.rpm
php-bcmath-5.1.6-27.el5_6.7.x86_64.rpm
php-cli-5.1.6-27.el5_6.7.x86_64.rpm
php-common-5.1.6-27.el5_6.7.x86_64.rpm
php-dba-5.1.6-27.el5_6.7.x86_64.rpm
php-debuginfo-5.1.6-27.el5_6.7.x86_64.rpm
php-devel-5.1.6-27.el5_6.7.x86_64.rpm
php-gd-5.1.6-27.el5_6.7.x86_64.rpm
php-imap-5.1.6-27.el5_6.7.x86_64.rpm
php-ldap-5.1.6-27.el5_6.7.x86_64.rpm
php-mbstring-5.1.6-27.el5_6.7.x86_64.rpm
php-mysql-5.1.6-27.el5_6.7.x86_64.rpm
php-ncurses-5.1.6-27.el5_6.7.x86_64.rpm
php-odbc-5.1.6-27.el5_6.7.x86_64.rpm
php-pdo-5.1.6-27.el5_6.7.x86_64.rpm
php-pgsql-5.1.6-27.el5_6.7.x86_64.rpm
php-snmp-5.1.6-27.el5_6.7.x86_64.rpm
php-soap-5.1.6-27.el5_6.7.x86_64.rpm
php-xml-5.1.6-27.el5_6.7.x86_64.rpm
php-xmlrpc-5.1.6-27.el5_6.7.x86_64.rpm

Red Hat Enterprise Linux EUS (v. 5.9 server):

Source:
php-5.1.6-40.el5_9.2.src.rpm

i386:
php-5.1.6-40.el5_9.2.i386.rpm
php-bcmath-5.1.6-40.el5_9.2.i386.rpm
php-cli-5.1.6-40.el5_9.2.i386.rpm
php-common-5.1.6-40.el5_9.2.i386.rpm
php-dba-5.1.6-40.el5_9.2.i386.rpm
php-debuginfo-5.1.6-40.el5_9.2.i386.rpm
php-devel-5.1.6-40.el5_9.2.i386.rpm
php-gd-5.1.6-40.el5_9.2.i386.rpm
php-imap-5.1.6-40.el5_9.2.i386.rpm
php-ldap-5.1.6-40.el5_9.2.i386.rpm
php-mbstring-5.1.6-40.el5_9.2.i386.rpm
php-mysql-5.1.6-40.el5_9.2.i386.rpm
php-ncurses-5.1.6-40.el5_9.2.i386.rpm
php-odbc-5.1.6-40.el5_9.2.i386.rpm
php-pdo-5.1.6-40.el5_9.2.i386.rpm
php-pgsql-5.1.6-40.el5_9.2.i386.rpm
php-snmp-5.1.6-40.el5_9.2.i386.rpm
php-soap-5.1.6-40.el5_9.2.i386.rpm
php-xml-5.1.6-40.el5_9.2.i386.rpm
php-xmlrpc-5.1.6-40.el5_9.2.i386.rpm

ia64:
php-5.1.6-40.el5_9.2.ia64.rpm
php-bcmath-5.1.6-40.el5_9.2.ia64.rpm
php-cli-5.1.6-40.el5_9.2.ia64.rpm
php-common-5.1.6-40.el5_9.2.ia64.rpm
php-dba-5.1.6-40.el5_9.2.ia64.rpm
php-debuginfo-5.1.6-40.el5_9.2.ia64.rpm
php-devel-5.1.6-40.el5_9.2.ia64.rpm
php-gd-5.1.6-40.el5_9.2.ia64.rpm
php-imap-5.1.6-40.el5_9.2.ia64.rpm
php-ldap-5.1.6-40.el5_9.2.ia64.rpm
php-mbstring-5.1.6-40.el5_9.2.ia64.rpm
php-mysql-5.1.6-40.el5_9.2.ia64.rpm
php-ncurses-5.1.6-40.el5_9.2.ia64.rpm
php-odbc-5.1.6-40.el5_9.2.ia64.rpm
php-pdo-5.1.6-40.el5_9.2.ia64.rpm
php-pgsql-5.1.6-40.el5_9.2.ia64.rpm
php-snmp-5.1.6-40.el5_9.2.ia64.rpm
php-soap-5.1.6-40.el5_9.2.ia64.rpm
php-xml-5.1.6-40.el5_9.2.ia64.rpm
php-xmlrpc-5.1.6-40.el5_9.2.ia64.rpm

ppc:
php-5.1.6-40.el5_9.2.ppc.rpm
php-bcmath-5.1.6-40.el5_9.2.ppc.rpm
php-cli-5.1.6-40.el5_9.2.ppc.rpm
php-common-5.1.6-40.el5_9.2.ppc.rpm
php-dba-5.1.6-40.el5_9.2.ppc.rpm
php-debuginfo-5.1.6-40.el5_9.2.ppc.rpm
php-devel-5.1.6-40.el5_9.2.ppc.rpm
php-gd-5.1.6-40.el5_9.2.ppc.rpm
php-imap-5.1.6-40.el5_9.2.ppc.rpm
php-ldap-5.1.6-40.el5_9.2.ppc.rpm
php-mbstring-5.1.6-40.el5_9.2.ppc.rpm
php-mysql-5.1.6-40.el5_9.2.ppc.rpm
php-ncurses-5.1.6-40.el5_9.2.ppc.rpm
php-odbc-5.1.6-40.el5_9.2.ppc.rpm
php-pdo-5.1.6-40.el5_9.2.ppc.rpm
php-pgsql-5.1.6-40.el5_9.2.ppc.rpm
php-snmp-5.1.6-40.el5_9.2.ppc.rpm
php-soap-5.1.6-40.el5_9.2.ppc.rpm
php-xml-5.1.6-40.el5_9.2.ppc.rpm
php-xmlrpc-5.1.6-40.el5_9.2.ppc.rpm

s390x:
php-5.1.6-40.el5_9.2.s390x.rpm
php-bcmath-5.1.6-40.el5_9.2.s390x.rpm
php-cli-5.1.6-40.el5_9.2.s390x.rpm
php-common-5.1.6-40.el5_9.2.s390x.rpm
php-dba-5.1.6-40.el5_9.2.s390x.rpm
php-debuginfo-5.1.6-40.el5_9.2.s390x.rpm
php-devel-5.1.6-40.el5_9.2.s390x.rpm
php-gd-5.1.6-40.el5_9.2.s390x.rpm
php-imap-5.1.6-40.el5_9.2.s390x.rpm
php-ldap-5.1.6-40.el5_9.2.s390x.rpm
php-mbstring-5.1.6-40.el5_9.2.s390x.rpm
php-mysql-5.1.6-40.el5_9.2.s390x.rpm
php-ncurses-5.1.6-40.el5_9.2.s390x.rpm
php-odbc-5.1.6-40.el5_9.2.s390x.rpm
php-pdo-5.1.6-40.el5_9.2.s390x.rpm
php-pgsql-5.1.6-40.el5_9.2.s390x.rpm
php-snmp-5.1.6-40.el5_9.2.s390x.rpm
php-soap-5.1.6-40.el5_9.2.s390x.rpm
php-xml-5.1.6-40.el5_9.2.s390x.rpm
php-xmlrpc-5.1.6-40.el5_9.2.s390x.rpm

x86_64:
php-5.1.6-40.el5_9.2.x86_64.rpm
php-bcmath-5.1.6-40.el5_9.2.x86_64.rpm
php-cli-5.1.6-40.el5_9.2.x86_64.rpm
php-common-5.1.6-40.el5_9.2.x86_64.rpm
php-dba-5.1.6-40.el5_9.2.x86_64.rpm
php-debuginfo-5.1.6-40.el5_9.2.x86_64.rpm
php-devel-5.1.6-40.el5_9.2.x86_64.rpm
php-gd-5.1.6-40.el5_9.2.x86_64.rpm
php-imap-5.1.6-40.el5_9.2.x86_64.rpm
php-ldap-5.1.6-40.el5_9.2.x86_64.rpm
php-mbstring-5.1.6-40.el5_9.2.x86_64.rpm
php-mysql-5.1.6-40.el5_9.2.x86_64.rpm
php-ncurses-5.1.6-40.el5_9.2.x86_64.rpm
php-odbc-5.1.6-40.el5_9.2.x86_64.rpm
php-pdo-5.1.6-40.el5_9.2.x86_64.rpm
php-pgsql-5.1.6-40.el5_9.2.x86_64.rpm
php-snmp-5.1.6-40.el5_9.2.x86_64.rpm
php-soap-5.1.6-40.el5_9.2.x86_64.rpm
php-xml-5.1.6-40.el5_9.2.x86_64.rpm
php-xmlrpc-5.1.6-40.el5_9.2.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/#package

7. References:

https://www.redhat.com/security/data/cve/CVE-2009-0689.html
https://access.redhat.com/security/updates/classification/#critical

8. Contact:

The Red Hat security contact is .  More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2014 Red Hat, Inc.
 
< Prev   Next >
    
Partner

 

Latest Features
Peter Smith Releases Linux Network Security Online
Securing a Linux Web Server
Password guessing with Medusa 2.0
Password guessing as an attack vector
Squid and Digest Authentication
Squid and Basic Authentication
Demystifying the Chinese Hacking Industry: Earning 6 Million a Night
Free Online security course (LearnSIA) - A Call for Help
What You Need to Know About Linux Rootkits
Review: A Practical Guide to Fedora and Red Hat Enterprise Linux - Fifth Edition
Yesterday's Edition
Shellshock makes Heartbleed look insignificant
Hacker Group Lizard Squad Takes Down Destiny, Call of Duty, FIFA And More
Partner Sponsor

Community | HOWTOs | Blogs | Features | Book Reviews | Networking
 Security Projects |  Latest News |  Newsletters |  SELinux |  Privacy |  Home
 Hardening |   About Us |   Advertise |   Legal Notice |   RSS |   Guardian Digital
(c)Copyright 2014 Guardian Digital, Inc. All rights reserved.