LinuxSecurity.com
Share your story
The central voice for Linux and Open Source security news
Home News Topics Advisories HOWTOs Features Newsletters About Register

Welcome!
Sign up!
EnGarde Community
Login
Polls
What is the most important Linux security technology?
 
Advisories
Community
Linux Events
Linux User Groups
Link to Us
Security Center
Book Reviews
Security Dictionary
Security Tips
SELinux
White Papers
Featured Blogs
All About Linux
DanWalsh LiveJournal
Securitydistro
Latest Newsletters
Linux Advisory Watch: October 24th, 2014
Linux Security Week: October 20th, 2014
Subscribe
LinuxSecurity Newsletters
E-mail:
Choose Lists:
About our Newsletters
RSS Feeds
Get the LinuxSecurity news you want faster with RSS
Powered By

  
Gentoo: 201310-21 MediaWiki: Multiple vulnerabilities Print E-mail
User Rating:      How can I rate this item?
Posted by Benjamin D. Thomas   
Gentoo Multiple vulnerabilities have been found in MediaWiki, the worst of which could lead to Denial of Service.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201310-21
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: MediaWiki: Multiple vulnerabilities
     Date: October 28, 2013
     Bugs: #460352, #466124, #468110, #471140, #483594
       ID: 201310-21

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in MediaWiki, the worst of
which could lead to Denial of Service.

Background
==========

The MediaWiki wiki web application as used on wikipedia.org.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  www-apps/mediawiki           < 1.21.2                  >= 1.21.2
                                                           *>= 1.20.7
                                                           *>= 1.19.8

Description
===========

Multiple vulnerabilities have been discovered in MediaWiki. Please
review the CVE identifiers referenced below for details.

Impact
======

A remote attacker may be able to execute arbitrary code, perform
man-in-the-middle attacks, obtain sensitive information or perform
cross-site scripting attacks.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All MediaWiki 1.21.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=www-apps/mediawiki-1.21.2"

All MediaWiki 1.20.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=www-apps/mediawiki-1.20.7"

All MediaWiki 1.19.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=www-apps/mediawiki-1.19.8"

References
==========

[  1 ] CVE-2013-1816
       http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-1816
[  2 ] CVE-2013-1817
       http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-1817
[  3 ] CVE-2013-1818
       http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-1818
[  4 ] CVE-2013-1951
       http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-1951
[  5 ] CVE-2013-2031
       http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-2031
[  6 ] CVE-2013-2032
       http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-2032
[  7 ] CVE-2013-2114
       http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-2114
[  8 ] CVE-2013-4301
       http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4301
[  9 ] CVE-2013-4302
       http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4302
[ 10 ] CVE-2013-4303
       http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4303
[ 11 ] CVE-2013-4304
       http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4304
[ 12 ] CVE-2013-4305
       http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4305
[ 13 ] CVE-2013-4306
       http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4306
[ 14 ] CVE-2013-4307
       http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4307
[ 15 ] CVE-2013-4308
       http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4308

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 http://security.gentoo.org/glsa/glsa-201310-21.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License

Copyright 2013 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
 
< Prev   Next >
    
Partner

 

Latest Features
Peter Smith Releases Linux Network Security Online
Securing a Linux Web Server
Password guessing with Medusa 2.0
Password guessing as an attack vector
Squid and Digest Authentication
Squid and Basic Authentication
Demystifying the Chinese Hacking Industry: Earning 6 Million a Night
Free Online security course (LearnSIA) - A Call for Help
What You Need to Know About Linux Rootkits
Review: A Practical Guide to Fedora and Red Hat Enterprise Linux - Fifth Edition
Yesterday's Edition
Pro-Privacy Senator Wyden on Fighting the NSA From Inside the System
NIST to hypervisor admins: secure your systems
Quick PHP patch beats slow research reveal
Partner Sponsor

Community | HOWTOs | Blogs | Features | Book Reviews | Networking
 Security Projects |  Latest News |  Newsletters |  SELinux |  Privacy |  Home
 Hardening |   About Us |   Advertise |   Legal Notice |   RSS |   Guardian Digital
(c)Copyright 2014 Guardian Digital, Inc. All rights reserved.