LinuxSecurity.com
Share your story
The central voice for Linux and Open Source security news
Home News Topics Advisories HOWTOs Features Newsletters About Register

Welcome!
Sign up!
EnGarde Community
Login
Polls
What is the most important Linux security technology?
 
Advisories
Community
Linux Events
Linux User Groups
Link to Us
Security Center
Book Reviews
Security Dictionary
Security Tips
SELinux
White Papers
Featured Blogs
All About Linux
DanWalsh LiveJournal
Securitydistro
Latest Newsletters
Linux Security Week: October 20th, 2014
Linux Advisory Watch: October 17th, 2014
Subscribe
LinuxSecurity Newsletters
E-mail:
Choose Lists:
About our Newsletters
RSS Feeds
Get the LinuxSecurity news you want faster with RSS
Powered By

  
Debian: 2643-1: puppet: Multiple vulnerabilities Print E-mail
User Rating:      How can I rate this item?
Posted by Benjamin D. Thomas   
Debian Multiple vulnerabilities were discovered in Puppet, a centralized configuration management system. CVE-2013-1640 [More...]
- -------------------------------------------------------------------------
Debian Security Advisory DSA-2643-1                   security@debian.org
http://www.debian.org/security/                         Yves-Alexis Perez
March 12, 2013                         http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package        : puppet
Vulnerability  : several
Problem type   : remote
Debian-specific: no
CVE ID         : CVE-2013-1640 CVE-2013-1652 CVE-2013-1653 CVE-2013-1654
                 CVE-2013-1655 CVE-2013-2274 CVE-2013-2275
Debian Bug     :

Multiple vulnerabilities were discovered in Puppet, a centralized
configuration management system.

CVE-2013-1640

    An authenticated malicious client may request its catalog from the puppet
    master, and cause the puppet master to execute arbitrary code. The puppet
    master must be made to invoke the `template` or `inline_template` functions
    during catalog compilation.

CVE-2013-1652

    An authenticated malicious client may retrieve catalogs from the puppet
    master that it is not authorized to access. Given a valid certificate and
    private key, it is possible to construct an HTTP GET request that will
    return a catalog for an arbitrary client.

CVE-2013-1653

    An authenticated malicious client may execute arbitrary code on Puppet
    agents that accept kick connections. Puppet agents are not vulnerable in
    their default configuration. However, if the Puppet agent is configured to
    listen for incoming connections, e.g. listen = true, and the agent's
    auth.conf allows access to the `run` REST endpoint, then an authenticated
    client can construct an HTTP PUT request to execute arbitrary code on the
    agent. This issue is made worse by the fact that puppet agents typically
    run as root.

CVE-2013-1654

    A bug in Puppet allows SSL connections to be downgraded to SSLv2, which is
    known to contain design flaw weaknesses This affects SSL connections
    between puppet agents and master, as well as connections that puppet agents
    make to third party servers that accept SSLv2 connections. Note that SSLv2
    is disabled since OpenSSL 1.0.

CVE-2013-1655

    An unauthenticated malicious client may send requests to the puppet master,
    and have the master load code in an unsafe manner. It only affects users
    whose puppet masters are running ruby 1.9.3 and above.

CVE-2013-2274

    An authenticated malicious client may execute arbitrary code on the
    puppet master in its default configuration. Given a valid certificate and
    private key, a client can construct an HTTP PUT request that is authorized
    to save the client's own report, but the request will actually cause the
    puppet master to execute arbitrary code.

CVE-2013-2275

    The default auth.conf allows an authenticated node to submit a report for
    any other node, which is a problem for compliance. It has been made more
    restrictive by default so that a node is only allowed to save its own
    report.

For the stable distribution (squeeze), these problems have been fixed in
version 2.6.2-5+squeeze7.

For the testing distribution (wheezy), these problems have been fixed in
version 2.7.18-3.

For the unstable distribution (sid), these problems have been fixed in
version 2.7.18-3.

We recommend that you upgrade your puppet packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org
-----BEGIN PGP SIGNATURE-----
 
< Prev   Next >
    
Partner

 

Latest Features
Peter Smith Releases Linux Network Security Online
Securing a Linux Web Server
Password guessing with Medusa 2.0
Password guessing as an attack vector
Squid and Digest Authentication
Squid and Basic Authentication
Demystifying the Chinese Hacking Industry: Earning 6 Million a Night
Free Online security course (LearnSIA) - A Call for Help
What You Need to Know About Linux Rootkits
Review: A Practical Guide to Fedora and Red Hat Enterprise Linux - Fifth Edition
Yesterday's Edition
USB is now UEC (use with extreme caution)
iPhone Encryption and the Return of the Crypto Wars
Partner Sponsor

Community | HOWTOs | Blogs | Features | Book Reviews | Networking
 Security Projects |  Latest News |  Newsletters |  SELinux |  Privacy |  Home
 Hardening |   About Us |   Advertise |   Legal Notice |   RSS |   Guardian Digital
(c)Copyright 2014 Guardian Digital, Inc. All rights reserved.