LinuxSecurity.com
Share your story
The central voice for Linux and Open Source security news
Home News Topics Advisories HOWTOs Features Newsletters About Register

Welcome!
Sign up!
EnGarde Community
Login
Polls
What is the most important Linux security technology?
 
Advisories
Community
Linux Events
Linux User Groups
Link to Us
Security Center
Book Reviews
Security Dictionary
Security Tips
SELinux
White Papers
Featured Blogs
All About Linux
DanWalsh LiveJournal
Securitydistro
Latest Newsletters
Linux Advisory Watch: November 28th, 2014
Linux Advisory Watch: November 21st, 2014
Subscribe
LinuxSecurity Newsletters
E-mail:
Choose Lists:
About our Newsletters
RSS Feeds
Get the LinuxSecurity news you want faster with RSS
Powered By

  
Gentoo: 201209-24 PostgreSQL: Multiple vulnerabilities Print E-mail
User Rating:      How can I rate this item?
Posted by Benjamin D. Thomas   
Gentoo Multiple vulnerabilities have been found in PostgreSQL which may allow a remote attacker to conduct several attacks.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201209-24
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: PostgreSQL: Multiple vulnerabilities
     Date: September 28, 2012
     Bugs: #406037, #419727, #431766
       ID: 201209-24

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in PostgreSQL which may allow
a remote attacker to conduct several attacks.

Background
==========

PostgreSQL is an open source object-relational database management
system.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  dev-db/postgresql-server
                                  < 9.1.5                  *>= 8.3.20
                                                           *>= 8.4.13
                                                            *>= 9.0.9
                                                             >= 9.1.5

Description
===========

Multiple vulnerabilities have been discovered in PostgreSQL. Please
review the CVE identifiers referenced below for details.

Impact
======

A remote attacker could spoof SSL connections. Furthermore, a remote
authenticated attacker could cause a Denial of Service, read and write
arbitrary files, inject SQL commands into dump scripts, or bypass
database restrictions to execute database functions.

A context-dependent attacker could more easily obtain access via
authentication attempts with an initial substring of the intended
password.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PostgreSQL 9.1 server users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-db/postgresql-server-9.1.5"

All PostgreSQL 9.0 server users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-db/postgresql-server-9.0.9"

All PostgreSQL 8.4 server users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot -v ">=dev-db/postgresql-server-8.4.13"

All PostgreSQL 8.3 server users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot -v ">=dev-db/postgresql-server-8.3.20"

References
==========

[ 1 ] CVE-2012-0866
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-0866
[ 2 ] CVE-2012-0867
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-0867
[ 3 ] CVE-2012-0868
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-0868
[ 4 ] CVE-2012-2143
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2143
[ 5 ] CVE-2012-2655
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2655
[ 6 ] CVE-2012-3488
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-3488
[ 7 ] CVE-2012-3489
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-3489

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 http://security.gentoo.org/glsa/glsa-201209-24.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License

Copyright 2012 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
 
< Prev   Next >
    
Partner

 

Latest Features
Peter Smith Releases Linux Network Security Online
Securing a Linux Web Server
Password guessing with Medusa 2.0
Password guessing as an attack vector
Squid and Digest Authentication
Squid and Basic Authentication
Demystifying the Chinese Hacking Industry: Earning 6 Million a Night
Free Online security course (LearnSIA) - A Call for Help
What You Need to Know About Linux Rootkits
Review: A Practical Guide to Fedora and Red Hat Enterprise Linux - Fifth Edition
Yesterday's Edition
Hacker Lexicon: What Is the Computer Fraud and Abuse Act?
World's best threat detection pwned by HOBBIT
Partner Sponsor

Community | HOWTOs | Blogs | Features | Book Reviews | Networking
 Security Projects |  Latest News |  Newsletters |  SELinux |  Privacy |  Home
 Hardening |   About Us |   Advertise |   Legal Notice |   RSS |   Guardian Digital
(c)Copyright 2014 Guardian Digital, Inc. All rights reserved.