LinuxSecurity.com
Share your story
The central voice for Linux and Open Source security news
Home News Topics Advisories HOWTOs Features Newsletters About Register

Welcome!
Sign up!
EnGarde Community
Login
Polls
What is the most important Linux security technology?
 
Advisories
Community
Linux Events
Linux User Groups
Link to Us
Security Center
Book Reviews
Security Dictionary
Security Tips
SELinux
White Papers
Featured Blogs
All About Linux
DanWalsh LiveJournal
Securitydistro
Latest Newsletters
Linux Security Week: October 20th, 2014
Linux Advisory Watch: October 17th, 2014
Subscribe
LinuxSecurity Newsletters
E-mail:
Choose Lists:
About our Newsletters
RSS Feeds
Get the LinuxSecurity news you want faster with RSS
Powered By

  
Fedora 10 Update: postgresql-8.3.8-1.fc10 Print E-mail
User Rating:      How can I rate this item?
Posted by Benjamin D. Thomas   
Fedora Update to PostgreSQL 8.3.8, for various fixes described at http://www.postgresql.org/docs/8.3/static/release-8-3-8.html including three security issues
--------------------------------------------------------------------------------
Fedora Update Notification
FEDORA-2009-9474
2009-09-11 22:39:13
--------------------------------------------------------------------------------

Name        : postgresql
Product     : Fedora 10
Version     : 8.3.8
Release     : 1.fc10
URL         : http://www.postgresql.org/
Summary     : PostgreSQL client programs and libraries
Description :
PostgreSQL is an advanced Object-Relational database management system
(DBMS) that supports almost all SQL constructs (including
transactions, subselects and user-defined types and functions). The
postgresql package includes the client programs and libraries that
you'll need to access a PostgreSQL DBMS server.  These PostgreSQL
client programs are programs that directly manipulate the internal
structure of PostgreSQL databases on a PostgreSQL server. These client
programs can be located on the same machine with the PostgreSQL
server, or may be on a remote machine which accesses a PostgreSQL
server over a network connection. This package contains the docs
in HTML for the whole package, as well as command-line utilities for
managing PostgreSQL databases on a PostgreSQL server.

If you want to manipulate a PostgreSQL database on a remote PostgreSQL
server, you need this package. You also need to install this package
if you're installing the postgresql-server package.

--------------------------------------------------------------------------------
Update Information:

Update to PostgreSQL 8.3.8, for various fixes described at
http://www.postgresql.org/docs/8.3/static/release-8-3-8.html  including three
security issues
--------------------------------------------------------------------------------
ChangeLog:

* Wed Sep  9 2009 Tom Lane  8.3.8-1
- Update to PostgreSQL 8.3.8, for various fixes described at
  http://www.postgresql.org/docs/8.3/static/release-8-3-8.html
  including three security issues
Related: #522084
Related: #522085
Related: #522092
* Thu Aug 20 2009 Tom "spot" Callaway  8.3.7-1.1
- fix license tag
* Sat Mar 21 2009 Tom Lane  8.3.7-1
- Update to PostgreSQL 8.3.7, for various fixes described at
  http://www.postgresql.org/docs/8.3/static/release-8-3-7.html
  notably the fix for CVE-2009-0922
* Mon Mar  9 2009 Oliver Falk  8.3.6-2
- Use -O1 on alpha, as on sparc64
- Renable selftests on alpha again
* Sat Feb  7 2009 Tom Lane  8.3.6-1
- Update to PostgreSQL 8.3.6, for various fixes described at
  http://www.postgresql.org/docs/8.3/static/release-8-3-6.html
* Wed Jan 21 2009 Dennis Gilmore  8.3.5-1.1
- use -O1 on sparc64
* Sun Nov  2 2008 Tom Lane  8.3.5-1
- Update to PostgreSQL 8.3.5.
- Improve display from init script's initdb action, per Michael Schwendt
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #522084 - postgresql: LDAP authentication bypass when anonymous LDAP bind are allowed
        https://bugzilla.redhat.com/show_bug.cgi?id=522084
  [ 2 ] Bug #522085 - postgresql: SQL privilege escalation, incomplete fix for CVE-2007-6600
        https://bugzilla.redhat.com/show_bug.cgi?id=522085
  [ 3 ] Bug #522092 - postgresql: authenticated user server DoS via plugin re-LOAD-ing
        https://bugzilla.redhat.com/show_bug.cgi?id=522092
--------------------------------------------------------------------------------

This update can be installed with the "yum" update program.  Use 
su -c 'yum update postgresql' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key.  More details on the
GPG keys used by the Fedora Project can be found at
http://fedoraproject.org/keys
--------------------------------------------------------------------------------

_______________________________________________
Fedora-package-announce mailing list
Fedora-package-announce@redhat.com
http://www.redhat.com/mailman/listinfo/fedora-package-announce
 
< Prev   Next >
    
Partner

 

Latest Features
Peter Smith Releases Linux Network Security Online
Securing a Linux Web Server
Password guessing with Medusa 2.0
Password guessing as an attack vector
Squid and Digest Authentication
Squid and Basic Authentication
Demystifying the Chinese Hacking Industry: Earning 6 Million a Night
Free Online security course (LearnSIA) - A Call for Help
What You Need to Know About Linux Rootkits
Review: A Practical Guide to Fedora and Red Hat Enterprise Linux - Fifth Edition
Yesterday's Edition
Pro-Privacy Senator Wyden on Fighting the NSA From Inside the System
NIST to hypervisor admins: secure your systems
Quick PHP patch beats slow research reveal
Partner Sponsor

Community | HOWTOs | Blogs | Features | Book Reviews | Networking
 Security Projects |  Latest News |  Newsletters |  SELinux |  Privacy |  Home
 Hardening |   About Us |   Advertise |   Legal Notice |   RSS |   Guardian Digital
(c)Copyright 2014 Guardian Digital, Inc. All rights reserved.