LinuxSecurity.com
Share your story
The central voice for Linux and Open Source security news
Home News Topics Advisories HOWTOs Features Newsletters About Register

Welcome!
Sign up!
EnGarde Community
Login
Polls
What is the most important Linux security technology?
 
Advisories
Community
Linux Events
Linux User Groups
Link to Us
Security Center
Book Reviews
Security Dictionary
Security Tips
SELinux
White Papers
Featured Blogs
All About Linux
DanWalsh LiveJournal
Securitydistro
Latest Newsletters
Linux Security Week: September 15th, 2014
Linux Security Week: September 8th, 2014
Subscribe
LinuxSecurity Newsletters
E-mail:
Choose Lists:
About our Newsletters
RSS Feeds
Get the LinuxSecurity news you want faster with RSS
Powered By

  
Gentoo: ModPlug User-assisted execution of arbitrary code Print E-mail
User Rating:      How can I rate this item?
Posted by Benjamin D. Thomas   
Gentoo ModPlug contains several buffer overflows that could lead to the execution of arbitrary code.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200907-07
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: ModPlug: User-assisted execution of arbitrary code
      Date: July 12, 2009
      Bugs: #266913
        ID: 200907-07

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

ModPlug contains several buffer overflows that could lead to the
execution of arbitrary code.

Background
==========

ModPlug is a library for playing MOD-like music.

Affected packages
=================

    -------------------------------------------------------------------
     Package                     /  Vulnerable  /           Unaffected
    -------------------------------------------------------------------
  1  media-libs/libmodplug            < 0.8.7                 >= 0.8.7
  2  media-libs/gst-plugins-bad      < 0.10.11              >= 0.10.11
    -------------------------------------------------------------------
     2 affected packages on all of their supported architectures.
    -------------------------------------------------------------------

Description
===========

Two vulnerabilities have been reported in ModPlug:

* dummy reported an integer overflow in the CSoundFile::ReadMed()
  function when processing a MED file with a crafted song comment or
  song name, which triggers a heap-based buffer overflow
  (CVE-2009-1438).

* Manfred Tremmel and Stanislav Brabec reported a buffer overflow in
  the PATinst() function when processing a long instrument name
  (CVE-2009-1513).

The GStreamer Bad plug-ins (gst-plugins-bad) before 0.10.11 built a
vulnerable copy of ModPlug.

Impact
======

A remote attacker could entice a user to read specially crafted files,
possibly resulting in the execution of arbitrary code with the
privileges of the user running the application.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All ModPlug users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=media-libs/libmodplug-0.8.7"

gst-plugins-bad 0.10.11 and later versions do not include the ModPlug
plug-in (it has been moved to media-plugins/gst-plugins-modplug). All
gst-plugins-bad users should upgrade to the latest version and install
media-plugins/gst-plugins-modplug:

    # emerge --sync
    # emerge --ask --oneshot -v ">=media-libs/gst-plugins-bad-0.10.11"
    # emerge --ask --verbose "media-plugins/gst-plugins-modplug"

References
==========

  [ 1 ] CVE-2009-1438
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-1438
  [ 2 ] CVE-2009-1513
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-1513

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200907-07.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2009 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
 
< Prev   Next >
    
Partner

 

Latest Features
Peter Smith Releases Linux Network Security Online
Securing a Linux Web Server
Password guessing with Medusa 2.0
Password guessing as an attack vector
Squid and Digest Authentication
Squid and Basic Authentication
Demystifying the Chinese Hacking Industry: Earning 6 Million a Night
Free Online security course (LearnSIA) - A Call for Help
What You Need to Know About Linux Rootkits
Review: A Practical Guide to Fedora and Red Hat Enterprise Linux - Fifth Edition
Yesterday's Edition
Today's Security Hacks Are After More Than Bank Info
How Boston Children's Hospital Hit Back at Anonymous
SNMP DDoS Scans Spoof Google Public DNS Server
Partner Sponsor

Community | HOWTOs | Blogs | Features | Book Reviews | Networking
 Security Projects |  Latest News |  Newsletters |  SELinux |  Privacy |  Home
 Hardening |   About Us |   Advertise |   Legal Notice |   RSS |   Guardian Digital
(c)Copyright 2014 Guardian Digital, Inc. All rights reserved.