LinuxSecurity.com
Share your story
The central voice for Linux and Open Source security news
Home News Topics Advisories HOWTOs Features Newsletters About Register

Welcome!
Sign up!
EnGarde Community
Login
Polls
What is the most important Linux security technology?
 
Advisories
Community
Linux Events
Linux User Groups
Link to Us
Security Center
Book Reviews
Security Dictionary
Security Tips
SELinux
White Papers
Featured Blogs
All About Linux
DanWalsh LiveJournal
Securitydistro
Latest Newsletters
Linux Security Week: April 7th, 2014
Linux Advisory Watch: April 4th, 2014
Subscribe
LinuxSecurity Newsletters
E-mail:
Choose Lists:
About our Newsletters
RSS Feeds
Get the LinuxSecurity news you want faster with RSS
Powered By

  
Gentoo: Openfire Multiple vulnerabilities Print E-mail
User Rating:      How can I rate this item?
Posted by Benjamin D. Thomas   
Gentoo Multiple vulnerabilities were discovered in Openfire, the worst of which may allow remote execution of arbitrary code.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200904-01
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Openfire: Multiple vulnerabilities
      Date: April 02, 2009
      Bugs: #246008, #254309
        ID: 200904-01

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=3D=3D=3D=3D=3D=3D=3D=3D

Multiple vulnerabilities were discovered in Openfire, the worst of
which may allow remote execution of arbitrary code.

Background
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

Ignite Realtime Openfire is a fast real-time collaboration server.

Affected packages
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

    -------------------------------------------------------------------
     Package          /  Vulnerable  /                      Unaffected
    -------------------------------------------------------------------
  1  net-im/openfire       < 3.6.3                            >=3D 3.6.3

Description
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

Two vulnerabilities have been reported by Federico Muttis, from CORE
IMPACT's Exploit Writing Team:

* Multiple missing or incomplete input validations in several .jsps
  (CVE-2009-0496).

* Incorrect input validation of the "log" parameter in log.jsp
  (CVE-2009-0497).

Multiple vulnerabilities have been reported by Andreas Kurtz:

* Erroneous built-in exceptions to input validation in login.jsp
  (CVE-2008-6508).

* Unsanitized user input to the "type" parameter in
  sipark-log-summary.jsp used in SQL statement. (CVE-2008-6509)

* A Cross-Site-Scripting vulnerability due to unsanitized input to
  the "url" parameter. (CVE-2008-6510, CVE-2008-6511)

Impact
=3D=3D=3D=3D=3D=3D

A remote attacker could execute arbitrary code on clients' systems by
uploading a specially crafted plugin, bypassing authentication.
Additionally, an attacker could read arbitrary files on the server or
execute arbitrary SQL statements. Depending on the server's
configuration the attacker might also execute code on the server via an
SQL injection.

Workaround
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

There is no known workaround at this time.

Resolution
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

All Openfire users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=3Dnet-im/openfire-3.6.3"

References
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

  [ 1 ] CVE-2008-6508
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCVE-2008-6508
  [ 2 ] CVE-2008-6509
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCVE-2008-6509
  [ 3 ] CVE-2008-6510
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCVE-2008-6510
  [ 4 ] CVE-2008-6511
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCVE-2008-6511
  [ 5 ] CVE-2009-0496
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCVE-2009-0496
  [ 6 ] CVE-2009-0497
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCVE-2009-0497

Availability
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200904-01.xml

Concerns?
=3D=3D=3D=3D=3D=3D=3D=3D=3D

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=3D=3D=3D=3D=3D=3D=3D

Copyright 2009 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
 
< Prev   Next >
    
Partner

 

Latest Features
Peter Smith Releases Linux Network Security Online
Securing a Linux Web Server
Password guessing with Medusa 2.0
Password guessing as an attack vector
Squid and Digest Authentication
Squid and Basic Authentication
Demystifying the Chinese Hacking Industry: Earning 6 Million a Night
Free Online security course (LearnSIA) - A Call for Help
What You Need to Know About Linux Rootkits
Review: A Practical Guide to Fedora and Red Hat Enterprise Linux - Fifth Edition
Yesterday's Edition
Hackers From China Waste Little Time in Exploiting Heartbleed
Parent gabfest Mumsnet hit by SSL bug: My heart bleeds, grins hacker
Why a hacker got paid for finding the Heartbleed bug
Partner Sponsor

Community | HOWTOs | Blogs | Features | Book Reviews | Networking
 Security Projects |  Latest News |  Newsletters |  SELinux |  Privacy |  Home
 Hardening |   About Us |   Advertise |   Legal Notice |   RSS |   Guardian Digital
(c)Copyright 2014 Guardian Digital, Inc. All rights reserved.