LinuxSecurity.com
Share your story
The central voice for Linux and Open Source security news
Home News Topics Advisories HOWTOs Features Newsletters About Register

Welcome!
Sign up!
EnGarde Community
Login
Polls
What is the most important Linux security technology?
 
Advisories
Community
Linux Events
Linux User Groups
Link to Us
Security Center
Book Reviews
Security Dictionary
Security Tips
SELinux
White Papers
Featured Blogs
All About Linux
DanWalsh LiveJournal
Securitydistro
Latest Newsletters
Linux Advisory Watch: October 31st, 2014
Linux Security Week: October 27th, 2014
Subscribe
LinuxSecurity Newsletters
E-mail:
Choose Lists:
About our Newsletters
RSS Feeds
Get the LinuxSecurity news you want faster with RSS
Powered By

  
Fedora 9 Update: moodle-1.9.4-6.fc9 Print E-mail
User Rating:      How can I rate this item?
Posted by Benjamin D. Thomas   
Fedora CVE-2009-1171: The TeX filter in Moodle 1.6 before 1.6.9+, 1.7 before 1.7.7+, 1.8 before 1.8.9, and 1.9 before 1.9.5 allows user-assisted attackers to read arbitrary files via an input command in a "$$" sequence, which causes LaTeX to include the contents of the file.
--------------------------------------------------------------------------------
Fedora Update Notification
FEDORA-2009-3283
2009-04-02 16:30:10
--------------------------------------------------------------------------------

Name        : moodle
Product     : Fedora 9
Version     : 1.9.4
Release     : 6.fc9
URL         : http://moodle.org/
Summary     : A Course Management System
Description :
Moodle is a course management system (CMS) - a free, Open Source software
package designed using sound pedagogical principles, to help educators create
effective online learning communities.

--------------------------------------------------------------------------------
Update Information:

CVE-2009-1171:  The TeX filter in Moodle 1.6 before 1.6.9+, 1.7 before 1.7.7+,
1.8  before 1.8.9, and 1.9 before 1.9.5 allows user-assisted attackers to  read
arbitrary files via an input command in a "$$" sequence, which  causes LaTeX to
include the contents of the file.     Upstream bug and CVS commit:
http://tracker.moodle.org/browse/MDL-18552
http://cvs.moodle.org/moodle/filter/tex/filter.php?r1=1.18.4.4&r2=1.18.4.5
References:
http://www.securityfocus.com/archive/1/archive/1/502231/100/0/threaded
http://www.securityfocus.com/bid/34278  http://www.milw0rm.com/exploits/8297
Upstream further reported that the above patch is not sufficient and following
change should be used instead:    For >=1.9.0:  http://git.catalyst.net.nz/gw?p=
moodle-r2.git;a=commitdiff;h=b950f126018a9e16a298d278375a0eedf791e5dd    For
1.6.* - 1.8.*:  http://git.catalyst.net.nz/gw?p=moodle-r2.git;a=commitdiff;h=cc9
bf1486e7ea9e8cda1e4522b96e07245459a0d
--------------------------------------------------------------------------------
ChangeLog:

* Wed Apr  1 2009 Jon Ciesla  - 1.9.4-6
- Patch for CVE-2009-1171, BZ 493109.
* Tue Mar 24 2009 Jon Ciesla  - 1.9.4-5
- Update for freefont->gnu-free-fonts change.
* Thu Feb 26 2009 Jon Ciesla  - 1.9.4-4
- Fix for symlink dir replacement.
* Mon Feb 23 2009 Jon Ciesla  - 1.9.4-2
- Putting back bundled MagpieRSS due to incompatibility, BZ 486777.
- Corrected moodle-cron.
* Tue Feb 10 2009 Jon Ciesla  - 1.9.4-1
- Update to 1.9.4 to fix CVE-2009-0499,0500,0501,0502.
* Tue Jan 27 2009 Jon Ciesla  - 1.9.3-6
- Dropped and symlinked to khmeros-base-fonts.
* Tue Jan 20 2009 Jon Ciesla  - 1.9.3-5
- Dropped and symlinked illegal sm and to fonts.
- Symlinking to FreeSans.
- Drop spell-check-logic.cgi, CVE-2008-5153, per upstream, BZ 472117, 472119, 472120.
* Wed Dec 17 2008 Jon Ciesla  - 1.9.3-4
- Texed fix, BZ 476709.
* Fri Nov  7 2008 Jon Ciesla  - 1.9.3-3
- Moved to weekly downloaded 11/7/08 to fix Snoopy CVE-2008-4796.
* Fri Oct 31 2008 Jon Ciesla  - 1.9.3-2
- Fix for BZ 468929, overactive cron job.
* Wed Oct 22 2008 Jon Ciesla  - 1.9.3-1
- Updated to 1.9.3.
- Updated language packs to 22 Oct 2008 versions.
* Wed Aug  6 2008 Jon Ciesla  - 1.9.2-2
- Remove bundled adodb, use system php-adodb. BZ 457886.
- Remove bundled magpie, use system php-magpierss. BZ 457886.
* Wed Aug  6 2008 Jon Ciesla  - 1.9.2-1
- Updated to 1.9.2.
- Remove bundled Smarty, use system php-Smarty. BZ 457886.
- Updated language packs to 06 Aug 2008 versions.
* Mon Jun 23 2008 Jon Ciesla  - 1.9.1-2
- Add php Requires, BZ 452341.
* Thu May 22 2008 Jon Ciesla  - 1.9.1-1
- Update to 1.9.1.
- Updated language packs to 22 May 2008 versions.
- Added Welsh, Uzbek support.
- Added php-xmlrpc Requires.
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #493109 - CVE-2009-1171 moodle: file disclosure flaw in TeX filter
        https://bugzilla.redhat.com/show_bug.cgi?id=493109
--------------------------------------------------------------------------------

This update can be installed with the "yum" update program.  Use 
su -c 'yum update moodle' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key.  More details on the
GPG keys used by the Fedora Project can be found at
http://fedoraproject.org/keys
--------------------------------------------------------------------------------

_______________________________________________
Fedora-package-announce mailing list
Fedora-package-announce@redhat.com
http://www.redhat.com/mailman/listinfo/fedora-package-announce
 
< Prev   Next >
    
Partner

 

Latest Features
Peter Smith Releases Linux Network Security Online
Securing a Linux Web Server
Password guessing with Medusa 2.0
Password guessing as an attack vector
Squid and Digest Authentication
Squid and Basic Authentication
Demystifying the Chinese Hacking Industry: Earning 6 Million a Night
Free Online security course (LearnSIA) - A Call for Help
What You Need to Know About Linux Rootkits
Review: A Practical Guide to Fedora and Red Hat Enterprise Linux - Fifth Edition
Yesterday's Edition
Pirate Bay founder guilty in historic hacker case
Parallels CTO: Linux container security is not the problem
Advisory says to assume all Drupal 7 websites are compromised
Partner Sponsor

Community | HOWTOs | Blogs | Features | Book Reviews | Networking
 Security Projects |  Latest News |  Newsletters |  SELinux |  Privacy |  Home
 Hardening |   About Us |   Advertise |   Legal Notice |   RSS |   Guardian Digital
(c)Copyright 2014 Guardian Digital, Inc. All rights reserved.