LinuxSecurity.com
Share your story
The central voice for Linux and Open Source security news
Home News Topics Advisories HOWTOs Features Newsletters About Register

Welcome!
Sign up!
EnGarde Community
Login
Polls
What is the most important Linux security technology?
 
Advisories
Community
Linux Events
Linux User Groups
Link to Us
Security Center
Book Reviews
Security Dictionary
Security Tips
SELinux
White Papers
Featured Blogs
All About Linux
DanWalsh LiveJournal
Securitydistro
Latest Newsletters
Linux Advisory Watch: October 17th, 2014
Linux Security Week: October 13th, 2014
Subscribe
LinuxSecurity Newsletters
E-mail:
Choose Lists:
About our Newsletters
RSS Feeds
Get the LinuxSecurity news you want faster with RSS
Powered By

  
Ubuntu: PostgreSQL vulnerability Print E-mail
User Rating:      How can I rate this item?
Posted by Benjamin D. Thomas   
Ubuntu PostgreSQL did not handle the "search_path" configuration option in a secure way for functions declared as "SECURITY DEFINER". Previously, an attacker could override functions and operators used by the security definer function to execute arbitrary SQL commands with the privileges of the user who created the security definer function.
=========================================================== 
Ubuntu Security Notice USN-454-1             April 26, 2007
postgresql-8.1, postgresql-8.2 vulnerability
CVE-2007-2138
===========================================================

A security issue affects the following Ubuntu releases:

Ubuntu 6.06 LTS
Ubuntu 6.10
Ubuntu 7.04

This advisory also applies to the corresponding versions of
Kubuntu, Edubuntu, and Xubuntu.

The problem can be corrected by upgrading your system to the
following package versions:

Ubuntu 6.06 LTS:
  postgresql-8.1                           8.1.9-0ubuntu0.6.06

Ubuntu 6.10:
  postgresql-8.1                           8.1.9-0ubuntu0.6.10

Ubuntu 7.04:
  postgresql-8.2                           8.2.4-0ubuntu0.7.04

In general, a standard system upgrade is sufficient to effect the
necessary changes.

Details follow:

PostgreSQL did not handle the "search_path" configuration option in a
secure way for functions declared as "SECURITY DEFINER". 

Previously, an attacker could override functions and operators used by
the security definer function to execute arbitrary SQL commands with
the privileges of the user who created the security definer function.
The updated version does not search the temporary table schema for
functions and operators any more.

Similarly, an attacker could put forged tables into the temporary
table schema to trick the security definer function into using
attacker defined data for processing. This was possible because the
temporary schema was always implicitly searched first before all other
entries in "search_path". The updated version now supports explicit
placement of the temporary schema. Please see the HTML documentation
or the manual page for "CREATE FUNCTION" for details and an example
how to write security definer functions in a secure way.


Updated packages for Ubuntu 6.06 LTS:

  Source archives:

    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-8.1_8.1.9-0ubuntu0.6.06.diff.gz
      Size/MD5:    25680 c8dcb92c9d3e5059a235463f1e73d918
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-8.1_8.1.9-0ubuntu0.6.06.dsc
      Size/MD5:     1121 8be59c06b28d9c68161df198c3f70964
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-8.1_8.1.9.orig.tar.gz
      Size/MD5: 11422807 a77d87607ee8f264c7bc9581e9048bb2

  Architecture independent packages:

    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-doc-8.1_8.1.9-0ubuntu0.6.06_all.deb
      Size/MD5:  1459666 bf5c81ac3954cbca6c1a966845e1eade

  amd64 architecture (Athlon64, Opteron, EM64T Xeon)

    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libecpg-compat2_8.1.9-0ubuntu0.6.06_amd64.deb
      Size/MD5:   158258 99703d2326077bd91a07c735fca4393f
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libecpg-dev_8.1.9-0ubuntu0.6.06_amd64.deb
      Size/MD5:   349862 aea8e61788ee4c824744be6927d57a66
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libecpg5_8.1.9-0ubuntu0.6.06_amd64.deb
      Size/MD5:   178980 f86abe6f9fb9c48f23d24e99d0398d74
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libpgtypes2_8.1.9-0ubuntu0.6.06_amd64.deb
      Size/MD5:   180374 3ff8b243c42ee96205075df99db336b6
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libpq-dev_8.1.9-0ubuntu0.6.06_amd64.deb
      Size/MD5:   313812 76e05d5b34bed281fea1fff2bfb4f57f
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libpq4_8.1.9-0ubuntu0.6.06_amd64.deb
      Size/MD5:   211962 aff8b24ae2b177df4654d2cfd5d44e38
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-8.1_8.1.9-0ubuntu0.6.06_amd64.deb
      Size/MD5:  3234342 919d04b62e5994496530dcfdc72ae7af
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-client-8.1_8.1.9-0ubuntu0.6.06_amd64.deb
      Size/MD5:   788204 903d63291b5ca11bd357ae671e14f79c
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-contrib-8.1_8.1.9-0ubuntu0.6.06_amd64.deb
      Size/MD5:   619778 c5a061683a75292653ac9904b86f5a01
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-plperl-8.1_8.1.9-0ubuntu0.6.06_amd64.deb
      Size/MD5:   174950 d9538ab098e6ac21ae42a7951e20d541
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-plpython-8.1_8.1.9-0ubuntu0.6.06_amd64.deb
      Size/MD5:   169110 3374672bfb17259e75db1b240f521de4
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-pltcl-8.1_8.1.9-0ubuntu0.6.06_amd64.deb
      Size/MD5:   169198 5f573e64710d5e6514ee99e84391bd18
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-server-dev-8.1_8.1.9-0ubuntu0.6.06_amd64.deb
      Size/MD5:   602154 89ac9e12d5e2ef0e85a4a64f725fe41f

  i386 architecture (x86 compatible Intel/AMD)

    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libecpg-compat2_8.1.9-0ubuntu0.6.06_i386.deb
      Size/MD5:   157248 8ee9c4b50bb58a03f685f4d8ad3111a1
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libecpg-dev_8.1.9-0ubuntu0.6.06_i386.deb
      Size/MD5:   341042 bf0065ba368c37cc6875731a9ad8945e
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libecpg5_8.1.9-0ubuntu0.6.06_i386.deb
      Size/MD5:   176686 194cc4b608cb60bd2278f26fd2491dad
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libpgtypes2_8.1.9-0ubuntu0.6.06_i386.deb
      Size/MD5:   178546 524dcc25c7af3ff977ccd46058bd8bce
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libpq-dev_8.1.9-0ubuntu0.6.06_i386.deb
      Size/MD5:   302310 a6801fa92e15c1e4d651add789907278
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libpq4_8.1.9-0ubuntu0.6.06_i386.deb
      Size/MD5:   204776 c6f6697624ff1dc906f8e24435fb8a2b
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-8.1_8.1.9-0ubuntu0.6.06_i386.deb
      Size/MD5:  3038116 78cdad8bb8798462949242ede7b40cfc
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-client-8.1_8.1.9-0ubuntu0.6.06_i386.deb
      Size/MD5:   716604 87acd971db7ca596bdff1d9d94611494
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-contrib-8.1_8.1.9-0ubuntu0.6.06_i386.deb
      Size/MD5:   574406 bbdc24c1f7efb5c2835027912f6fb28c
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-plperl-8.1_8.1.9-0ubuntu0.6.06_i386.deb
      Size/MD5:   173188 073b79674044922ebaad1acf753cd43a
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-plpython-8.1_8.1.9-0ubuntu0.6.06_i386.deb
      Size/MD5:   166312 56d1c3413aaffaa755ec29eea0adc437
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-pltcl-8.1_8.1.9-0ubuntu0.6.06_i386.deb
      Size/MD5:   167682 c1b05d417e19acacd99172d7fbdabc45
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-server-dev-8.1_8.1.9-0ubuntu0.6.06_i386.deb
      Size/MD5:   602130 374d74ff7dad8939e9c7c974456d9a2c

  powerpc architecture (Apple Macintosh G3/G4/G5)

    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libecpg-compat2_8.1.9-0ubuntu0.6.06_powerpc.deb
      Size/MD5:   158940 05c228089827b919f13bcd71b9f9788b
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libecpg-dev_8.1.9-0ubuntu0.6.06_powerpc.deb
      Size/MD5:   346524 3295f506a00d0f47608915626c828452
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libecpg5_8.1.9-0ubuntu0.6.06_powerpc.deb
      Size/MD5:   179804 927c56d31779d1ff33628c349e6b9b7f
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libpgtypes2_8.1.9-0ubuntu0.6.06_powerpc.deb
      Size/MD5:   182884 e150e5ef3fc7215215c1e17b62ec5ad8
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libpq-dev_8.1.9-0ubuntu0.6.06_powerpc.deb
      Size/MD5:   308290 fcc2776e9077b229b20a7eed7a9fc811
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libpq4_8.1.9-0ubuntu0.6.06_powerpc.deb
      Size/MD5:   208448 44a290904326a8caf57ca3f8abb0949c
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-8.1_8.1.9-0ubuntu0.6.06_powerpc.deb
      Size/MD5:  3528038 68e8913bd05485b41b654ef575307e69
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-client-8.1_8.1.9-0ubuntu0.6.06_powerpc.deb
      Size/MD5:   788166 e9b1fb3c48f50373e9d9406fde151471
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-contrib-8.1_8.1.9-0ubuntu0.6.06_powerpc.deb
      Size/MD5:   635928 43c1f962f969d5f1c53af92849aa1ff2
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-plperl-8.1_8.1.9-0ubuntu0.6.06_powerpc.deb
      Size/MD5:   174660 ea5a73377c0ab06e2d1235267514cc3e
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-plpython-8.1_8.1.9-0ubuntu0.6.06_powerpc.deb
      Size/MD5:   169052 cd6e5d8dc88dc0d29a4ab0e3969b4909
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-pltcl-8.1_8.1.9-0ubuntu0.6.06_powerpc.deb
      Size/MD5:   169990 084385dfeeb9abe95568c9d6657d8aa5
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-server-dev-8.1_8.1.9-0ubuntu0.6.06_powerpc.deb
      Size/MD5:   602132 8b775ffa401e5c87d1120ae30d911d05

  sparc architecture (Sun SPARC/UltraSPARC)

    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libecpg-compat2_8.1.9-0ubuntu0.6.06_sparc.deb
      Size/MD5:   156942 8256ad3537d8803b07a7ac1fa6d0cb91
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libecpg-dev_8.1.9-0ubuntu0.6.06_sparc.deb
      Size/MD5:   337694 b5d7c5e0ec964d5b2b5adc24f73afc64
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libecpg5_8.1.9-0ubuntu0.6.06_sparc.deb
      Size/MD5:   177252 7e3effdef8c0fbac39246cf1dd0ac87b
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libpgtypes2_8.1.9-0ubuntu0.6.06_sparc.deb
      Size/MD5:   178010 519874ccc7164be2ad5e45a56927cd5b
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libpq-dev_8.1.9-0ubuntu0.6.06_sparc.deb
      Size/MD5:   304392 a31d632dc0a529c7dc043b06ed7aac71
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libpq4_8.1.9-0ubuntu0.6.06_sparc.deb
      Size/MD5:   205068 fb282ac163b390716fbf3cc3b918ad0f
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-8.1_8.1.9-0ubuntu0.6.06_sparc.deb
      Size/MD5:  3402248 1296972532e9b168e2cf79d7a572e093
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-client-8.1_8.1.9-0ubuntu0.6.06_sparc.deb
      Size/MD5:   744618 377b9edbabb3f37330da196c53df4131
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-contrib-8.1_8.1.9-0ubuntu0.6.06_sparc.deb
      Size/MD5:   594362 201ea81f75dba9506ac5b8c0b1b51736
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-plperl-8.1_8.1.9-0ubuntu0.6.06_sparc.deb
      Size/MD5:   173262 0db4a6db41e467e8208ba5bbdac55f00
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-plpython-8.1_8.1.9-0ubuntu0.6.06_sparc.deb
      Size/MD5:   167370 c16bd4dfd576eb96d34499bd2503389c
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-pltcl-8.1_8.1.9-0ubuntu0.6.06_sparc.deb
      Size/MD5:   168122 5930901815a91179407f106743d4f07f
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-server-dev-8.1_8.1.9-0ubuntu0.6.06_sparc.deb
      Size/MD5:   602136 4fdfdf3d2aed30e4cafaaf60860617be

Updated packages for Ubuntu 6.10:

  Source archives:

    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-8.1_8.1.9-0ubuntu0.6.10.diff.gz
      Size/MD5:    33328 881e61ca72d6016e8c22cead06392183
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-8.1_8.1.9-0ubuntu0.6.10.dsc
      Size/MD5:     1182 1bc7260ee71d9b9784dc422761aa5fef
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-8.1_8.1.9.orig.tar.gz
      Size/MD5: 11422807 a77d87607ee8f264c7bc9581e9048bb2

  Architecture independent packages:

    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-doc-8.1_8.1.9-0ubuntu0.6.10_all.deb
      Size/MD5:  1460682 231240b2ad9c4bb11466d32547f4db96

  amd64 architecture (Athlon64, Opteron, EM64T Xeon)

    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libecpg-compat2_8.1.9-0ubuntu0.6.10_amd64.deb
      Size/MD5:   159328 c3c741a40fe0c020ac2b911382a26c53
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libecpg-dev_8.1.9-0ubuntu0.6.10_amd64.deb
      Size/MD5:   351310 6357444edece06590d3af78df50b2d11
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libecpg5_8.1.9-0ubuntu0.6.10_amd64.deb
      Size/MD5:   180220 17472c941630464f55c3faf4a9ce3a81
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libpgtypes2_8.1.9-0ubuntu0.6.10_amd64.deb
      Size/MD5:   181664 9613fd5ada18c6818c55fbac8ed7ec76
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libpq-dev_8.1.9-0ubuntu0.6.10_amd64.deb
      Size/MD5:   319476 c615317672869844ebad873446af88d9
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libpq4_8.1.9-0ubuntu0.6.10_amd64.deb
      Size/MD5:   213036 abbe2499e9223fa8265fd4902f141329
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-8.1_8.1.9-0ubuntu0.6.10_amd64.deb
      Size/MD5:  3271340 8d486570aba36402f2a285b3947f30ec
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-client-8.1_8.1.9-0ubuntu0.6.10_amd64.deb
      Size/MD5:   800672 f0cb787329d9d943593405c7ebc090b6
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-contrib-8.1_8.1.9-0ubuntu0.6.10_amd64.deb
      Size/MD5:   627126 03dd3a304ea678420759019415c56e34
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-plperl-8.1_8.1.9-0ubuntu0.6.10_amd64.deb
      Size/MD5:   175696 d944f917a1ed1aaa37543fce3fb79615
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-plpython-8.1_8.1.9-0ubuntu0.6.10_amd64.deb
      Size/MD5:   170148 4347485174c80186392d93d962c15a7c
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-pltcl-8.1_8.1.9-0ubuntu0.6.10_amd64.deb
      Size/MD5:   170460 ea7282675652f9fc80af401059495f36
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-server-dev-8.1_8.1.9-0ubuntu0.6.10_amd64.deb
      Size/MD5:   603494 b850a10ac3925f877e181208c6f157eb

  i386 architecture (x86 compatible Intel/AMD)

    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libecpg-compat2_8.1.9-0ubuntu0.6.10_i386.deb
      Size/MD5:   158616 f17a956f67dbc8d5a2399beb6743e5cf
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libecpg-dev_8.1.9-0ubuntu0.6.10_i386.deb
      Size/MD5:   348308 f0c65fd45e3c0b302167e4d9243f89e3
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libecpg5_8.1.9-0ubuntu0.6.10_i386.deb
      Size/MD5:   178882 2a6ff8f281c4c873b3bae70346f7a834
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libpgtypes2_8.1.9-0ubuntu0.6.10_i386.deb
      Size/MD5:   181466 ffdb54461fd80910be853fab4241fe4e
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libpq-dev_8.1.9-0ubuntu0.6.10_i386.deb
      Size/MD5:   312668 1fdd4af8d90fc28937a8d904de05e6cd
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libpq4_8.1.9-0ubuntu0.6.10_i386.deb
      Size/MD5:   208934 ba7949a5cea5767b54c505bcc05edeca
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-8.1_8.1.9-0ubuntu0.6.10_i386.deb
      Size/MD5:  3168600 b67714316f0f624681292d996ee22a7e
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-client-8.1_8.1.9-0ubuntu0.6.10_i386.deb
      Size/MD5:   770848 536f08734318e60f0868309b94b90d26
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-contrib-8.1_8.1.9-0ubuntu0.6.10_i386.deb
      Size/MD5:   594650 78b2a876edaa17c3f91baf06f93b2538
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-plperl-8.1_8.1.9-0ubuntu0.6.10_i386.deb
      Size/MD5:   174534 2743126b0062b99cfb7dce673470edeb
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-plpython-8.1_8.1.9-0ubuntu0.6.10_i386.deb
      Size/MD5:   167972 90c63b8fa46e38df84d7d1896a0f86cb
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-pltcl-8.1_8.1.9-0ubuntu0.6.10_i386.deb
      Size/MD5:   169380 e277af9d62483f68d0a5b0756f7ee4be
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-server-dev-8.1_8.1.9-0ubuntu0.6.10_i386.deb
      Size/MD5:   603494 7c45a4e4d1014522844e08d7dfa68231

  powerpc architecture (Apple Macintosh G3/G4/G5)

    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libecpg-compat2_8.1.9-0ubuntu0.6.10_powerpc.deb
      Size/MD5:   160038 56aba05adad61971cda3bd97960e7943
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libecpg-dev_8.1.9-0ubuntu0.6.10_powerpc.deb
      Size/MD5:   346418 a865d8100dc559a69ecc6e448993cf20
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libecpg5_8.1.9-0ubuntu0.6.10_powerpc.deb
      Size/MD5:   181120 3412f56554e00f03e29378b179b70fc8
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libpgtypes2_8.1.9-0ubuntu0.6.10_powerpc.deb
      Size/MD5:   184728 9a6962d5c50b6d5cadc8eb5a0f894188
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libpq-dev_8.1.9-0ubuntu0.6.10_powerpc.deb
      Size/MD5:   314864 0b34cfe7b60eb4c3daef494ba2b34588
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libpq4_8.1.9-0ubuntu0.6.10_powerpc.deb
      Size/MD5:   210956 6b1dd004567f6533a6de153dde656597
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-8.1_8.1.9-0ubuntu0.6.10_powerpc.deb
      Size/MD5:  3571770 e66e88c237e72e61ec0f93da5611fb0a
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-client-8.1_8.1.9-0ubuntu0.6.10_powerpc.deb
      Size/MD5:   811196 cdcca3c12495b26d54c01e3eb223c238
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-contrib-8.1_8.1.9-0ubuntu0.6.10_powerpc.deb
      Size/MD5:   646778 1540d3f9d53f4652e0fc1d20c13168ff
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-plperl-8.1_8.1.9-0ubuntu0.6.10_powerpc.deb
      Size/MD5:   175472 5de467e3c17a091a063f6e6101c671da
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-plpython-8.1_8.1.9-0ubuntu0.6.10_powerpc.deb
      Size/MD5:   170334 feb50c14ff6e681f6762eecffad3b195
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-pltcl-8.1_8.1.9-0ubuntu0.6.10_powerpc.deb
      Size/MD5:   171330 ca6be8581e00989b91bce8ddff0a75e7
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-server-dev-8.1_8.1.9-0ubuntu0.6.10_powerpc.deb
      Size/MD5:   603514 ecbbeb1c3dce46161c31ea1174822121

  sparc architecture (Sun SPARC/UltraSPARC)

    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libecpg-compat2_8.1.9-0ubuntu0.6.10_sparc.deb
      Size/MD5:   157964 bff23b88032e625bac5bb6d1eea94aa7
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libecpg-dev_8.1.9-0ubuntu0.6.10_sparc.deb
      Size/MD5:   342064 184bea50f6cf78f9e3cf97b70f9f23ab
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libecpg5_8.1.9-0ubuntu0.6.10_sparc.deb
      Size/MD5:   178428 fb194d3529d6301a359db30d650a83c2
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libpgtypes2_8.1.9-0ubuntu0.6.10_sparc.deb
      Size/MD5:   179706 deeed2ab917872910e2dbbe6c7a3cffd
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libpq-dev_8.1.9-0ubuntu0.6.10_sparc.deb
      Size/MD5:   312028 317bcd5d8b59eb8dabef7b834e081963
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/libpq4_8.1.9-0ubuntu0.6.10_sparc.deb
      Size/MD5:   207198 1f9ad4b9bc976905cd9f3ead5fb735a5
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-8.1_8.1.9-0ubuntu0.6.10_sparc.deb
      Size/MD5:  3500074 8e6f1343276ac24b1c6841138da957c6
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-client-8.1_8.1.9-0ubuntu0.6.10_sparc.deb
      Size/MD5:   785860 ae3b580ea1ba2e9c5e3ae51d375bb5c2
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-contrib-8.1_8.1.9-0ubuntu0.6.10_sparc.deb
      Size/MD5:   605892 e73638e1f1e474fbdc92f01d7a1ca344
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-plperl-8.1_8.1.9-0ubuntu0.6.10_sparc.deb
      Size/MD5:   174150 32c11cb83592f82ac9a49786f9c29d84
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-plpython-8.1_8.1.9-0ubuntu0.6.10_sparc.deb
      Size/MD5:   168610 cc9d3c1eadf9874c239ff7f78ee4aa03
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-pltcl-8.1_8.1.9-0ubuntu0.6.10_sparc.deb
      Size/MD5:   169390 38582b1de5c37b0929b07ce75610c932
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.1/postgresql-server-dev-8.1_8.1.9-0ubuntu0.6.10_sparc.deb
      Size/MD5:   603514 d8abfdb18399929d2dd2291d5f3048ba

Updated packages for Ubuntu 7.04:

  Source archives:

    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/postgresql-8.2_8.2.4-0ubuntu0.7.04.diff.gz
      Size/MD5:    27760 38e9b478104480f362008238b4e0a9a2
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/postgresql-8.2_8.2.4-0ubuntu0.7.04.dsc
      Size/MD5:     1186 94cb7ec9567ff0a9f0493b5f62ea0fc7
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/postgresql-8.2_8.2.4.orig.tar.gz
      Size/MD5: 12229789 6331e68e3d9932bbb6fb1822fa650f3c

  Architecture independent packages:

    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/postgresql-doc-8.2_8.2.4-0ubuntu0.7.04_all.deb
      Size/MD5:  1593300 1e58e892de2a4c963e767c4e0fe1758a

  amd64 architecture (Athlon64, Opteron, EM64T Xeon)

    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/libecpg-compat2_8.2.4-0ubuntu0.7.04_amd64.deb
      Size/MD5:   175150 f9779c866090c8bf88d7d126a1d111aa
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/libecpg-dev_8.2.4-0ubuntu0.7.04_amd64.deb
      Size/MD5:   371880 9499cbecbe84280dbd4d59a28d77e6b5
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/libecpg5_8.2.4-0ubuntu0.7.04_amd64.deb
      Size/MD5:   194408 d2e2f2603d1ce0d1c0ec26f0827b2544
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/libpgtypes2_8.2.4-0ubuntu0.7.04_amd64.deb
      Size/MD5:   198140 46111aa61202ac609abe11922de22df0
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/libpq-dev_8.2.4-0ubuntu0.7.04_amd64.deb
      Size/MD5:   339852 8a0ab6d9b8d1bb12c6b442fba358e4a4
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/libpq5_8.2.4-0ubuntu0.7.04_amd64.deb
      Size/MD5:   227722 b280c58fbea37439232c505b4f04fca2
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/postgresql-8.2_8.2.4-0ubuntu0.7.04_amd64.deb
      Size/MD5:  3691126 b4355cbe5d6b25bb3801cb99553c1a40
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/postgresql-client-8.2_8.2.4-0ubuntu0.7.04_amd64.deb
      Size/MD5:   850570 0f0708c0d40339b4b04f0204efb7f25d
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/postgresql-contrib-8.2_8.2.4-0ubuntu0.7.04_amd64.deb
      Size/MD5:   694744 a9dc6a161292b2dff583bcbb1866811a
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/postgresql-plperl-8.2_8.2.4-0ubuntu0.7.04_amd64.deb
      Size/MD5:   196460 e98521023c62e1c572f6c517476eaef4
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/postgresql-plpython-8.2_8.2.4-0ubuntu0.7.04_amd64.deb
      Size/MD5:   188764 79273e6ee65758267c5b86ca80a9bdfb
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/postgresql-pltcl-8.2_8.2.4-0ubuntu0.7.04_amd64.deb
      Size/MD5:   186086 ed4ca2837faa4d9746b0c43236e013d3
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/postgresql-server-dev-8.2_8.2.4-0ubuntu0.7.04_amd64.deb
      Size/MD5:   663806 207b78994653972d3d6e5e58e7851fa6

  i386 architecture (x86 compatible Intel/AMD)

    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/libecpg-compat2_8.2.4-0ubuntu0.7.04_i386.deb
      Size/MD5:   174232 109d0e4bad264464a6b9a53bdd4b42ae
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/libecpg-dev_8.2.4-0ubuntu0.7.04_i386.deb
      Size/MD5:   368148 e22e65c5727558e9d9a8a93a0f14ee85
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/libecpg5_8.2.4-0ubuntu0.7.04_i386.deb
      Size/MD5:   193182 092389ef911b2a862c91f3e40d114715
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/libpgtypes2_8.2.4-0ubuntu0.7.04_i386.deb
      Size/MD5:   197834 d5e98f878810270feb3b9e49d3a7de36
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/libpq-dev_8.2.4-0ubuntu0.7.04_i386.deb
      Size/MD5:   332240 1fd2e2f534cc93fa2bc475b3afec6629
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/libpq5_8.2.4-0ubuntu0.7.04_i386.deb
      Size/MD5:   223424 1a080d8f109ea5a60424a3f975f9b87a
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/postgresql-8.2_8.2.4-0ubuntu0.7.04_i386.deb
      Size/MD5:  3581272 bdab70222ef47a85cc5762d64f96a139
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/postgresql-client-8.2_8.2.4-0ubuntu0.7.04_i386.deb
      Size/MD5:   819120 dea0b39ece430ea9dbe4e04a875bb16c
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/postgresql-contrib-8.2_8.2.4-0ubuntu0.7.04_i386.deb
      Size/MD5:   656478 5e728e5678ad6a7a70061335459fccdc
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/postgresql-plperl-8.2_8.2.4-0ubuntu0.7.04_i386.deb
      Size/MD5:   194688 4b00e644783e04b14f3e72fc75f40ae9
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/postgresql-plpython-8.2_8.2.4-0ubuntu0.7.04_i386.deb
      Size/MD5:   185960 703dd9f2443d289b84c267cc06443dc2
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/postgresql-pltcl-8.2_8.2.4-0ubuntu0.7.04_i386.deb
      Size/MD5:   184906 c8d6bad8902ca4845fe4fc49b3506f98
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/postgresql-server-dev-8.2_8.2.4-0ubuntu0.7.04_i386.deb
      Size/MD5:   662370 73bd6ec6c50653ee56382b42707682ec

  powerpc architecture (Apple Macintosh G3/G4/G5)

    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/libecpg-compat2_8.2.4-0ubuntu0.7.04_powerpc.deb
      Size/MD5:   176760 3133342da2a9080e0549d2150edff797
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/libecpg-dev_8.2.4-0ubuntu0.7.04_powerpc.deb
      Size/MD5:   367910 83faf3d1ef2dbc431128564c358dc762
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/libecpg5_8.2.4-0ubuntu0.7.04_powerpc.deb
      Size/MD5:   196764 ac76b838c33aee329f708f95004c283e
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/libpgtypes2_8.2.4-0ubuntu0.7.04_powerpc.deb
      Size/MD5:   202328 1187c50c8e2a5259640e194484640c1d
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/libpq-dev_8.2.4-0ubuntu0.7.04_powerpc.deb
      Size/MD5:   338000 c988a6baeb36d5b743eb52162b1fb6b5
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/libpq5_8.2.4-0ubuntu0.7.04_powerpc.deb
      Size/MD5:   226604 4f2f1ae8aa4ae66495a182c27d3d3c52
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/postgresql-8.2_8.2.4-0ubuntu0.7.04_powerpc.deb
      Size/MD5:  4004682 63a8cadf8d41bc4fb4590c85ce27b9e1
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/postgresql-client-8.2_8.2.4-0ubuntu0.7.04_powerpc.deb
      Size/MD5:   879788 f4b3de2c8fdc1dbb4f49ba5c3ada9e09
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/postgresql-contrib-8.2_8.2.4-0ubuntu0.7.04_powerpc.deb
      Size/MD5:   741690 280fbe405393100cb34108790c333422
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/postgresql-plperl-8.2_8.2.4-0ubuntu0.7.04_powerpc.deb
      Size/MD5:   198052 0b912f50d17ab04d4a5df43086b2f4cf
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/postgresql-plpython-8.2_8.2.4-0ubuntu0.7.04_powerpc.deb
      Size/MD5:   189826 f3cee879382605cf07c1df3fee49a8ed
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/postgresql-pltcl-8.2_8.2.4-0ubuntu0.7.04_powerpc.deb
      Size/MD5:   188052 f3473f89b929a2a174a5f603d8959fd2
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/postgresql-server-dev-8.2_8.2.4-0ubuntu0.7.04_powerpc.deb
      Size/MD5:   664964 e0e06622d4171366049ccbcdf47650bc

  sparc architecture (Sun SPARC/UltraSPARC)

    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/libecpg-compat2_8.2.4-0ubuntu0.7.04_sparc.deb
      Size/MD5:   173556 2d6ad5e254cdbbe51e4beb4ede22b7f9
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/libecpg-dev_8.2.4-0ubuntu0.7.04_sparc.deb
      Size/MD5:   361520 0961c30acdfcddc6fb2cdb0505b5212a
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/libecpg5_8.2.4-0ubuntu0.7.04_sparc.deb
      Size/MD5:   192750 4a46b31ccc7c3ccaee87c718b6d741be
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/libpgtypes2_8.2.4-0ubuntu0.7.04_sparc.deb
      Size/MD5:   195802 4cf6d0272bbcc112e97a9ccb8fe4d4f4
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/libpq-dev_8.2.4-0ubuntu0.7.04_sparc.deb
      Size/MD5:   331586 3ae0cfefb6fcd6901371050bcf0c5ea6
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/libpq5_8.2.4-0ubuntu0.7.04_sparc.deb
      Size/MD5:   221890 3e1ec19a35d31e490bc156be11e7d9e6
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/postgresql-8.2_8.2.4-0ubuntu0.7.04_sparc.deb
      Size/MD5:  3886718 0b2bcbb9be681246b5dd4ec9664b49d5
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/postgresql-client-8.2_8.2.4-0ubuntu0.7.04_sparc.deb
      Size/MD5:   838946 59eaa27dc3bbbe0e92b3003dce3bd6ad
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/postgresql-contrib-8.2_8.2.4-0ubuntu0.7.04_sparc.deb
      Size/MD5:   669714 b3b09cfb572cf147f1817c8ef9ceed39
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/postgresql-plperl-8.2_8.2.4-0ubuntu0.7.04_sparc.deb
      Size/MD5:   194554 99ea24f62555af9d78908e0573b0d468
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/postgresql-plpython-8.2_8.2.4-0ubuntu0.7.04_sparc.deb
      Size/MD5:   186830 f01a9c2f1fb94c94edcd9927143777dc
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/postgresql-pltcl-8.2_8.2.4-0ubuntu0.7.04_sparc.deb
      Size/MD5:   184810 0a16b71933f2666bf4359094af63fb10
    http://security.ubuntu.com/ubuntu/pool/main/p/postgresql-8.2/postgresql-server-dev-8.2_8.2.4-0ubuntu0.7.04_sparc.deb
      Size/MD5:   663934 8976925eaf1424af09ffbfd45dac54be

--+9faIjRurCDpBc7U
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFGMfoHDecnbV4Fd/IRAtQ5AKDJYxeWBPPHH1AJqcDi0TGRzapmyACfWwdb
emxZhW4Ild61xgMqMGmzw0c=GJYJ
-----END PGP SIGNATURE-----

--+9faIjRurCDpBc7U--


--=============="61446191625786007=Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

--
ubuntu-security-announce mailing list
ubuntu-security-announce@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-security-announce

--=============="61446191625786007==--
 
< Prev   Next >
    
Partner

 

Latest Features
Peter Smith Releases Linux Network Security Online
Securing a Linux Web Server
Password guessing with Medusa 2.0
Password guessing as an attack vector
Squid and Digest Authentication
Squid and Basic Authentication
Demystifying the Chinese Hacking Industry: Earning 6 Million a Night
Free Online security course (LearnSIA) - A Call for Help
What You Need to Know About Linux Rootkits
Review: A Practical Guide to Fedora and Red Hat Enterprise Linux - Fifth Edition
Weekend Edition
The Hacktivist as Angry Young Man
The Hacker Wars Hits NYC
CAINE Linux Distribution Helps Investigators With Forensic Analysis
Partner Sponsor

Community | HOWTOs | Blogs | Features | Book Reviews | Networking
 Security Projects |  Latest News |  Newsletters |  SELinux |  Privacy |  Home
 Hardening |   About Us |   Advertise |   Legal Notice |   RSS |   Guardian Digital
(c)Copyright 2014 Guardian Digital, Inc. All rights reserved.