LinuxSecurity.com
Share your story
The central voice for Linux and Open Source security news
Home News Topics Advisories HOWTOs Features Newsletters About Register

Welcome!
Sign up!
EnGarde Community
Login
Polls
What is the most important Linux security technology?
 
Advisories
Community
Linux Events
Linux User Groups
Link to Us
Security Center
Book Reviews
Security Dictionary
Security Tips
SELinux
White Papers
Featured Blogs
All About Linux
DanWalsh LiveJournal
Securitydistro
Latest Newsletters
Linux Advisory Watch: October 31st, 2014
Linux Security Week: October 27th, 2014
Subscribe
LinuxSecurity Newsletters
E-mail:
Choose Lists:
About our Newsletters
RSS Feeds
Get the LinuxSecurity news you want faster with RSS
Powered By

  
Gentoo: Adobe Acrobat Reader Multiple vulnerabilities Print E-mail
User Rating:      How can I rate this item?
Posted by Benjamin D. Thomas   
Gentoo Adobe Acrobat Reader is vulnerable to remote code execution, Denial of Service, and cross-site scripting attacks.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200701-16
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Adobe Acrobat Reader: Multiple vulnerabilities
      Date: January 22, 2007
      Bugs: #159874
        ID: 200701-16

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Adobe Acrobat Reader is vulnerable to remote code execution, Denial of
Service, and cross-site scripting attacks.

Background
==========

Adobe Acrobat Reader is a PDF reader released by Adobe.

Affected packages
=================

    -------------------------------------------------------------------
     Package            /  Vulnerable  /                    Unaffected
    -------------------------------------------------------------------
  1  app-text/acroread       < 7.0.9                          >= 7.0.9

Description
===========

Adobe Acrobat Reader in stand-alone mode is vulnerable to remote code
execution via heap corruption when loading a specially crafted PDF
file.

The browser plugin released with Adobe Acrobat Reader (nppdf.so) does
not properly handle URLs, and crashes if given a URL that is too long.
The plugin does not correctly handle JavaScript, and executes
JavaScript that is given as a GET variable to the URL of a PDF file.
Lastly, the plugin does not properly handle the FDF, xml, xfdf AJAX
request parameters following the # character in a URL, allowing for
multiple cross-site scripting vulnerabilities.

Impact
======

An attacker could entice a user to open a specially crafted PDF file
and execute arbitrary code with the rights of the user running Adobe
Acrobat Reader. An attacker could also entice a user to browse to a
specially crafted URL and either crash the Adobe Acrobat Reader browser
plugin, execute arbitrary JavaScript in the context of the user's
browser, or inject arbitrary HTML or JavaScript into the document being
viewed by the user. Note that users who have emerged Adobe Acrobat
Reader with the "nsplugin" USE flag disabled are not vulnerable to
issues with the Adobe Acrobat Reader browser plugin.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Adobe Acrobat Reader users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=app-text/acroread-7.0.9"

References
==========

  [ 1 ] CVE-2006-5857
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-5857
  [ 2 ] CVE-2007-0044
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-0044
  [ 3 ] CVE-2007-0045
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-0045
  [ 4 ] CVE-2007-0046
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-0046
  [ 5 ] CVE-2007-0048
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-0048

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200701-16.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2007 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
 
< Prev   Next >
    
Partner

 

Latest Features
Peter Smith Releases Linux Network Security Online
Securing a Linux Web Server
Password guessing with Medusa 2.0
Password guessing as an attack vector
Squid and Digest Authentication
Squid and Basic Authentication
Demystifying the Chinese Hacking Industry: Earning 6 Million a Night
Free Online security course (LearnSIA) - A Call for Help
What You Need to Know About Linux Rootkits
Review: A Practical Guide to Fedora and Red Hat Enterprise Linux - Fifth Edition
Yesterday's Edition
Pirate Bay founder guilty in historic hacker case
Parallels CTO: Linux container security is not the problem
Advisory says to assume all Drupal 7 websites are compromised
Partner Sponsor

Community | HOWTOs | Blogs | Features | Book Reviews | Networking
 Security Projects |  Latest News |  Newsletters |  SELinux |  Privacy |  Home
 Hardening |   About Us |   Advertise |   Legal Notice |   RSS |   Guardian Digital
(c)Copyright 2014 Guardian Digital, Inc. All rights reserved.