LinuxSecurity.com
Share your story
The central voice for Linux and Open Source security news
Home News Topics Advisories HOWTOs Features Newsletters About Register

Welcome!
Sign up!
EnGarde Community
Login
Polls
What is the most important Linux security technology?
 
Advisories
Community
Linux Events
Linux User Groups
Link to Us
Security Center
Book Reviews
Security Dictionary
Security Tips
SELinux
White Papers
Featured Blogs
All About Linux
DanWalsh LiveJournal
Securitydistro
Latest Newsletters
Linux Security Week: April 21st, 2014
Linux Security Week: April 7th, 2014
Subscribe
LinuxSecurity Newsletters
E-mail:
Choose Lists:
About our Newsletters
RSS Feeds
Get the LinuxSecurity news you want faster with RSS
Powered By

  
Gentoo: MadWifi Kernel driver buffer overflow Print E-mail
User Rating:      How can I rate this item?
Posted by Benjamin D. Thomas   
Gentoo OpenSSL contains multiple vulnerabilities including the possible execution of remote arbitrary code.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200612-11
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: AMD64 x86 emulation base libraries: OpenSSL multiple
            vulnerabilities
      Date: December 11, 2006
      Bugs: #152640
        ID: 200612-11

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

OpenSSL contains multiple vulnerabilities including the possible
execution of remote arbitrary code.

Background
==========

OpenSSL is a toolkit implementing the Secure Sockets Layer, Transport
Layer Security protocols and a general-purpose cryptography library.
The x86 emulation base libraries for AMD64 contain a vulnerable version
of OpenSSL.

Affected packages
=================

    -------------------------------------------------------------------
     Package                  /  Vulnerable  /              Unaffected
    -------------------------------------------------------------------
  1  emul-linux-x86-baselibs       < 2.5.5                    >= 2.5.5
    -------------------------------------------------------------------
     # Package 1 only applies to AMD64 users.

Description
===========

Tavis Ormandy and Will Drewry, both of the Google Security Team,
discovered that the SSL_get_shared_ciphers() function contains a buffer
overflow vulnerability, and that the SSLv2 client code contains a flaw
leading to a crash. Additionally, Dr. Stephen N. Henson found that the
ASN.1 handler contains two Denial of Service vulnerabilities: while
parsing an invalid ASN.1 structure and while handling certain types of
public key.

Impact
======

An attacker could trigger the buffer overflow by sending a malicious
suite of ciphers to an application using the vulnerable function, and
thus execute arbitrary code with the rights of the user running the
application. An attacker could also consume CPU and/or memory by
exploiting the Denial of Service vulnerabilities. Finally, a malicious
server could crash a SSLv2 client through the SSLv2 vulnerability.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All AMD64 x86 emulation base libraries users should upgrade to the
latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=app-emulation/emul-linux-x86-baselibs-2.5.5"

References
==========

  [ 1 ] CVE-2006-2937
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2937
  [ 2 ] CVE-2006-2940
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2940
  [ 3 ] CVE-2006-3738
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3738
  [ 4 ] CVE-2006-4343
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-4343

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200612-11.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2006 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
 
< Prev   Next >
    
Partner

 

Latest Features
Peter Smith Releases Linux Network Security Online
Securing a Linux Web Server
Password guessing with Medusa 2.0
Password guessing as an attack vector
Squid and Digest Authentication
Squid and Basic Authentication
Demystifying the Chinese Hacking Industry: Earning 6 Million a Night
Free Online security course (LearnSIA) - A Call for Help
What You Need to Know About Linux Rootkits
Review: A Practical Guide to Fedora and Red Hat Enterprise Linux - Fifth Edition
Yesterday's Edition
Partner Sponsor

Community | HOWTOs | Blogs | Features | Book Reviews | Networking
 Security Projects |  Latest News |  Newsletters |  SELinux |  Privacy |  Home
 Hardening |   About Us |   Advertise |   Legal Notice |   RSS |   Guardian Digital
(c)Copyright 2014 Guardian Digital, Inc. All rights reserved.