LinuxSecurity.com
Share your story
The central voice for Linux and Open Source security news
Home News Topics Advisories HOWTOs Features Newsletters About Register

Welcome!
Sign up!
EnGarde Community
Login
Polls
What is the most important Linux security technology?
 
Advisories
Community
Linux Events
Linux User Groups
Link to Us
Security Center
Book Reviews
Security Dictionary
Security Tips
SELinux
White Papers
Featured Blogs
All About Linux
DanWalsh LiveJournal
Securitydistro
Latest Newsletters
Linux Advisory Watch: October 17th, 2014
Linux Security Week: October 13th, 2014
Subscribe
LinuxSecurity Newsletters
E-mail:
Choose Lists:
About our Newsletters
RSS Feeds
Get the LinuxSecurity news you want faster with RSS
Powered By

  
Gentoo: subversion Heap overflow vulnerability Print E-mail
User Rating:      How can I rate this item?
Posted by LinuxSecurity.com Team   
Gentoo Subversion is vulnerable to a remote Denial of Service that may be exploitable to execute arbitrary code

Gentoo Linux Security Advisory                           GLSA 200406-07
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                             http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: Subversion: Remote heap overflow
      Date: June 10, 2004
        ID: 200406-07

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Subversion is vulnerable to a remote Denial of Service that may be
exploitable to execute arbitrary code on the server running svnserve.

Background
==========

Subversion is a revision control system that aims to be a "compelling
replacement for CVS". It enjoys wide use in the open source community.
svnserve allows access to Subversion repositories using URIs with the
svn://, svn+ssh://, and other tunelled svn+*:// protocols.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /   Vulnerable   /                Unaffected
    -------------------------------------------------------------------
  1  dev-util/subversion       <= 1.0.4                    >= 1.0.4-r1

Description
===========

The svn protocol parser trusts the indicated length of a URI string
sent by a client. This allows a client to specify a very long string,
thereby causing svnserve to allocate enough memory to hold that string.
This may cause a Denial of Service. Alternately, given a string that
causes an integer overflow in the variable holding the string length,
the server might allocate less memory than required, allowing a heap
overflow. This heap overflow may then be exploitable, allowing remote
code execution. The attacker does not need read or write access to the
Subversion repository being served, since even un-authenticated users
can send svn protocol requests.

Impact
======

Ranges from remote Denial of Service to potential arbitrary code
execution with privileges of the svnserve process.

Workaround
==========

Servers without svnserve running are not vulnerable. Disable svnserve
and use DAV for access instead.

Resolution
==========

All users should upgrade to the latest version of Subversion.

    # emerge sync

    # emerge -pv ">=dev-util/subversion-1.0.4-r1"
    # emerge ">=dev-util/subversion-1.0.4-r1"

References
==========

  [ 1 ] CAN-2004-0413
         http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0413

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

      http://security.gentoo.org/glsa/glsa-200406-07.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at 
http://bugs.gentoo.org.

License
=======

Copyright 2004 Gentoo Technologies, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.
 
http://creativecommons.org/licenses/by-sa/1.0

 
< Prev   Next >
    
Partner

 

Latest Features
Peter Smith Releases Linux Network Security Online
Securing a Linux Web Server
Password guessing with Medusa 2.0
Password guessing as an attack vector
Squid and Digest Authentication
Squid and Basic Authentication
Demystifying the Chinese Hacking Industry: Earning 6 Million a Night
Free Online security course (LearnSIA) - A Call for Help
What You Need to Know About Linux Rootkits
Review: A Practical Guide to Fedora and Red Hat Enterprise Linux - Fifth Edition
Weekend Edition
The Hacktivist as Angry Young Man
The Hacker Wars Hits NYC
CAINE Linux Distribution Helps Investigators With Forensic Analysis
Partner Sponsor

Community | HOWTOs | Blogs | Features | Book Reviews | Networking
 Security Projects |  Latest News |  Newsletters |  SELinux |  Privacy |  Home
 Hardening |   About Us |   Advertise |   Legal Notice |   RSS |   Guardian Digital
(c)Copyright 2014 Guardian Digital, Inc. All rights reserved.