LinuxSecurity.com
Share your story
The central voice for Linux and Open Source security news
Home News Topics Advisories HOWTOs Features Newsletters About Register

Welcome!
Sign up!
EnGarde Community
Login
Polls
What is the most important Linux security technology?
 
Advisories
Community
Linux Events
Linux User Groups
Link to Us
Security Center
Book Reviews
Security Dictionary
Security Tips
SELinux
White Papers
Featured Blogs
All About Linux
DanWalsh LiveJournal
Securitydistro
Latest Newsletters
Linux Advisory Watch: November 21st, 2014
Linux Security Week: November 17th, 2014
Subscribe
LinuxSecurity Newsletters
E-mail:
Choose Lists:
About our Newsletters
RSS Feeds
Get the LinuxSecurity news you want faster with RSS
Powered By

  
Gentoo: Apache 1.3 Multiple vulnerabilities Print E-mail
User Rating:      How can I rate this item?
Posted by LinuxSecurity.com Team   
Gentoo Several security vulnerabilites have been fixed in the latest release of Apache 1.3.

Gentoo Linux Security Advisory                           GLSA 200405-22
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                             http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Apache 1.3: Multiple vulnerabilities
      Date: May 26, 2004
      Bugs: #51815
        ID: 200405-22

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Several security vulnerabilites have been fixed in the latest release
of Apache 1.3.

Background
==========

The Apache HTTP Server Project is an effort to develop and maintain an
open-source HTTP server for modern operating systems. The goal of this
project is to provide a secure, efficient and extensible server that
provides services in tune with the current HTTP standards.

Affected packages
=================

    -------------------------------------------------------------------
     Package         /   Vulnerable   /                     Unaffected
    -------------------------------------------------------------------
  1  net-www/apache       < 1.3.31                           >= 1.3.31

Description
===========

On 64-bit big-endian platforms, mod_access does not properly parse
Allow/Deny rules using IP addresses without a netmask which could
result in failure to match certain IP addresses.

Terminal escape sequences are not filtered from error logs. This could
be used by an attacker to insert escape sequences into a terminal
emulater vulnerable to escape sequences.

mod_digest does not properly verify the nonce of a client response by
using a AuthNonce secret. This could permit an attacker to replay the
response of another website. This does not affect mod_auth_digest.

On certain platforms there is a starvation issue where listening
sockets fails to handle short-lived connection on a rarely-accessed
listening socket. This causes the child to hold the accept mutex and
block out new connections until another connection arrives on the same
rarely-accessed listening socket thus leading to a denial of service.

Impact
======

These vulnerabilities could lead to attackers bypassing intended access
restrictions, denial of service, and possibly execution of arbitrary
code.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All users should upgrade to the latest stable version of Apache 1.3.

    # emerge sync

    # emerge -pv ">=net-www/apache-1.3.31"
    # emerge ">=net-www/apache-1.3.31"

References
==========

  [ 1 ] CAN-2003-0993
         http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2003-0993
  [ 2 ] CAN-2003-0020
         http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2003-0020
  [ 3 ] CAN-2003-0987
         http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2003-0987
  [ 4 ] CAN-2004-0174
         http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0174

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

      http://security.gentoo.org/glsa/glsa-200405-22.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at 
http://bugs.gentoo.org.

License
=======

Copyright 2004 Gentoo Technologies, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.
 
http://creativecommons.org/licenses/by-sa/1.0

 
< Prev   Next >
    
Partner

 

Latest Features
Peter Smith Releases Linux Network Security Online
Securing a Linux Web Server
Password guessing with Medusa 2.0
Password guessing as an attack vector
Squid and Digest Authentication
Squid and Basic Authentication
Demystifying the Chinese Hacking Industry: Earning 6 Million a Night
Free Online security course (LearnSIA) - A Call for Help
What You Need to Know About Linux Rootkits
Review: A Practical Guide to Fedora and Red Hat Enterprise Linux - Fifth Edition
Weekend Edition
Google Releases Open Source Tool for Testing Web App Security Scanners
Most Targeted Attacks Exploit Privileged Accounts
NotCompable sets new standards for mobile botnet sophistication
Hands on with Caine Linux: Pentesting and UEFI compatible
Partner Sponsor

Community | HOWTOs | Blogs | Features | Book Reviews | Networking
 Security Projects |  Latest News |  Newsletters |  SELinux |  Privacy |  Home
 Hardening |   About Us |   Advertise |   Legal Notice |   RSS |   Guardian Digital
(c)Copyright 2014 Guardian Digital, Inc. All rights reserved.