LinuxSecurity.com
Share your story
The central voice for Linux and Open Source security news
Home News Topics Advisories HOWTOs Features Newsletters About Register

Welcome!
Sign up!
EnGarde Community
Login
Polls
What is the most important Linux security technology?
 
Advisories
Community
Linux Events
Linux User Groups
Link to Us
Security Center
Book Reviews
Security Dictionary
Security Tips
SELinux
White Papers
Featured Blogs
All About Linux
DanWalsh LiveJournal
Securitydistro
Latest Newsletters
Linux Security Week: October 20th, 2014
Linux Advisory Watch: October 17th, 2014
Subscribe
LinuxSecurity Newsletters
E-mail:
Choose Lists:
About our Newsletters
RSS Feeds
Get the LinuxSecurity news you want faster with RSS
Powered By

  
Gentoo: xine Multiple vulnerabilities Print E-mail
User Rating:      How can I rate this item?
Posted by LinuxSecurity.com Team   
Gentoo Several vulnerabilities have been found in xine-ui and xine-lib, potentially allowing an attacker to overwrite files with the rights of the user.

Gentoo Linux Security Advisory                           GLSA 200404-20
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                             http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Multiple vulnerabilities in xine
      Date: April 27, 2004
      Bugs: #45448, #48107, #48108
        ID: 200404-20

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Several vulnerabilities have been found in xine-ui and xine-lib,
potentially allowing an attacker to overwrite files with the rights of
the user.

Background
==========

xine is a multimedia player allowing to play back CDs, DVDs, and VCDs
and decoding multimedia files like AVI, MOV, WMV, and MP3 from local
disk drives, and displays multimedia streamed over the Internet. It is
available in Gentoo as a reusable library (xine-lib) with a standard
user interface (xine-ui).

Affected packages
=================

    -------------------------------------------------------------------
     Package              /    Vulnerable    /              Unaffected
    -------------------------------------------------------------------
  1  media-video/xine-ui      <= 0.9.23-r1                >= 0.9.23-r2
  2  media-libs/xine-lib       <= 1_rc3-r2                 >= 1_rc3-r3
    -------------------------------------------------------------------
     2 affected packages on all of their supported architectures.
    -------------------------------------------------------------------

Description
===========

Several vulnerabilities were found in xine-ui and xine-lib. By opening
a malicious MRL in any xine-lib based media player, an attacker can
write arbitrary content to an arbitrary file, only restricted by the
permissions of the user running the application. By opening a malicious
playlist in the xine-ui media player, an attacker can write arbitrary
content to an arbitrary file, only restricted by the permissions of the
user running xine-ui. Finally, a temporary file is created in an
insecure manner by the xine-check and xine-bugreport scripts,
potentially allowing a local attacker to use a symlink attack.

Impact
======

These three vulnerabilities may alow an attacker to corrupt system
files, thus potentially leading to a Denial of Service. It is also
theoretically possible, though very unlikely, to use these
vulnerabilities to elevate the privileges of the attacker.

Workaround
==========

There is no known workaround at this time. All users are advised to
upgrade to the latest available versions of xine-ui and xine-lib.

Resolution
==========

All users of xine-ui or another xine-based player should upgrade to the
latest stable versions:

    # emerge sync

    # emerge -pv ">=media-video/xine-ui-0.9.23-r2"
    # emerge ">=media-video/xine-ui-0.9.23-r2"

    # emerge -pv ">=media-libs/xine-lib-1_rc3-r3"
    # emerge ">=media-libs/xine-lib-1_rc3-r3"

References
==========

  [ 1 ] Xine Security Advisories
         http://xinehq.de/index.php/security
  [ 2 ] xine-bugreport and xine-check vulnerability
         http://nettwerked.mg2.org/advisories/xinebug

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

      http://security.gentoo.org/glsa/glsa-200404-20.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at 
http://bugs.gentoo.org.

License
=======

Copyright 2004 Gentoo Technologies, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.
 
http://creativecommons.org/licenses/by-sa/1.0

 
< Prev   Next >
    
Partner

 

Latest Features
Peter Smith Releases Linux Network Security Online
Securing a Linux Web Server
Password guessing with Medusa 2.0
Password guessing as an attack vector
Squid and Digest Authentication
Squid and Basic Authentication
Demystifying the Chinese Hacking Industry: Earning 6 Million a Night
Free Online security course (LearnSIA) - A Call for Help
What You Need to Know About Linux Rootkits
Review: A Practical Guide to Fedora and Red Hat Enterprise Linux - Fifth Edition
Yesterday's Edition
Hacker Halted 2014: Johnny Long Calls for Hackers for Charity Volunteers
RIPS – Static Source Code Analysis For PHP Vulnerabilities
Finding a Video Poker Bug Made These Guys Rich—Then Vegas Made Them Pay
Partner Sponsor

Community | HOWTOs | Blogs | Features | Book Reviews | Networking
 Security Projects |  Latest News |  Newsletters |  SELinux |  Privacy |  Home
 Hardening |   About Us |   Advertise |   Legal Notice |   RSS |   Guardian Digital
(c)Copyright 2014 Guardian Digital, Inc. All rights reserved.