LinuxSecurity.com
Share your story
The central voice for Linux and Open Source security news
Home News Topics Advisories HOWTOs Features Newsletters About Register

Welcome!
Sign up!
EnGarde Community
Login
Polls
What is the most important Linux security technology?
 
Advisories
Community
Linux Events
Linux User Groups
Link to Us
Security Center
Book Reviews
Security Dictionary
Security Tips
SELinux
White Papers
Featured Blogs
All About Linux
DanWalsh LiveJournal
Securitydistro
Latest Newsletters
Linux Advisory Watch: September 19th, 2014
Linux Security Week: September 15th, 2014
Subscribe
LinuxSecurity Newsletters
E-mail:
Choose Lists:
About our Newsletters
RSS Feeds
Get the LinuxSecurity news you want faster with RSS
Powered By

  
Gentoo: apache 2.x Multiple vulnerabilities Print E-mail
User Rating:      How can I rate this item?
Posted by LinuxSecurity.com Team   
Gentoo Vulnerabilities include code execution and denial of service.

Gentoo Linux Security Advisory                           GLSA 200403-04
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                              http://security.gentoo.org
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Multiple security vulnerabilities in Apache 2
      Date: March 22, 2004
      Bugs: #45206
        ID: 200403-04

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A memory leak in mod_ssl allows a remote denial of service attack
against an SSL-enabled server via plain HTTP requests. Another flaw
was found when arbitrary client-supplied strings can be written to the
error log, allowing the exploit of certain terminal emulators. A third
flaw exists with the mod_disk_cache module.

Background
==========

The Apache HTTP Server Project is an effort to develop and maintain an
open-source HTTP server for modern operating systems. The goal of this
project is to provide a secure, efficient and extensible server that
provides services in tune with the current HTTP standards.

Affected packages
=================

    -------------------------------------------------------------------
     Package         /   Vulnerable   /                     Unaffected
    -------------------------------------------------------------------
     net-www/apache       <= 2.0.48                            == 1.3*
     net-www/apache       <= 2.0.48                          >= 2.0.49

Description
===========

Three vulnerabilities were found:

1. A memory leak in ssl_engine_io.c for mod_ssl in Apache 2.0.48 and
   below allows remote attackers to cause a denial of service attack
   via plain HTTP requests to the SSL port of an SSL-enabled server.

2. Apache fails to filter terminal escape sequences from error logs
   that begin with the ASCII (0x1B) sequence and are followed by a
   series of arguments. If a remote attacker could inject escape
   sequences into an Apache error log, the attacker could take
   advantages of weaknesses in various terminal emulators, launching
   attacks against remote users including further denial of service
   attacks, file modification, and the execution of arbitrary commands.

3. The Apache mod_disk_cache has been found to be vulnerable to a
   weakness that allows attackers to gain access to authentication
   credentials through the issue of caching HTTP hop-by-hop headers
   which would contain plaintext user passwords. There is no available
   resolution for this issue yet.

Impact
======

No special privileges are required for these vulnerabilities. As a
result, all users are recommended to upgrade their Apache
installations.

Workaround
==========

There is no immediate workaround; a software upgrade is required. There
is no workaround for the mod_disk_cache issue; users are recommended to
disable the feature on their servers until a patched version is
released.

Resolution
==========

Users are urged to upgrade to Apache 2.0.49:

    # emerge sync
    # emerge -pv ">=net-www/apache-2.0.49"
    # emerge ">=net-www/apache-2.0.49"

    # ** IMPORTANT **

    # If you are migrating from Apache 2.0.48-r1 or earlier versions,
    # it is important that the following directories are removed.

    # The following commands should cause no data loss since these
    # are symbolic links.

    # rm /etc/apache2/lib /etc/apache2/logs /etc/apache2/modules
    # rm /etc/apache2/modules

    # ** ** ** ** **

    # ** ALSO NOTE **

    # Users who use mod_disk_cache should edit their Apache
    # configuration and disable mod_disk_cache.

References
==========

  [ 1 ]  http://www.securityfocus.com/bid/9933/info/
  [ 2 ]  http://www.apache.org/dist/httpd/Announcement2.html

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at 
http://bugs.gentoo.org.

 
< Prev   Next >
    
Partner

 

Latest Features
Peter Smith Releases Linux Network Security Online
Securing a Linux Web Server
Password guessing with Medusa 2.0
Password guessing as an attack vector
Squid and Digest Authentication
Squid and Basic Authentication
Demystifying the Chinese Hacking Industry: Earning 6 Million a Night
Free Online security course (LearnSIA) - A Call for Help
What You Need to Know About Linux Rootkits
Review: A Practical Guide to Fedora and Red Hat Enterprise Linux - Fifth Edition
Yesterday's Edition
Encryption goof fixed in TorrentLocker file-locking malware
Qubes: The Open Source OS Built for Security
Partner Sponsor

Community | HOWTOs | Blogs | Features | Book Reviews | Networking
 Security Projects |  Latest News |  Newsletters |  SELinux |  Privacy |  Home
 Hardening |   About Us |   Advertise |   Legal Notice |   RSS |   Guardian Digital
(c)Copyright 2014 Guardian Digital, Inc. All rights reserved.