LinuxSecurity.com
Share your story
The central voice for Linux and Open Source security news
Home News Topics Advisories HOWTOs Features Newsletters About Register

Welcome!
Sign up!
EnGarde Community
Login
Polls
What is the most important Linux security technology?
 
Advisories
Community
Linux Events
Linux User Groups
Link to Us
Security Center
Book Reviews
Security Dictionary
Security Tips
SELinux
White Papers
Featured Blogs
All About Linux
DanWalsh LiveJournal
Securitydistro
Latest Newsletters
Linux Advisory Watch: September 26th, 2014
Linux Security Week: September 22nd, 2014
Subscribe
LinuxSecurity Newsletters
E-mail:
Choose Lists:
About our Newsletters
RSS Feeds
Get the LinuxSecurity news you want faster with RSS
Powered By

  
Gentoo: OpenSSL Denial of service vulnerabilities Print E-mail
User Rating:      How can I rate this item?
Posted by LinuxSecurity.com Team   
Gentoo Three vulnerabilities have been found in OpenSSL via a commercial test suite for the TLS protocol developed by Codenomicon Ltd.

Gentoo Linux Security Advisory                           GLSA 200403-03
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                              http://security.gentoo.org
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Multiple OpenSSL Vulnerabilities
      Date: March 17, 2004
      Bugs: #44941
        ID: 200403-03

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Three vulnerabilities have been found in OpenSSL via a commercial test
suite for the TLS protocol developed by Codenomicon Ltd.

Background
==========

The OpenSSL Project is a collaborative effort to develop a robust,
commercial-grade, full-featured, and Open Source toolkit implementing
the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
v1) protocols as well as a full-strength general purpose cryptography
library.

Affected packages
=================

    -------------------------------------------------------------------
     Package           /   Vulnerable   /                   Unaffected
    -------------------------------------------------------------------
     dev-libs/openssl       <= 0.9.7c                        >= 0.9.7d
     dev-libs/openssl       <= 0.9.7c                        == 0.9.6m

Description
===========

1. Testing performed by the OpenSSL group using the Codenomicon TLS
   Test Tool uncovered a null-pointer assignment in the
   do_change_cipher_spec() function. A remote attacker could perform a
   carefully crafted SSL/TLS handshake against a server that used the
   OpenSSL library in such a way as to cause OpenSSL to crash.
   Depending on the application this could lead to a denial of service.
   All versions of OpenSSL from 0.9.6c to 0.9.6l inclusive and from
   0.9.7a to 0.9.7c inclusive are affected by this issue.

2. A flaw has been discovered in SSL/TLS handshaking code when using
   Kerberos ciphersuites. A remote attacker could perform a carefully
   crafted SSL/TLS handshake against a server configured to use
   Kerberos ciphersuites in such a way as to cause OpenSSL to crash.
   Most applications have no ability to use Kerberos cipher suites and
   will therefore be unaffected. Versions 0.9.7a, 0.9.7b, and 0.9.7c of
   OpenSSL are affected by this issue.

3. Testing performed by the OpenSSL group using the Codenomicon TLS
   Test Tool uncovered a bug in older versions of OpenSSL 0.9.6 that
   can lead to a Denial of Service attack (infinite loop). This issue
   was traced to a fix that was added to OpenSSL 0.9.6d some time ago.
   This issue will affect vendors that ship older versions of OpenSSL
   with backported security patches.

Impact
======

Although there are no public exploits known for bug, users are
recommended to upgrade to ensure the security of their infrastructure.

Workaround
==========

There is no immediate workaround; a software upgrade is required. The
vulnerable function in the code has been rewritten.

Resolution
==========

All users are recommened to upgrade openssl to either 0.9.7d or 0.9.6m:

    # emerge sync
    # emerge -pv ">=dev-libs/openssl-0.9.7d"
    # emerge ">=dev-libs/openssl-0.9.7d"

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at 
http://bugs.gentoo.org.

 
< Prev   Next >
    
Partner

 

Latest Features
Peter Smith Releases Linux Network Security Online
Securing a Linux Web Server
Password guessing with Medusa 2.0
Password guessing as an attack vector
Squid and Digest Authentication
Squid and Basic Authentication
Demystifying the Chinese Hacking Industry: Earning 6 Million a Night
Free Online security course (LearnSIA) - A Call for Help
What You Need to Know About Linux Rootkits
Review: A Practical Guide to Fedora and Red Hat Enterprise Linux - Fifth Edition
Yesterday's Edition
Honeypot Snares Two Bots Exploiting Bash Vulnerability
CloudFlare Rolls Out Free SSL
Partner Sponsor

Community | HOWTOs | Blogs | Features | Book Reviews | Networking
 Security Projects |  Latest News |  Newsletters |  SELinux |  Privacy |  Home
 Hardening |   About Us |   Advertise |   Legal Notice |   RSS |   Guardian Digital
(c)Copyright 2014 Guardian Digital, Inc. All rights reserved.