LinuxSecurity.com
Share your story
The central voice for Linux and Open Source security news
Home News Topics Advisories HOWTOs Features Newsletters About Register

Welcome!
Sign up!
EnGarde Community
Login
Polls
What is the most important Linux security technology?
 
Advisories
Community
Linux Events
Linux User Groups
Link to Us
Security Center
Book Reviews
Security Dictionary
Security Tips
SELinux
White Papers
Featured Blogs
All About Linux
DanWalsh LiveJournal
Securitydistro
Latest Newsletters
Linux Security Week: October 20th, 2014
Linux Advisory Watch: October 17th, 2014
Subscribe
LinuxSecurity Newsletters
E-mail:
Choose Lists:
About our Newsletters
RSS Feeds
Get the LinuxSecurity news you want faster with RSS
Powered By

  
Gentoo: Glibc buffer overrun vulnerability Print E-mail
User Rating:      How can I rate this item?
Posted by LinuxSecurity.com Team   
Gentoo A bug in the getgrouplist function can cause a buffer overflow if the size ofthe group list is too small to hold all the user's groups. This overflow cancause segmentation faults in user applications. This vulnerability existsonly when an administrator has placed a user in a number of groups largerthan that expected by an application.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1


- - ---------------------------------------------------------------------------
GENTOO LINUX SECURITY ANNOUNCEMENT 200311-05
- - ---------------------------------------------------------------------------

GLSA:        200311-05
package:     sys-libs/glibc
summary:     Glibc getgrouplist buffer overrun vulnerability
severity:    normal
Gentoo bug:  33383
date:        2003-11-22
CVE:         CAN-2003-0689
affected:    <=2.2.4
fixed:       >=2.2.5

DESCRIPTION:


A bug in the getgrouplist function can cause a buffer overflow if the size of
the group list is too small to hold all the user's groups. This overflow can
cause segmentation faults in user applications. This vulnerability exists
only when an administrator has placed a user in a number of groups larger
than that expected by an application. 


SOLUTION:


It is recommended that all Gentoo Linux users update their systems as
follows:

emerge sync
emerge '>=sys-libs/glibc-2.2.5'
emerge clean


- -- 
Andrea Barisani <lcars@gentoo.org>                            .*.
Gentoo Linux Infrastructure Developer                          V
                                                             (   )
GPG-Key 0xC9EE0905  http://dev.gentoo.org/~lcars/pubkey.asc   (   )
    491D E9E0 3875 0EC9 10DD 150B CAA9 2C7D C9EE 0905        ^^_^^


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.3 (GNU/Linux)

iD8DBQE/wi7zyqksfcnuCQURAvuSAJ97zIRL9qlicQB6HYG2jjoQ1Y4SLwCaAg8w
jqF5Mni+HSg5NhrUOnmOQek=
=MDV8
-----END PGP SIGNATURE-----


 
< Prev   Next >
    
Partner

 

Latest Features
Peter Smith Releases Linux Network Security Online
Securing a Linux Web Server
Password guessing with Medusa 2.0
Password guessing as an attack vector
Squid and Digest Authentication
Squid and Basic Authentication
Demystifying the Chinese Hacking Industry: Earning 6 Million a Night
Free Online security course (LearnSIA) - A Call for Help
What You Need to Know About Linux Rootkits
Review: A Practical Guide to Fedora and Red Hat Enterprise Linux - Fifth Edition
Yesterday's Edition
Mobile Device Encryption Could Lead to a ‘Very, Very Dark Place’, FBI Director Says
What a hacker can learn about your life from the coffee shop’s Wi-Fi network
Partner Sponsor

Community | HOWTOs | Blogs | Features | Book Reviews | Networking
 Security Projects |  Latest News |  Newsletters |  SELinux |  Privacy |  Home
 Hardening |   About Us |   Advertise |   Legal Notice |   RSS |   Guardian Digital
(c)Copyright 2014 Guardian Digital, Inc. All rights reserved.