LinuxSecurity.com
Share your story
The central voice for Linux and Open Source security news
Home News Topics Advisories HOWTOs Features Newsletters About Register

Welcome!
Sign up!
EnGarde Community
Login
Polls
What is the most important Linux security technology?
 
Advisories
Community
Linux Events
Linux User Groups
Link to Us
Security Center
Book Reviews
Security Dictionary
Security Tips
SELinux
White Papers
Featured Blogs
All About Linux
DanWalsh LiveJournal
Securitydistro
Latest Newsletters
Linux Advisory Watch: October 24th, 2014
Linux Security Week: October 20th, 2014
Subscribe
LinuxSecurity Newsletters
E-mail:
Choose Lists:
About our Newsletters
RSS Feeds
Get the LinuxSecurity news you want faster with RSS
Powered By

  
NetBSD: openssl multiple vulnerabilities Print E-mail
User Rating:      How can I rate this item?
Posted by LinuxSecurity.com Team   
NetBSD OpenSSL had multiple vulnerabilities, they were found by tests performedby NISCC (www.niscc.gov.uk).

		 NetBSD Security Advisory 2003-017
		 =================================

Topic:		OpenSSL multiple vulnerabilities

Version:	NetBSD-current:	sources prior to October 3, 2003
		NetBSD 1.6.1:	affected
		NetBSD 1.6:	affected
		NetBSD-1.5.3:	affected
		NetBSD-1.5.2:	affected
		NetBSD-1.5.1:	affected
		NetBSD-1.5:	affected
		pkgsrc:		packages prior to openssl-0.9.6k/0.9.7c

Severity:	possible remote code injection

Fixed:		NetBSD-current:		October 3, 2003
		NetBSD-1.6 branch:	October 3, 2003 (1.6.2 will include the fix)
		NetBSD-1.5 branch:	October 4, 2003
		pkgsrc:		openssl-0.9.6k/0.9.7c corrects the issue


Abstract
========

OpenSSL had multiple vulnerabilities, they were found by tests performed
by NISCC (www.niscc.gov.uk).

- - ASN.1 decoder could overrun its stack if a malicious X.509 certificate
is received

- - malfomed X.509 certificates could cause crashes under certain
circumstances

The vulnerability can be attacked remotely, even if SSL client
authentication is not enabled.

Note that OpenSSH is not affected by this issue, as it does not use the
OpenSSL ASN.1 decoder.


Technical Details
=================
 
http://www.securityfocus.com/archive/1/339623/2003-09-27/2003-10-03/0 
http://www.uniras.gov.uk/vuls/2003/006489/openssl.htm
 
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2003-0545 
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2003-0543 
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2003-0544


Solutions and Workarounds
=========================

A rebuild of libcrypto and libssl is necessary.  If you have installed
any program that statically links one of those libraries, it must be
rebuilt too.

If you have daemons that use those libraries, any running instances must
be restarted.  A reboot after replacing libcrypto/libssl is recommended.

The following instructions describe how to upgrade your libcrypto/libssl
binaries by updating your source tree and rebuilding and
installing a new version of libcrypto/libssl.

* NetBSD-current:

	Systems running NetBSD-current dated from before 2003-10-02
	should be upgraded to NetBSD-current dated 2003-10-03 or later.

	The following directories need to be updated from the
	netbsd-current CVS branch (aka HEAD):
		crypto/dist/openssl

	To update from CVS, re-build, and re-install libcrypto and libssl:

		# cd src
		# cvs update -d -P crypto/dist/openssl

		# cd lib/libcrypto
		# make USETOOLS=no cleandir dependall
		# make USETOOLS=no install

		# cd ../../lib/libssl
		# make USETOOLS=no cleandir dependall
		# make USETOOLS=no install

* NetBSD 1.6, 1.6.1:

	The binary distribution of NetBSD 1.6 and 1.6.1 are vulnerable.

	Systems running NetBSD 1.6 sources dated from before
	2003-10-02 should be upgraded from NetBSD 1.6 sources dated
	2003-10-03 or later.

	NetBSD 1.6.2 will include the fix.

	The following directories need to be updated from the
	netbsd-1-6 CVS branch:
		crypto/dist/openssl

	To update from CVS, re-build, and re-install libcrypto and libssl:

		# cd src
		# cvs update -d -P -r netbsd-1-6 crypto/dist/openssl

		# cd lib/libcrypto
		# make USETOOLS=no cleandir dependall
		# make USETOOLS=no install

		# cd ../../lib/libssl
		# make USETOOLS=no cleandir dependall
		# make USETOOLS=no install


* NetBSD 1.5, 1.5.1, 1.5.2, 1.5.3:

	The binary distribution of NetBSD 1.5 to 1.5.3 are vulnerable.   

	Systems running NetBSD 1.5, 1.5.1, 1.5.2, or 1.5.3 sources dated
	from before 2003-10-03 should be upgraded from NetBSD 1.5.*
	sources dated 2003-10-04 or later.

	The following directories need to be updated from the
	netbsd-1-5 CVS branch:
		crypto/dist/openssl

	To update from CVS, re-build, and re-install libcrypto and libssl:

		# cd src
		# cvs update -d -P -r netbsd-1-5 crypto/dist/openssl

		# cd lib/libcrypto
		# make cleandir dependall
		# make install

		# cd ../../lib/libssl
		# make cleandir dependall
		# make install


Thanks To
=========

Matthias Scheler


Revision History
================

	2003-10-09	Initial release


More Information
================

Advisories may be updated as new information becomes available.
The most recent version of this advisory (PGP signed) can be found at 
   ftp://ftp.NetBSD.org/pub/NetBSD/security/advisories/NetBSD-SA2003-017.txt.asc

Information about NetBSD and NetBSD security can be found at 
http://www.NetBSD.org/ and  http://www.NetBSD.org/Security/.


Copyright 2003, The NetBSD Foundation, Inc.  All Rights Reserved.
Redistribution permitted only in full, unmodified form.

$NetBSD: NetBSD-SA2003-017.txt,v 1.4 2003/10/09 19:29:53 david Exp $



 
< Prev   Next >
    
Partner

 

Latest Features
Peter Smith Releases Linux Network Security Online
Securing a Linux Web Server
Password guessing with Medusa 2.0
Password guessing as an attack vector
Squid and Digest Authentication
Squid and Basic Authentication
Demystifying the Chinese Hacking Industry: Earning 6 Million a Night
Free Online security course (LearnSIA) - A Call for Help
What You Need to Know About Linux Rootkits
Review: A Practical Guide to Fedora and Red Hat Enterprise Linux - Fifth Edition
Yesterday's Edition
Pro-Privacy Senator Wyden on Fighting the NSA From Inside the System
NIST to hypervisor admins: secure your systems
Quick PHP patch beats slow research reveal
Partner Sponsor

Community | HOWTOs | Blogs | Features | Book Reviews | Networking
 Security Projects |  Latest News |  Newsletters |  SELinux |  Privacy |  Home
 Hardening |   About Us |   Advertise |   Legal Notice |   RSS |   Guardian Digital
(c)Copyright 2014 Guardian Digital, Inc. All rights reserved.