Share your story
The central voice for Linux and Open Source security news
Home News Topics Advisories HOWTOs Features Newsletters About Register

Sign up!
EnGarde Community
What is the most important Linux security technology?
Linux Events
Linux User Groups
Link to Us
Security Center
Book Reviews
Security Dictionary
Security Tips
White Papers
Featured Blogs
All About Linux
DanWalsh LiveJournal
Latest Newsletters
Linux Security Week: March 30th, 2015
Linux Advisory Watch: March 27th, 2015
LinuxSecurity Newsletters
Choose Lists:
About our Newsletters
RSS Feeds
Get the LinuxSecurity news you want faster with RSS
Powered By

Gentoo: apache 2.x denial of service vulnerability Print E-mail
User Rating:      How can I rate this item?
Posted by Team   
Gentoo Apache 2.0 versions 2.0.37 through 2.0.45 can be caused to crash in certain circumstances.

- - - ---------------------------------------------------------------------
- - - ---------------------------------------------------------------------

          PACKAGE : apache-2.x
          SUMMARY : denial of service
             DATE : 2003-06-01 12:01 UTC
          EXPLOIT : remote
VERSIONS AFFECTED : =apache-2.0.46
              CVE : CAN-2003-0245 CAN-2003-0189 

- - - ---------------------------------------------------------------------

- From announcement:

"Apache 2.0 versions 2.0.37 through 2.0.45 can be caused to crash in 
certain circumstances.  This can be triggered remotely through mod_dav 
and possibly other mechanisms.  The crash was originally reported by 
David Endler <> and was researched and fixed by 
Joe Orton <jorton@Red>.  Specific details and an analysis of the 
crash will be published Friday, May 30.  No more specific information 
is disclosed at this time, but all Apache 2.0 users are encouraged to 
upgrade now."
"Apache 2.0 versions 2.0.40 through 2.0.45 on Unix platforms were 
vulnerable to a denial-of-service attack on the basic authentication 
module, which was reported by John Hughes <>. 
A bug in the configuration scripts caused the apr_password_validate() 
function to be thread-unsafe on platforms with crypt_r(), including 
AIX and Linux.  All versions of Apache 2.0 have this thread-safety 
problem on platforms with no crypt_r() and no thread-safe crypt(), 
such as Mac OS X and possibly others.  When using a threaded MPM (which 
is not the default on these platforms), this allows remote attackers 
to create a denial of service which causes valid usernames and 
passwords for Basic Authentication to fail until Apache is restarted. 
We do not believe this bug could allow unauthorized users to gain 
access to protected resources."

Read the full advisories at:


It is recommended that all Gentoo Linux users who are running
net-www/apache-2.x upgrade to apache-2.0.46 as follows

emerge sync
emerge apache
emerge clean

- - - --------------------------------------------------------------------- - GnuPG key is available at
- - - ---------------------------------------------------------------------

< Prev   Next >


Latest Features
Peter Smith Releases Linux Network Security Online
Securing a Linux Web Server
Password guessing with Medusa 2.0
Password guessing as an attack vector
Squid and Digest Authentication
Squid and Basic Authentication
Demystifying the Chinese Hacking Industry: Earning 6 Million a Night
Free Online security course (LearnSIA) - A Call for Help
What You Need to Know About Linux Rootkits
Review: A Practical Guide to Fedora and Red Hat Enterprise Linux - Fifth Edition
Yesterday's Edition
Partner Sponsor

Community | HOWTOs | Blogs | Features | Book Reviews | Networking
 Security Projects |  Latest News |  Newsletters |  SELinux |  Privacy |  Home
 Hardening |   About Us |   Advertise |   Legal Notice |   RSS |   Guardian Digital
(c)Copyright 2015 Guardian Digital, Inc. All rights reserved.