LinuxSecurity.com
Share your story
The central voice for Linux and Open Source security news
Home News Topics Advisories HOWTOs Features Newsletters About Register

Welcome!
Sign up!
EnGarde Community
Login
Polls
What is the most important Linux security technology?
 
Advisories
Community
Linux Events
Linux User Groups
Link to Us
Security Center
Book Reviews
Security Dictionary
Security Tips
SELinux
White Papers
Featured Blogs
All About Linux
DanWalsh LiveJournal
Securitydistro
Latest Newsletters
Linux Advisory Watch: December 19th, 2014
Linux Advisory Watch: December 12th, 2014
Subscribe
LinuxSecurity Newsletters
E-mail:
Choose Lists:
About our Newsletters
RSS Feeds
Get the LinuxSecurity news you want faster with RSS
Powered By

  
Gentoo: cyrus-imapd multiple buffer overflows Print E-mail
User Rating:      How can I rate this item?
Posted by LinuxSecurity.com Team   
Gentoo Multiple buffer overflow vulnerabilities have been discovered in cyrus-imapd.

- --------------------------------------------------------------------
GENTOO LINUX SECURITY ANNOUNCEMENT 200212-11
- --------------------------------------------------------------------

PACKAGE : cyrus-imapd
SUMMARY : buffer overflows
DATE    : 2002-12-27 23:12 UTC
EXPLOIT : remote

- --------------------------------------------------------------------

From first advisory:

"Cyrus' Sieve implementation contains a couple of classic string based
buffer overflows in script parsing code. Anyone who can execute Sieve
scripts can exploit these bugs. Versions up to libSieve 2.1.2 and
Cyrus IMAP 2.1.10 are affected."

From second advisory:

"Cyrus IMAP server has a a remotely exploitable pre-login buffer
overflow. I checked versions 1.4 (oldest in web page) and 2.1.10 which
both had it, so apparently all versions are affected."

Read the full advisories at 
http://marc.theaimsgroup.com/?l=bugtraq&m=103886433123554&w=2 
http://marc.theaimsgroup.com/?l=bugtraq&m=103886607825605&w=2

SOLUTION

It is recommended that all Gentoo Linux users who are running
net-mail/cyrus-imapd-2.1.9-r1 update their systems as follows:

emerge rsync
emerge cyrus-imapd
emerge clean

If you have cyrus-imap-dev-2.1.9-r1 and/or cyrus-imap-admin-2.1.9
installed you need to update those aswell:

emerge cyrus-imap-dev
and/or
emerge cyrus-imap-admin

- --------------------------------------------------------------------
aliz@gentoo.org - GnuPG key is available at www.gentoo.org/~aliz
raker@gentoo.org
- --------------------------------------------------------------------


 
< Prev   Next >
    
Partner

 

Latest Features
Peter Smith Releases Linux Network Security Online
Securing a Linux Web Server
Password guessing with Medusa 2.0
Password guessing as an attack vector
Squid and Digest Authentication
Squid and Basic Authentication
Demystifying the Chinese Hacking Industry: Earning 6 Million a Night
Free Online security course (LearnSIA) - A Call for Help
What You Need to Know About Linux Rootkits
Review: A Practical Guide to Fedora and Red Hat Enterprise Linux - Fifth Edition
Yesterday's Edition
Report: U.S. planning “proportional response” to Sony hack, blamed on North Korea
Heartbleed, Shellshock, Tor and more: The 13 biggest security stories of 2014
Partner Sponsor

Community | HOWTOs | Blogs | Features | Book Reviews | Networking
 Security Projects |  Latest News |  Newsletters |  SELinux |  Privacy |  Home
 Hardening |   About Us |   Advertise |   Legal Notice |   RSS |   Guardian Digital
(c)Copyright 2014 Guardian Digital, Inc. All rights reserved.