LinuxSecurity.com
Share your story
The central voice for Linux and Open Source security news
Home News Topics Advisories HOWTOs Features Newsletters About Register

Welcome!
Sign up!
EnGarde Community
Login
Polls
What is the most important Linux security technology?
 
Advisories
Community
Linux Events
Linux User Groups
Link to Us
Security Center
Book Reviews
Security Dictionary
Security Tips
SELinux
White Papers
Featured Blogs
All About Linux
DanWalsh LiveJournal
Securitydistro
Latest Newsletters
Linux Security Week: August 25th, 2014
Linux Advisory Watch: August 15th, 2014
Subscribe
LinuxSecurity Newsletters
E-mail:
Choose Lists:
About our Newsletters
RSS Feeds
Get the LinuxSecurity news you want faster with RSS
Powered By

  
RedHat: PostScript and PDF vulnerability Print E-mail
User Rating:      How can I rate this item?
Posted by LinuxSecurity.com Team   
RedHat Linux A local buffer overflow was found in gv version 3.5.8 and earlier. ggv versions 1.0.2 and earlier contain code derived from gv and therefore have the same vulnerability. An attacker can create a carefully crafted malformed PDF or PostScript file in such a way that when that file is viewed arbitrary commands can be executed.

---------------------------------------------------------------------
                   Red Hat, Inc. Red Hat Security Advisory

Synopsis:          Updated packages fix PostScript and PDF security issue
Advisory ID:       RHSA-2002:212-06
Issue date:        2002-09-25
Updated on:        2002-09-30
Product:           Red Hat Powertools
Keywords:          pdf adobe postscript exploit
Cross references:  
Obsoletes:         
CVE Names:         CAN-2002-0838
---------------------------------------------------------------------

1. Topic:

Updated packages for ggv fix a local buffer overflow
when reading malformed PDF or PostScript files.

2. Relevant releases/architectures:

Red Hat Powertools 7.0 - alpha, i386
Red Hat Powertools 7.1 - alpha, i386

3. Problem description:

ggv is a user interface for the Ghostscript PostScript(R) interpreter used
to display PostScript and PDF documents on an X Window System.

Zen Parse found a local buffer overflow in gv version 3.5.8 and earlier. 
ggv versions 1.0.2 and earlier contain code derived from gv and therefore
have the same vulnerability. An attacker can create a carefully crafted
malformed PDF or PostScript file in such a way that when that file is
viewed arbitrary commands can be executed.

All users of ggv are advised to upgrade to the errata packages which
contain a patch and are not vulnerable to this issue.

4. Solution:

Before applying this update, make sure all previously released errata
relevant to your system have been applied.


To update all RPMs for your particular architecture, run:

rpm -Fvh [filenames]

where [filenames] is a list of the RPMs you wish to upgrade.  Only those
RPMs which are currently installed will be updated.  Those RPMs which are
not installed but included in the list will not be updated.  Note that you
can also use wildcards (*.rpm) if your current directory *only* contains the
desired RPMs.

Please note that this update is also available via Red Hat Network.  Many
people find this an easier way to apply updates.  To use Red Hat Network,
launch the Red Hat Update Agent with the following command:

up2date

This will start an interactive process that will result in the appropriate
RPMs being upgraded on your system.

5. RPMs required:

Red Hat Powertools 7.0:

SRPMS: 
ftp://updates.Red Hat.com/7.0/en/powertools/SRPMS/ggv-1.0.2-5.1.src.rpm

alpha: 
ftp://updates.Red Hat.com/7.0/en/powertools/alpha/ggv-1.0.2-5.1.alpha.rpm

i386: 
ftp://updates.Red Hat.com/7.0/en/powertools/i386/ggv-1.0.2-5.1.i386.rpm

Red Hat Powertools 7.1:

SRPMS: 
ftp://updates.Red Hat.com/7.1/en/powertools/SRPMS/ggv-1.0.2-5.1.src.rpm

alpha: 
ftp://updates.Red Hat.com/7.1/en/powertools/alpha/ggv-1.0.2-5.1.alpha.rpm

i386: 
ftp://updates.Red Hat.com/7.1/en/powertools/i386/ggv-1.0.2-5.1.i386.rpm


6. Verification:

MD5 sum                          Package Name
--------------------------------------------------------------------------
c0915e40e1d512174f9c2f024399e866 7.0/en/powertools/SRPMS/ggv-1.0.2-5.1.src.rpm
2f105b4be32d361cb5477d04f2a2fbba 7.0/en/powertools/alpha/ggv-1.0.2-5.1.alpha.rpm
afd4eab8f18ca4f03ead7c4025f99ab1 7.0/en/powertools/i386/ggv-1.0.2-5.1.i386.rpm
c0915e40e1d512174f9c2f024399e866 7.1/en/powertools/SRPMS/ggv-1.0.2-5.1.src.rpm
2f105b4be32d361cb5477d04f2a2fbba 7.1/en/powertools/alpha/ggv-1.0.2-5.1.alpha.rpm
afd4eab8f18ca4f03ead7c4025f99ab1 7.1/en/powertools/i386/ggv-1.0.2-5.1.i386.rpm


These packages are GPG signed by Red Hat, Inc. for security.  Our key
is available at:
     http://www.Red Hat.com/about/contact/pgpkey.html

You can verify each package with the following command:
    rpm --checksig  

If you only wish to verify that each package has not been corrupted or
tampered with, examine only the md5sum with the following command:
    rpm --checksig --nogpg 


7. References:
 
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2002-0838


Copyright(c) 2000, 2001, 2002 Red Hat, Inc.


 
< Prev   Next >
    
Partner

 

Latest Features
Peter Smith Releases Linux Network Security Online
Securing a Linux Web Server
Password guessing with Medusa 2.0
Password guessing as an attack vector
Squid and Digest Authentication
Squid and Basic Authentication
Demystifying the Chinese Hacking Industry: Earning 6 Million a Night
Free Online security course (LearnSIA) - A Call for Help
What You Need to Know About Linux Rootkits
Review: A Practical Guide to Fedora and Red Hat Enterprise Linux - Fifth Edition
Yesterday's Edition
Partner Sponsor

Community | HOWTOs | Blogs | Features | Book Reviews | Networking
 Security Projects |  Latest News |  Newsletters |  SELinux |  Privacy |  Home
 Hardening |   About Us |   Advertise |   Legal Notice |   RSS |   Guardian Digital
(c)Copyright 2014 Guardian Digital, Inc. All rights reserved.